[SOLVED] LM12 LXDE: Problem with Thunderbird autostart

Forums for the LXDE Edition
Forum rules
Before you post please read this

[SOLVED] LM12 LXDE: Problem with Thunderbird autostart

Postby etisdale on Wed Apr 18, 2012 3:19 pm

I've been successful autostarting a number of different programs under LM12 LXDE with one important exception: Thunderbird.

This is the method that I use:

1) Copy the .desktop file of the program to autostart from /usr/share/applications into /home/[user]/.config/autostart

2) Menu > Preferences > Desktop Session Settings to enable/disable the program under Automatically Started Applications

3) Restart

Unfortunately, Thunderbird does not work for me using the above method. Anybody know why this might be?

I suppose I could try another method to autostart Thunderbird, but would appreciate any ideas.

Thanks!

[Edited to mark as solved.]
Last edited by etisdale on Wed Apr 18, 2012 9:59 pm, edited 1 time in total.
etisdale
Level 1
Level 1
 
Posts: 14
Joined: Wed Apr 18, 2012 2:49 pm

Linux Mint is funded by ads and donations.
 

Re: LM12 LXDE: Problem with Thunderbird autostart

Postby seppalta on Wed Apr 18, 2012 4:46 pm

Try adding it to /etc/xdg/lxsession/Mint/autostart. See http://douwil7.100webspace.net/linux/Tuning.html#16.
seppalta
Level 4
Level 4
 
Posts: 390
Joined: Wed Jun 08, 2011 12:08 pm

Re: LM12 LXDE: Problem with Thunderbird autostart

Postby etisdale on Wed Apr 18, 2012 9:02 pm

Wouldn't adding it to /etc/xdg/lxsession/Mint/autostart be a system-wide setting? I would prefer to have a user-based solution.

What in my standard thunderbird.desktop file (from /usr/share/applications) might be causing the problem? Every other .desktop file I've used has worked. Thanks!
etisdale
Level 1
Level 1
 
Posts: 14
Joined: Wed Apr 18, 2012 2:49 pm

Re: LM12 LXDE: Problem with Thunderbird autostart

Postby etisdale on Wed Apr 18, 2012 9:58 pm

Solution:

I simply removed "%u" from my thunderbird.desktop file (which was copied into /home/[user]/.config/autostart from /usr/share/applications).

Specifically, I changed the line

Exec=thunderbird %u

to the line

Exec=thunderbird

by removing the trailing "%u".

Apparently, "%u" is a field code for a single URL (which URL, I don't know!):

http://standards.freedesktop.org/deskto ... 01s06.html
etisdale
Level 1
Level 1
 
Posts: 14
Joined: Wed Apr 18, 2012 2:49 pm


Return to LXDE

Who is online

Users browsing this forum: No registered users and 3 guests