processor underclocks itself after installing bea/bianca

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

processor underclocks itself after installing bea/bianca

Postby timmyflight on Sat Feb 10, 2007 5:23 pm

Got a really weird problem with my emachines computer. i've got winxp
installed on my primary hd, and mint installed on my second hd.
My processor is a amd sempron 3100+ 1.8 ghz. After installing mint,when i boot up winxp, it shows the processor clock speed at only 1.0 ghz.
The clock speed in bios cannot be adjusted manually in emachines computers (don't know why). The only way to reset the clock speed is to do
a complete format and reinstall of the emachines/winxp system with the recovery cd. And when I reinstall mint, it promptly takes it back to 1.0 ghz again :x What to do????????????????? Thanks for any input!

OK, I found that if I turn the computer off and then turn it back on and boot
into windows directly, it will keep the clock speed at 1.8 ghz. But if I'm in Mint
and restart, then boot into windows, it goes back to 1.0 ghz. :x grrrr!!
Image

Believe on the Lord Jesus Christ, and you will be saved, and your house
Acts 16:31
User avatar
timmyflight
Level 2
Level 2
 
Posts: 87
Joined: Tue Dec 12, 2006 11:42 pm
Location: PA, USA

Linux Mint is funded by ads and donations.
 

processor underclocks itself after installing bea/bianca

Postby nick on Sun Feb 11, 2007 5:42 am

Hi Timmy
The clock speed of my AMD 3.8 sits at a reading
of 1.2Ghz in Linux when I am just surfing, but if I
start editing Videos or Burnining CDs it goes to the correct speed, it is controlled by POWER NOW, (Cool and Quiet) i.e. the speed is supplied when required.
http://www.amd.com/us-en/Processors/Pro ... 0220_10221^964,00.htm
You will have to cut and paste link as the ^ seems to cause problems!
Looks like your Bios may possibly be staying at the previously used setting in Linux.
Do not know anything about windows but is there a "power now or cool and quite" option to
install in windows?
Or, there is a way to turn off Power Now Linux and then the processor may reboot at the correct speed in windows, or may be it still needs power now installed windows
Will try to find how to disable Power Now In Linux.
Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

processor underclocks itself after installing bea/bianca

Postby nick on Sun Feb 11, 2007 7:41 am

Hi Timmy
To see if your processor supports frequency scaling try
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
on my Sempron 3.4 box I get:
2000000 1800000 1000000 which means
that the above frequencies (in Hz) are supported by my CPU, and…
$cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
gives:
userspace powersave ondemand conservative performance
http://ubuntu.wordpress.com/2005/11/04/ ... y-scaling/
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

processor underclocks itself after installing bea/bianca

Postby nick on Sun Feb 11, 2007 11:03 am

Hi Timmy again
If I type "powernow=off" in linux processor goes to full speed
And maybe if you download the file:
PowerNow! Dashboard Installation files.zip
on the page
http://www.amd.com/us-en/Processors/Pro ... 0220_10221^964,00.html
You maybe able to set the speed in XP, cannot test as I do not have Widows
Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby timmyflight on Mon Feb 12, 2007 1:06 am

hi Nick, I ran the command for available frequencies, it will handle the 1.0
and the 1.8 frequencies. The powernow=off command didn't work, it comes back with command not found. I'll try to get the cpu scaling program and see how that does... :)

(Edit) I downloaded and installed a program called cpudyn fron synaptic,
which incidentally uninstalled a file called powernowd, I think it fixed the problem (fingers crossed). So far the speed stays at 1.8 ghz. now, when I
cold boot or restart into xp. :D :D
Image

Believe on the Lord Jesus Christ, and you will be saved, and your house
Acts 16:31
User avatar
timmyflight
Level 2
Level 2
 
Posts: 87
Joined: Tue Dec 12, 2006 11:42 pm
Location: PA, USA

Postby happyponcho42 on Thu Feb 15, 2007 11:13 am

For future reference, if you encounter any issues with underclocking due to your processor's battery saving feature, simply type this in the terminal:
Code: Select all
sudo apt-get remove powernowd


There's no need to installing any other unnecessary apps just to remove it when you can simply remove it itself. A forewarning is that following the removal of powernowd, you should not expect your battery to last up to it's full potential; when your battery life was ranked, it was most likely dependent on your processors ability to downclock when the extra clock speed was not necessary, which in turns lowers power usage and thus prolongs battery life in between charges.
happyponcho42
Level 1
Level 1
 
Posts: 1
Joined: Fri Jan 05, 2007 7:15 pm

Postby timmyflight on Thu Feb 15, 2007 11:56 pm

My computer is actually a desktop unit, not a laptop... :)
I wonder why the powernowd file would install in this case? :roll:
Image

Believe on the Lord Jesus Christ, and you will be saved, and your house
Acts 16:31
User avatar
timmyflight
Level 2
Level 2
 
Posts: 87
Joined: Tue Dec 12, 2006 11:42 pm
Location: PA, USA

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: gintrnis and 3 guests