Mint12 with Python3: Cairo

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Mint12 with Python3: Cairo

Postby smikesmith on Fri Jun 15, 2012 12:55 am

Does anyone know how to configure Python 3 to work with Cairo on Mint 12? I've installed everything I can find (applicable) from repo, and Python 3 works, itself, but any Cairo drawing simply doesn't happen. No error roports of any kind, just nothing there. The installation seems to be missing a part of the introspection, perhaps, but I'm no expert on this and can't seem to figure out how to get it working.

The same script or scripts DO work with Python 2 on Mint, and they WILL work with Python 3 in Ubuntu 12.04, so it isn't a script problem. The versions of Python 3 are, of course, different between Mint12 and Ubuntu12.

mike
smikesmith
Level 1
Level 1
 
Posts: 3
Joined: Fri Jun 15, 2012 12:41 am

Linux Mint is funded by ads and donations.
 

Re: Mint12 with Python3: Cairo

Postby smikesmith on Fri Jun 15, 2012 10:45 am

I think I've determined that what's missing is "python3-gi-cairo". This is in the Precise repository, but not the Oneiric repository. Any clues on how to get it?
smikesmith
Level 1
Level 1
 
Posts: 3
Joined: Fri Jun 15, 2012 12:41 am

Re: Mint12 with Python3: Cairo

Postby smikesmith on Fri Jun 15, 2012 11:26 am

Actually, I fixed the problem, but with a bit of a dangerous hack: I copied "_gi_cpython-32mu.so" and "pygtkcompat.py" from the Ubuntu 12.04 installation to the Mint ".../ python3/dist-packages/gi" folder.

Now it works!

But I'd like to find the proper way to achieve this...
smikesmith
Level 1
Level 1
 
Posts: 3
Joined: Fri Jun 15, 2012 12:41 am


Return to Other topics

Who is online

Users browsing this forum: Exabot [Bot] and 5 guests