updated and it broke

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

updated and it broke

Postby alan2273 on Mon Feb 12, 2007 5:55 am

I have been away for a few days and when i switched on it said there were 78 updates so i updated and it told me to reboot, but unfortunately i clicked switch off.
When i switched on it could not find a screen to load.
It seemed it had updated the kernel from 10 to 11.
at the prompt i typed startx and it said no GUI found that could be loaded, so i rebooted and selected number10 to load and it is OK.
Why has update 11 broken the Nvidia configuration and how do i put it right?.
User avatar
alan2273
Level 2
Level 2
 
Posts: 80
Joined: Wed Jan 03, 2007 2:36 pm
Location: England

Linux Mint is funded by ads and donations.
 

Postby clem on Mon Feb 12, 2007 8:51 am

You probably need to run envy again.

Clem
User avatar
clem
Level 15
Level 15
 
Posts: 5545
Joined: Wed Nov 15, 2006 8:34 am

Postby alan2273 on Mon Feb 12, 2007 9:05 am

Thanks Clem that did the trick, I must put my brain in gear in future, I had tried all sorts but never thought of reinstalling the Nvidia driver. :oops:
User avatar
alan2273
Level 2
Level 2
 
Posts: 80
Joined: Wed Jan 03, 2007 2:36 pm
Location: England

Re: updated and it broke

Postby scorp123 on Mon Feb 12, 2007 12:58 pm

alan2273 wrote:Why has update 11 broken the Nvidia configuration and how do i put it right?.
Happens every time you update the kernel or the X.org drivers. That's because Nvidia's drivers rely upon a module (a kernel driver) which is closed source and therefore needs to recompiled every time you change certain parts in your system (the kernel developpers cannot update that part as this Nvidia stuff is closed source and regarded as a "trade secret" by Nvidia Corp.). It's a bit of a nuisance, I agree. But as you now know how to get around it if it happens, it shouldn't be a big problem, right? :wink:
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby alan2273 on Mon Feb 12, 2007 4:00 pm

scorp123, thanks for that explanation, as you say I will know for the future. :D
User avatar
alan2273
Level 2
Level 2
 
Posts: 80
Joined: Wed Jan 03, 2007 2:36 pm
Location: England

Postby trsnrtr on Mon Feb 12, 2007 7:11 pm

In my case, running envy didn't work on either of my two machines, however, it's a simple task to download the install file from Nvidia and run it.

The problem that I had with envy, was that I kept getting a checksum failure on the new driver download and envy would halt.

Dennis
User avatar
trsnrtr
Level 1
Level 1
 
Posts: 46
Joined: Thu Jan 11, 2007 8:11 pm


Return to Other topics

Who is online

Users browsing this forum: Bing [Bot] and 3 guests