Noop Scheduler Issue......

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Noop Scheduler Issue......

Postby xillius200 on Fri Sep 07, 2012 10:25 am

I have an issue that is in Linux Mint and Ubuntu....whenever I try to use noop scheduler the system gradually begins to get slower and slower then over time becomes so slow it actually freezes. However with deadline or CFQ I do not get this problem. I was wondering if anyone else has ever had this problem and if anyone knows a way to fix it??

PS: Reason I want to get it fixed is because using noop before it begins to get slow it is faster than the other schedulers. I like to get the most out of my SSD lol

Specs:
Laptop - Dell Studio 1558
Processor - i7 720qm
Ram: 2x 4gb 1600mhz
Graphics: Mobility Radeon HD 5470
Wireless Network Card - Intel b/g
Storage: 60GB Mushkin Chronos SSD
Audio - Realtek
Ethernet - Realtek
SD card reader - Ricoh
xillius200
Level 1
Level 1
 
Posts: 5
Joined: Wed May 09, 2012 4:10 am

Linux Mint is funded by ads and donations.
 

Re: Noop Scheduler Issue......

Postby Therion87 on Fri Sep 07, 2012 11:38 am

Did you add the options to the fstab for noatime and discard? Those enable trim in Linux. Also, did you check for possible firmware updates for your SSD? NOOP basically just lets the SSD handle the IO by itself with it's firmware so make sure it's up to date. How are you enabling NOOP? With the rc.local file? Or if it being compiled in the kernel?

EDIT:

Newest Firmware for Mushkin Chornos SSD
Processor: i7-2860QM
Memory: 16 GB DDR3 @ 1600MHz
Graphics: Nvidia 560M 1.5GB - 313.18
Operating System: Linux Mint 13 Maya
HDD: 120 GB SSD & 500 GB HDD
Kernel: 3.9
User avatar
Therion87
Level 2
Level 2
 
Posts: 63
Joined: Thu Apr 07, 2011 4:07 pm
Location: Youngstown, OH

Re: Noop Scheduler Issue......

Postby xillius200 on Fri Sep 07, 2012 12:21 pm

Therion87 wrote:Did you add the options to the fstab for noatime and discard? Those enable trim in Linux. Also, did you check for possible firmware updates for your SSD? NOOP basically just lets the SSD handle the IO by itself with it's firmware so make sure it's up to date. How are you enabling NOOP? With the rc.local file? Or if it being compiled in the kernel?

EDIT:

Newest Firmware for Mushkin Chornos SSD


I have got the fstab stuff added etc. and for enabling noop I have used elevator=noop in grub, the rc.local file and tried the echo noop > /etc/..... but all with the same ending :/ However I have not updated the SSD since I bought it lol maybe an update is available and will do good as you said lol ill try and post back ^^

PS: Seems I have lasted firmware already installed.
Last edited by xillius200 on Fri Sep 07, 2012 12:45 pm, edited 1 time in total.
xillius200
Level 1
Level 1
 
Posts: 5
Joined: Wed May 09, 2012 4:10 am

Re: Noop Scheduler Issue......

Postby Therion87 on Fri Sep 07, 2012 12:27 pm

xillius200 wrote:
Therion87 wrote:Did you add the options to the fstab for noatime and discard? Those enable trim in Linux. Also, did you check for possible firmware updates for your SSD? NOOP basically just lets the SSD handle the IO by itself with it's firmware so make sure it's up to date. How are you enabling NOOP? With the rc.local file? Or if it being compiled in the kernel?

EDIT:

Newest Firmware for Mushkin Chornos SSD


I have got the fstab stuff added etc. and for enabling noop I have used elevator=noop in grub, the rc.local file and tried the echo noop > /etc/..... but all with the same ending :/ However I have not updated the SSD since I bought it lol maybe an update is available and will do good as you said lol ill try and post back ^^


Ok good deal. Let us know and we'll go from there.
Processor: i7-2860QM
Memory: 16 GB DDR3 @ 1600MHz
Graphics: Nvidia 560M 1.5GB - 313.18
Operating System: Linux Mint 13 Maya
HDD: 120 GB SSD & 500 GB HDD
Kernel: 3.9
User avatar
Therion87
Level 2
Level 2
 
Posts: 63
Joined: Thu Apr 07, 2011 4:07 pm
Location: Youngstown, OH

Re: Noop Scheduler Issue......

Postby xillius200 on Fri Sep 07, 2012 12:45 pm

Therion87 wrote:
xillius200 wrote:
Therion87 wrote:Did you add the options to the fstab for noatime and discard? Those enable trim in Linux. Also, did you check for possible firmware updates for your SSD? NOOP basically just lets the SSD handle the IO by itself with it's firmware so make sure it's up to date. How are you enabling NOOP? With the rc.local file? Or if it being compiled in the kernel?

EDIT:

Newest Firmware for Mushkin Chornos SSD


I have got the fstab stuff added etc. and for enabling noop I have used elevator=noop in grub, the rc.local file and tried the echo noop > /etc/..... but all with the same ending :/ However I have not updated the SSD since I bought it lol maybe an update is available and will do good as you said lol ill try and post back ^^


Ok good deal. Let us know and we'll go from there.


well I had a look seems my firmware was already the latest available...
xillius200
Level 1
Level 1
 
Posts: 5
Joined: Wed May 09, 2012 4:10 am

Re: Noop Scheduler Issue......

Postby Therion87 on Fri Sep 07, 2012 12:49 pm

How old is the drive? How full is it? If it's not old or full, maybe the firmware on the drive just sucks and doesn't handle IO well. In which case I would use deadline instead of noop.
Processor: i7-2860QM
Memory: 16 GB DDR3 @ 1600MHz
Graphics: Nvidia 560M 1.5GB - 313.18
Operating System: Linux Mint 13 Maya
HDD: 120 GB SSD & 500 GB HDD
Kernel: 3.9
User avatar
Therion87
Level 2
Level 2
 
Posts: 63
Joined: Thu Apr 07, 2011 4:07 pm
Location: Youngstown, OH

Re: Noop Scheduler Issue......

Postby xillius200 on Fri Sep 07, 2012 12:52 pm

Therion87 wrote:How old is the drive? How full is it? If it's not old or full, maybe the firmware on the drive just sucks and doesn't handle IO well. In which case I would use deadline instead of noop.


yeah drives not too old lol and it's just been reformatted with a fresh linux mint 13 mate installed on it lol. K ill stick with deadline then lol thanks for trying to help ^^

PS: Solved now lol your thing on firmware was right xD I downloaded the large fw and reinstalled it even though it's the same and no more noop issues :D maybe it was a bad flash somewhere or something before xD
xillius200
Level 1
Level 1
 
Posts: 5
Joined: Wed May 09, 2012 4:10 am

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: No registered users and 9 guests