Need help updating - (proxy blocking)

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Need help updating - (proxy blocking)

Postby sandt1g3r on Sun Oct 07, 2012 11:13 am

Hi all

I did a fresh install of Mint Maya Cinnamon and I was greeted with a huge list of updates, which I did. However there seems to be one update that is failing on all repositories - liborbit2 . Consequently I now have broken dependencies.
Further checking reveals that this page is being blocked by my IT department (i am in a college behind a proxy). They seem to be blocking anything with the word "orbit" in the url. Hence I need some way to manually get and install this package. Could somebody please (any one should be enough) -

i) tell me how to bypass the ban ?
ii) provide me a link to the mirror where the package is named appropriately (no orbit in url)
iii) upload the .udeb file with a different name here so i may download it (its <200kb)

Thanks
Last edited by sandt1g3r on Sun Oct 07, 2012 11:32 am, edited 1 time in total.
sandt1g3r
Level 1
Level 1
 
Posts: 17
Joined: Thu May 10, 2012 5:27 am

Linux Mint is funded by ads and donations.
 

Re: Need help updating - (proxy blocking)

Postby xenopeek on Sun Oct 07, 2012 11:31 am

I've uploaded a .tar.gz archive with both the i386 (32 bit) and amd64 (64 bit) deb files: http://www.filehost.ws/65b9cymt0un1

Now let's hope file hosters aren't blocked...
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14664
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Need help updating - (proxy blocking)

Postby sandt1g3r on Sun Oct 07, 2012 11:52 am

Vincent Vermeulen wrote:I've uploaded a .tar.gz archive with both the i386 (32 bit) and amd64 (64 bit) deb files: http://www.filehost.ws/65b9cymt0un1

Now let's hope file hosters aren't blocked...



Thanks a lot, you're a lifesaver . Everything is back to normal now.

Oh BTW, most file hosts are blocked too (rapidshare,mediafire etc.) I was surprised the one you chose wasn't :)
sandt1g3r
Level 1
Level 1
 
Posts: 17
Joined: Thu May 10, 2012 5:27 am

Re: Need help updating - (proxy blocking)

Postby xenopeek on Sun Oct 07, 2012 12:01 pm

Close call then :D I don't normally use file hosters so I just searched for one where I didn't have to make an account...

You might want to drop a line to your IT department, mentioning you couldn't download liborbit2 and asking if they can adjust the proxy for that.

From Debian's page (http://packages.debian.org/squeeze/liborbit2) it makes it a little more clear what liborbit2 does:
ORBit2 is a high-performance CORBA (Common Object Request Broker Architecture) ORB (Object Request Broker). It allows programs to send requests and receive replies from other programs, regardless of the locations of the two programs. CORBA is an architecture that enables communication between program objects, regardless of the programming language they're written in or the operating system they run on.

This package contains the run-time libraries used by ORBit2-based applications.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14664
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Need help updating - (proxy blocking)

Postby sandt1g3r on Sun Oct 07, 2012 12:14 pm

Yep, will surely let the IT department know - just that they are exceptionally difficult to locate on Sundays. I am planning to send them a mail saying "Regular expressions can be deadly"
liborbit2 had inadvertently stuck up synaptic, I don't think it was direct dependency for many but a lot of half-cooked updates broke my system
sandt1g3r
Level 1
Level 1
 
Posts: 17
Joined: Thu May 10, 2012 5:27 am


Return to Other topics

Who is online

Users browsing this forum: No registered users and 7 guests