Language Does Not Exist

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Language Does Not Exist

Postby motsteve on Sat Oct 20, 2012 7:49 am

I've searched this subject and they all match mine, but there is not one single reply to any of them. The message at boot: Language en_US does not exist: Using system default. Really, someone has to know how to correct this one. Mine occurs just after I sign in and the boot up is ready to finish. I'm running Mint 13 with Mate. Come to think of it, it may not have happened until I did my first update, but I'm going from memory here and I've been know to have senior moments. :D
motsteve
Level 1
Level 1
 
Posts: 33
Joined: Sat Mar 20, 2010 12:07 pm

Linux Mint is funded by ads and donations.
 

Re: Language Does Not Exist

Postby xenopeek on Sat Oct 20, 2012 4:04 pm

What have you configured in your /etc/default/locale file?
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14838
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Language Does Not Exist

Postby HAMOS on Sun Mar 24, 2013 9:56 am

I am having the same issue, in the file is LANG="en_US.UTF-8"
HAMOS
Level 1
Level 1
 
Posts: 23
Joined: Wed Sep 08, 2010 4:24 pm

Re: Language Does Not Exist

Postby HAMOS on Wed Mar 27, 2013 12:01 pm

I wanted to post the fix to this after digging.

Step #1: Changing your locale file so that it includes both these lines. Edit your /etc/default/locale file as root (gksudo pluma /etc/default/locale). This is for English USA language.

Code: Select all
LANG="en_US.UTF-8"
LANGUAGE="en_US.UTF-8"


Then restart your computer.

Step #2: Changing the default language at the login screen. If your have automatic login, let the computer finish loading. Then log out (DO NOT switch user) and choose Language then English USA and make default. A message will pop up asking what you would like to do. Choose the selection that makes this change perminate (NOT the "Just for this session").


Login to your account.

Step #3 Open terminal and type in:

Code: Select all
sudo locale-gen --purge --no-archive


Reboot and problem solved.
Last edited by HAMOS on Fri Mar 29, 2013 10:17 pm, edited 6 times in total.
HAMOS
Level 1
Level 1
 
Posts: 23
Joined: Wed Sep 08, 2010 4:24 pm

Re: Language Does Not Exist

Postby xenopeek on Wed Mar 27, 2013 12:51 pm

Setting LANGUAGE= should not be needed, but yes you do need to set your default language at the login screen correctly. Seems to be a MATE specific issue. Thanks for sharing in detail HAMOS!
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14838
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Other topics

Who is online

Users browsing this forum: No registered users and 6 guests