System boot too slow - LM14

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

System boot too slow - LM14

Postby kimented on Fri Dec 28, 2012 8:09 am

Hello,

My laptop boot is very slow, I never had this before. When I boot with nosplash, the boot freeze one minute at this message:
Code: Select all
 * Starting CPU interrupts balancing daemon[ OK ]


OS: Linux Mint 14 Mate 32bits
CPU: Intel DualCore i686
GPU: VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Thank you for your help.

You can see my bootchart attached to this post.

My boot.log
Code: Select all
fsck de util-linux 2.20.1
fsck de util-linux 2.20.1
/dev/sda7 : propre, 218427/716672 fichiers, 1370066/2863872 blocs
/dev/sda5 : propre, 177227/5898240 fichiers, 20816069/23575379 blocs
 * Setting sensors limits       
[ OK ]
 * Starting mDNS/DNS-SD daemon[ OK ]
 * Starting bluetooth daemon[ OK ]
 * Starting network connection manager[ OK ]
 * Stopping enable remaining boot-time encrypted block devices[ OK ]
 * Stopping Mount filesystems on boot[ OK ]
 * Starting CUPS printing spooler/server[ OK ]
 * Starting Samba Auto-reload Integration[ OK ]
 * Stopping Samba Auto-reload Integration[ OK ]
 * Loading cpufreq kernel modules...       
[ OK ]
 * Stopping System V initialisation compatibility[ OK ]
 * Starting System V runlevel compatibility[ OK ]
 * Starting [ OK ]
 * Starting [ OK ]
 * Starting ACPI daemon[ OK ]
 * Starting anac(h)ronistic cron[ OK ]
 * Starting [ OK ]
 * Starting [ OK ]
 * Starting save kernel messages[ OK ]
 * Starting [ OK ]
 * Starting KVM[ OK ]
 * Starting regular background program processing daemon[ OK ]
 * Starting deferred execution scheduler[ OK ]
 * Starting automatic crash report generation[ OK ]
 * CPU0...         * Stopping anac(h)ronistic cron[ OK ]
 * Stopping save kernel messages[ OK ]
 * CPU1...         * CPUFreq Utilities: Setting ondemand CPUFreq governor...       
[ OK ]
 * Starting CPU interrupts balancing daemon[ OK ]
 * Starting VirtualBox kernel modules       
[ OK ]
 * VirtualBox Additions disabled, not in a Virtual Machine
 * Starting NetBIOS name server[ OK ]
 * Starting Mount network filesystems[ OK ]
 * Stopping Mount network filesystems[ OK ]
 * Stopping CPU interrupts balancing daemon[ OK ]
 * Starting Mail Transport Agent (MTA) sendmail       
[ OK ]
 * Starting MDM Display Manager mdm       
[ OK ]
saned disabled; edit /etc/default/saned
Attachments
laptop-nadia-20121228-2.png
bootchart
laptop-nadia-20121228-2.png (660.68 KiB) Viewed 1071 times
kimented
Level 1
Level 1
 
Posts: 2
Joined: Fri Dec 28, 2012 7:49 am

Linux Mint is funded by ads and donations.
 

Re: System boot too slow - LM14

Postby xenopeek on Fri Dec 28, 2012 9:10 am

As you can see from your bootgraph your hard disk is completely stressed out for over a minute (high wait I/O means processes are waiting for the hard disk to complete their requests). It can't load the files fast enough and so the boot process is dragged to a crawl as everything is waiting for the hard disk to just do its job for once (you should fire it from its job it BTW, get a SSD). That may however be an indication of the hard disk having problems. Suggest you install gnome-disk-utility and then run Disk Utility from the menu and do a read benchmark for your hard disk, and look at the SMART information. Check that everything is okay with the hard disk before you try anything else.

When did you download and install Linux Mint 14? Last day of November the ISOs for Linux Mint 14 were refreshed because previously there had been an issue with bad performance in Intel GPUs. See this announcement: http://blog.linuxmint.com/?p=2234. That was fixed in MDM version 1.0.8, which you should have on your system if you are up to date. You can check easy on the terminal with the following command. You should have MDM version "1.0.8+nadia".
Code: Select all
dpkg -l mdm

Aside from that, you can disable some services you may not need and perhaps that will help (less files to load). Some ideas for that here, also see the posts linked from that post, viewtopic.php?f=18&t=106417&p=600177#p600177.

Not sure if it will put much of a dent into it, but you could remove the VirtualBox guest additions. You only need those when you are running Linux Mint inside a virtual machine. You can safely remove then if you are running on metal.
Code: Select all
sudo apt-get --purge autoremove virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: System boot too slow - LM14

Postby kimented on Fri Dec 28, 2012 12:38 pm

Ok, it seems my HD will die... :( It's just strange I have no problem when the system is totally launched.

Read Error Rate: 86060705 -> this number don't seems to change
Seek Error Rate: 47 554 334 932 -> this number increases fast

Thank you for your help.
kimented
Level 1
Level 1
 
Posts: 2
Joined: Fri Dec 28, 2012 7:49 am

Re: System boot too slow - LM14

Postby xenopeek on Fri Dec 28, 2012 12:46 pm

Ouch :( That's bad news, I had hoped it to be something else. At least you caught it in time and can back up your personal documents before it breaks further.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Other topics

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests