Color profile set to default after suspend/sleep

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help

Color profile set to default after suspend/sleep

Postby q____q on Sat Jan 19, 2013 2:47 pm

Not sure where to post this, please move topic if neccesary.

I'm running Linux Mate 14 (64bit, Cinnamon) on a MacbookPro 7,1 and it's really awesome so far ('cept for minor things like having to disable keyboard backlight at every login).

One thing that annoys me is that the color profile is set to default every time I wake the laptop from sleep/suspend (reopening the lid). Deleting the default profile in the Color preferences did not help. It might be the Nvidia Settings (Geforce 320M, using the proprietary driver) interfering here but I don't know how to solve this

Any ideas?
q____q
Level 1
Level 1
 
Posts: 9
Joined: Sat Jan 19, 2013 2:23 pm

Linux Mint is funded by ads and donations.
 

Re: Color profile set to default after suspend/sleep

Postby q____q on Sun Jan 20, 2013 10:01 am

Yay, I just found a way to disable the keyboard backlight that actually works on my MacbookPro7,1:

Add
Code: Select all
echo 1 >> /sys/class/leds/smc::kbd_backlight/brightness

to rc.local via
Code: Select all
sudo gedit /etc/rc.local


No progress on the profile-problem though …

EDIT: The above obviously only sets the backlight to one (and doesn't really turn it fully off). But since 0 and -1 do not work I think this is good enough. To set the screen brightness to something else then full power at login add the line:
Code: Select all
echo 3 >> /sys/class/backlight/apple_backlight/brightness
Last edited by q____q on Wed Jan 23, 2013 12:01 pm, edited 1 time in total.
q____q
Level 1
Level 1
 
Posts: 9
Joined: Sat Jan 19, 2013 2:23 pm

Re: Color profile set to default after suspend/sleep

Postby q____q on Sun Jan 20, 2013 10:20 am

This seems to be a bug known since 2011 not only affacting NVIDIA.
q____q
Level 1
Level 1
 
Posts: 9
Joined: Sat Jan 19, 2013 2:23 pm

Re: Color profile set to default after suspend/sleep

Postby q____q on Wed Jan 23, 2013 11:55 am

Found a way to solve this:

Install xcalib.

Place a script with the following in /etc/pm/sleep.d/

Code: Select all
#!/bin/bash
case "$1" in
    thaw|resume)
        export DISPLAY=:0
        su -c - <USERNAME>
        /usr/bin/xcalib "<PATH TO COLOR PROFILE>"
        ;;
    *)
        ;;
esac
exit $?


Thanks/credit to this and this thread.
q____q
Level 1
Level 1
 
Posts: 9
Joined: Sat Jan 19, 2013 2:23 pm


Return to Other topics

Who is online

Users browsing this forum: No registered users and 4 guests