How to disable journaling on ext4?

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

How to disable journaling on ext4?

Postby DriveR on Sun Apr 21, 2013 1:11 pm

Hello!
How to disable journaling on ext4?
On the Internet, a lot of different advice, but no one to MINT14
DriveR
Level 1
Level 1
 
Posts: 4
Joined: Sun Apr 21, 2013 1:01 pm

Linux Mint is funded by ads and donations.
 

Re: How to disable journaling on ext4?

Postby xenopeek on Sun Apr 21, 2013 4:00 pm

I wouldn't recommend doing that. The risk you take with your data files by disabling journaling isn't offset by any imagined physical life span extension of your SSD. This advice to disable journaling stems back to the days when cheap SSDs were often fake goods; basically compact flash cards with an IDE connector :| Modern SSDs do automatic wear leveling, so if you stick to reputable manufacturers this shouldn't be a worry for you. My SSD from Intel has been purring for 4 years now, without any sign of trouble. Same for my 3 year old SSD from OCZ.

To disable journaling, I would boot from your Linux Mint installation DVD / USB. That way you know you aren't using your partitions (as they aren't mounted). From there run the commands:
Code: Select all
tune2fs -O ^has_journal /dev/sdXY
e2fsck -f /dev/sdXY

Where you replace /dev/sdXY with your device name and number for the partition you want to disable journaling on. For example /dev/sda1 for the first partition on the first disk. If you don't know, run the following command to list your partitions:
Code: Select all
sudo parted -l

Before you do anything funky with your file system though, back up any important personal files!!!
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14540
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Other topics

Who is online

Users browsing this forum: Bing [Bot] and 3 guests