shutdown issue, need tutorial

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

shutdown issue, need tutorial

Postby tinny on Wed Feb 28, 2007 10:39 pm

I have experienced a final shutdown hang over several distributions on this box. All *buntu , Vector, Mint, none of them will shut down this standard Intel chipset P3 1000mhz. I would give more info, except I havent figured out where the sys info utility is in Bianca. MSI 815 PRO (aka MS-6326) motherboard, 512MB PC133 ram, 10.2 GB hdd. That refusal to shut down may be a quirk of the latest kernel re P3 mobos.

Please show me a good tutorial for making edits to fix an APM/ACPI shutdown issue? I have made that edit for APM on a slower P3, but not ACPI. I believe the BIOS in this computer has ACPI settings. I'll double check and post a correction if not. On second thought, maybe I already made this edit for Kubuntu 6.06.1 which is on another (separate) hard drive in this box.

I have Bea on another computer, Abit KR7A mobo with Athlon XP 2000+ processor, and it never had shutdown issues, nor did Kubuntu 6.10 on the same box.

Any clue why P3 mobos do this (hang on shutdown)?

----------------------------------------------------------------------------------------------

Here is the output of dmesg

[17179569.184000] Linux version 2.6.17-11-generic (root@terranova) (gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)) #2 SMP Thu Feb 1 19:52:28 UTC 2007 (Ubuntu 2.6.17-11.35-generic)
[17179569.184000] BIOS-provided physical RAM map:
[17179569.184000] BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[17179569.184000] BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[17179569.184000] BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
[17179569.184000] BIOS-e820: 0000000000100000 - 000000001fee0000 (usable)
[17179569.184000] BIOS-e820: 000000001fee0000 - 000000001fef0000 (ACPI data)
[17179569.184000] BIOS-e820: 000000001fef0000 - 000000001ff00000 (ACPI NVS)
[17179569.184000] BIOS-e820: 000000001ff00000 - 0000000020000000 (reserved)
[17179569.184000] BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
[17179569.184000] 0MB HIGHMEM available.
[17179569.184000] 510MB LOWMEM available.
[17179569.184000] On node 0 totalpages: 130784
[17179569.184000] DMA zone: 4096 pages, LIFO batch:0
[17179569.184000] Normal zone: 126688 pages, LIFO batch:31
[17179569.184000] DMI 2.3 present.
[17179569.184000] ACPI: RSDP (v000 AMI ) @ 0x000fbd40
[17179569.184000] ACPI: RSDT (v001 AMIINT AMIINT10 0x00001000 MSFT 0x0100000b) @ 0x1fee0000
[17179569.184000] ACPI: FADT (v001 AMIINT AMIINT10 0x00001000 MSFT 0x0100000b) @ 0x1fee0030
[17179569.184000] ACPI: DSDT (v001 INTEL SOLANO 0x00001000 MSFT 0x0100000b) @ 0x00000000
[17179569.184000] ACPI: BIOS age (1997) fails cutoff (2000), acpi=force is required to enable ACPI
[17179569.184000] ACPI: Disabling ACPI support
[17179569.184000] Allocating PCI resources starting at 30000000 (gap: 20000000:dff80000)
[17179569.184000] Built 1 zonelists
[17179569.184000] Kernel command line: root=/dev/hda1 ro quiet splash
[17179569.184000] Local APIC disabled by BIOS (or by default) -- you can enable it with "lapic"
[17179569.184000] mapped APIC to ffffd000 (0140a000)
[17179569.184000] Enabling fast FPU save and restore... done.
[17179569.184000] Enabling unmasked SIMD FPU exception support... done.
[17179569.184000] Initializing CPU#0
[17179569.184000] PID hash table entries: 2048 (order: 11, 8192 bytes)
[ 0.000000] Detected 1002.401 MHz processor.
[ 42.861358] Using tsc for high-res timesource
[ 42.863246] Console: colour VGA+ 80x25
[ 42.864455] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[ 42.865857] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[ 42.913879] Memory: 508640k/523136k available (1911k kernel code, 13876k reserved, 1073k data, 308k init, 0k highmem)
[ 42.913888] Checking if this processor honours the WP bit even in supervisor mode... Ok.
[ 42.993174] Calibrating delay using timer specific routine.. 2007.40 BogoMIPS (lpj=4014805)
[ 42.993257] Security Framework v1.0.0 initialized
[ 42.993275] SELinux: Disabled at boot.
[ 42.993308] Mount-cache hash table entries: 512
[ 42.993580] CPU: After generic identify, caps: 0387f9ff 00000000 00000000 00000000 00000000 00000000 00000000
[ 42.993595] CPU: After vendor identify, caps: 0387f9ff 00000000 00000000 00000000 00000000 00000000 00000000
[ 42.993614] CPU: L1 I cache: 16K, L1 D cache: 16K
[ 42.993620] CPU: L2 cache: 256K
[ 42.993625] CPU serial number disabled.
[ 42.993630] CPU: After all inits, caps: 0383f9ff 00000000 00000000 00000040 00000000 00000000 00000000
[ 42.993671] Checking 'hlt' instruction... OK.
[ 43.009312] SMP alternatives: switching to UP code
[ 43.009610] Freeing SMP alternatives: 16k freed
[ 43.009909] checking if image is initramfs... it is
[ 44.048740] Freeing initrd memory: 5590k freed
[ 44.048763] CPU0: Intel Pentium III (Coppermine) stepping 0a
[ 44.048776] SMP motherboard not detected.
[ 44.048781] Local APIC not detected. Using dummy APIC emulation.
[ 44.048979] Brought up 1 CPUs
[ 44.049036] migration_cost=0
[ 44.049784] NET: Registered protocol family 16
[ 44.049868] EISA bus registered
[ 44.060154] PCI: PCI BIOS revision 2.10 entry at 0xfdb21, last bus=1
[ 44.060168] PCI: Using configuration type 1
[ 44.060173] Setting up standard PCI resources
[ 44.135148] ACPI: Interpreter disabled.
[ 44.135158] Linux Plug and Play Support v0.97 (c) Adam Belay
[ 44.135188] pnp: PnP ACPI: disabled
[ 44.135198] PnPBIOS: Scanning system for PnP BIOS support...
[ 44.135426] PnPBIOS: Found PnP BIOS installation structure at 0xc00f61d0
[ 44.135439] PnPBIOS: PnP BIOS version 1.0, entry 0xf0000:0x5234, dseg 0xf0000
[ 44.139901] PnPBIOS: 17 nodes reported by PnP BIOS; 17 recorded by driver
[ 44.140015] PCI: Probing PCI hardware
[ 44.140025] PCI: Probing PCI hardware (bus 00)
[ 44.140217] Boot video device is 0000:00:02.0
[ 44.140343] PCI quirk: region 0400-047f claimed by ICH4 ACPI/GPIO/TCO
[ 44.140350] PCI quirk: region 0480-04bf claimed by ICH4 GPIO
[ 44.140409] PCI: Ignoring BAR0-3 of IDE controller 0000:00:1f.1
[ 44.140870] PCI: Transparent bridge - 0000:00:1e.0
[ 44.141904] PCI: Using IRQ router PIIX/ICH [8086/2410] at 0000:00:1f.0
[ 44.161595] PCI: Ignore bogus resource 6 [0:0] of 0000:00:02.0
[ 44.161608] PCI: Bridge: 0000:00:1e.0
[ 44.161614] IO window: a000-afff
[ 44.161623] MEM window: efd00000-efdfffff
[ 44.161630] PREFETCH window: e7b00000-e7bfffff
[ 44.161653] PCI: Setting latency timer of device 0000:00:1e.0 to 64
[ 44.161711] NET: Registered protocol family 2
[ 44.200638] IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 44.200919] TCP established hash table entries: 16384 (order: 5, 131072 bytes)
[ 44.201388] TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
[ 44.201664] TCP: Hash tables configured (established 16384 bind 8192)
[ 44.201672] TCP reno registered
[ 44.203355] audit: initializing netlink socket (disabled)
[ 44.203393] audit(1172713424.528:1): initialized
[ 44.203737] VFS: Disk quotas dquot_6.5.1
[ 44.203791] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[ 44.203927] Initializing Cryptographic API
[ 44.203937] io scheduler noop registered
[ 44.203953] io scheduler anticipatory registered
[ 44.203967] io scheduler deadline registered
[ 44.203995] io scheduler cfq registered (default)
[ 44.204543] isapnp: Scanning for PnP cards...
[ 44.558517] isapnp: No Plug & Play device found
[ 44.612072] Real Time Clock Driver v1.12ac
[ 44.612316] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
[ 44.612498] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[ 44.612858] serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
[ 44.613986] 00:09: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[ 44.614459] 00:0a: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
[ 44.615025] mice: PS/2 mouse device common for all mice
[ 44.616336] RAMDISK driver initialized: 16 RAM disks of 65536K size 1024 blocksize
[ 44.616823] Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
[ 44.616834] ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
[ 44.617249] PNP: PS/2 Controller [PNP0303,PNP0f13] at 0x60,0x64 irq 1,12
[ 44.618858] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 44.618927] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 44.619405] EISA: Probing bus 0 at eisa.0
[ 44.619455] EISA: Detected 0 cards.
[ 44.619997] TCP bic registered
[ 44.620024] NET: Registered protocol family 1
[ 44.620039] NET: Registered protocol family 8
[ 44.620043] NET: Registered protocol family 20
[ 44.620093] Using IPI No-Shortcut mode
[ 44.621300] Freeing unused kernel memory: 308k freed
[ 44.643703] input: AT Translated Set 2 keyboard as /class/input/input0
[ 45.844881] Capability LSM initialized
[ 46.962432] ICH: IDE controller at PCI slot 0000:00:1f.1
[ 46.962461] ICH: chipset revision 2
[ 46.962465] ICH: not 100% native mode: will probe irqs later
[ 46.962483] ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
[ 46.962504] ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:DMA
[ 46.962519] Probing IDE interface ide0...
[ 47.250727] hda: WDC WD102BA, ATA DISK drive
[ 47.923036] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[ 47.923436] Probing IDE interface ide1...
[ 48.657865] hdc: PLEXTOR CD-R PX-W1610A, ATAPI CD/DVD-ROM drive
[ 49.441389] hdd: HITACHI DVD-ROM GD-5000, ATAPI CD/DVD-ROM drive
[ 49.504220] ide1 at 0x170-0x177,0x376 on irq 15
[ 49.520154] hda: max request size: 128KiB
[ 49.550799] hda: 20028960 sectors (10254 MB) w/2048KiB Cache, CHS=19870/16/63, UDMA(66)
[ 49.550820] hda: cache flushes not supported
[ 49.550920] hda: hda1 hda2 < hda5 >
[ 49.625917] hdc: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache, DMA
[ 49.625937] Uniform CD-ROM driver Revision: 3.20
[ 49.635955] hdd: ATAPI 40X DVD-ROM drive, 512kB Cache, DMA
[ 49.974714] usbcore: registered new driver usbfs
[ 49.974773] usbcore: registered new driver hub
[ 49.977792] USB Universal Host Controller Interface driver v3.0
[ 49.977895] PCI: Found IRQ 5 for device 0000:00:1f.2
[ 49.977941] PCI: Setting latency timer of device 0000:00:1f.2 to 64
[ 49.977949] uhci_hcd 0000:00:1f.2: UHCI Host Controller
[ 49.978197] uhci_hcd 0000:00:1f.2: new USB bus registered, assigned bus number 1
[ 49.978240] uhci_hcd 0000:00:1f.2: irq 5, io base 0x0000d000
[ 49.978422] usb usb1: configuration #1 chosen from 1 choice
[ 49.978482] hub 1-0:1.0: USB hub found
[ 49.978501] hub 1-0:1.0: 2 ports detected
[ 50.134510] Attempting manual resume
[ 50.187674] kjournald starting. Commit interval 5 seconds
[ 50.187705] EXT3-fs: mounted filesystem with ordered data mode.
[ 66.502199] input: PC Speaker as /class/input/input1
[ 66.547620] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 66.553141] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[ 66.801904] Linux agpgart interface v0.101 (c) Dave Jones
[ 66.806568] agpgart: Detected an Intel i815 Chipset.
[ 66.817037] agpgart: AGP aperture is 64M @ 0xe8000000
[ 66.834659] Floppy drive(s): fd0 is 1.44M
[ 66.854437] FDC 0 is a post-1991 82077
[ 66.867055] parport: PnPBIOS parport detected.
[ 66.867105] parport0: PC-style at 0x378, irq 7 [PCSPP]
[ 66.915998] PCI: Found IRQ 11 for device 0000:00:1f.5
[ 66.916024] PCI: Sharing IRQ 11 with 0000:00:1f.3
[ 66.916069] PCI: Setting latency timer of device 0000:00:1f.5 to 64
[ 67.011248] hw_random hardware driver 1.0.0 loaded
[ 67.246484] intel8x0_measure_ac97_clock: measured 54592 usecs
[ 67.246494] intel8x0: clocking to 48000
[ 67.248630] i810_smbus 0000:00:02.0: i810/i815 i2c device found.
[ 67.838877] 8139too Fast Ethernet driver 0.9.27
[ 67.842381] eth0: RealTek RTL8139 at 0xe0964f00, 00:e0:29:71:b3:d1, IRQ 11
[ 67.842391] eth0: Identified 8139 chip type 'RTL-8139B'
[ 67.880069] input: ImPS/2 Generic Wheel Mouse as /class/input/input2
[ 67.954353] ts: Compaq touchscreen protocol output
[ 68.236094] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[ 68.486438] fuse init (API version 7.6)
[ 68.539309] lp0: using parport0 (interrupt-driven).
[ 68.606212] Adding 441748k swap on /dev/disk/by-uuid/a11b74cd-70a1-4278-b2c5-ec4468903098. Priority:-1 extents:1 across:441748k
[ 68.689150] EXT3 FS on hda1, internal journal
[ 69.440389] NET: Registered protocol family 17
[ 80.937996] apm: BIOS not found.
[ 88.013930] Bluetooth: Core ver 2.8
[ 88.013947] NET: Registered protocol family 31
[ 88.013951] Bluetooth: HCI device and connection manager initialized
[ 88.013990] Bluetooth: HCI socket layer initialized
[ 88.084161] Bluetooth: L2CAP ver 2.8
[ 88.084177] Bluetooth: L2CAP socket layer initialized
[ 88.093663] Bluetooth: RFCOMM socket layer initialized
[ 88.093705] Bluetooth: RFCOMM TTY layer initialized
[ 88.093710] Bluetooth: RFCOMM ver 1.7

-----------------------------------------------------------------------------------------

Output of lspci

00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82815 CGC [Chipset Graphics Controller] (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801AA USB (rev 02)
00:1f.3 SMBus: Intel Corporation 82801AA SMBus (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio (rev 02)
01:00.0 Communication controller: Rockwell International HCF 56k Data/Fax Modem (rev 01)
01:01.0 Ethernet controller: Accton Technology Corporation SMC2-1211TX (rev 10)

----------------------------------------------------------------------------------------------

What does this mean?

[17179569.184000] ACPI: BIOS age (1997) fails cutoff (2000), acpi=force is required to enable ACPI
[17179569.184000] ACPI: Disabling ACPI support

Thanks
User avatar
tinny
Level 3
Level 3
 
Posts: 100
Joined: Thu Feb 22, 2007 2:35 pm
Location: USA

Linux Mint is funded by ads and donations.
 

Postby metapy on Thu Mar 01, 2007 12:48 am

Hate to say it, but you are probably better off posting this in the Ubuntu forums as there are TONS more people there. If it is a problem with ALL Ubuntu distros (Mint included) it seems the best place for a solution would be the Ubuntu forums.

Hopefully someone will post the solution here and make a fool of me. ;)
metapy
Level 1
Level 1
 
Posts: 27
Joined: Fri Feb 23, 2007 9:01 pm

Postby |_NiGhTmArE_| on Thu Mar 01, 2007 6:59 am

What does this mean?

[17179569.184000] ACPI: BIOS age (1997) fails cutoff (2000), acpi=force is required to enable ACPI
[17179569.184000] ACPI: Disabling ACPI support


this means that the ACPI is not enabled... if you know that your mobo can handle ACPI you may try to force your system to use it...
to make this you have to edit your /boot/grub/menu.lst, search your kernel entry and add acpi=force at the very end of the line

it should look like this:

kernel /boot/vmlinuz-2.X.XX-XX-XXX root=/dev/hdXX ro quiet splash acpi=force
User avatar
|_NiGhTmArE_|
Level 1
Level 1
 
Posts: 48
Joined: Mon Feb 05, 2007 6:16 pm
Location: Italy


Return to Other topics

Who is online

Users browsing this forum: No registered users and 5 guests