Can't login as root, no access to my SATA drive

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Can't login as root, no access to my SATA drive

Postby Peter Witteveen on Sat Mar 10, 2007 11:21 am

Dear reader,

I have a working linux mint with internet connection.
However, i don't have access to my SATA drive, i can read, but i do not have permissions to write and stuff like that.

In order to give myself permissions on my own disks, i will have to login as root.

I have tried the {su -} command, and sudo. But with these i still can't login as root. So some1 please tell me how to login as root and how to give myself
permissions to my disks. As long as this isn't fixed i can't download anything using bittorrent. bittorrent apps simply say : can't save your file, because it is read only, and i can't change this because of not being root.

greetings,

Peter
Peter Witteveen
Level 1
Level 1
 
Posts: 36
Joined: Sat Mar 10, 2007 11:12 am

Linux Mint is funded by ads and donations.
 

Postby scorp123 on Sat Mar 10, 2007 11:42 am

sudo ... and when it asks for the password, it's your password. Another trick is: sudo su - which will give you a root shell.

If you really really want to enable the root account you can give it a passwd once you're root. From there on su - should work like expected again.
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby Peter Witteveen on Sat Mar 10, 2007 11:53 am

I know, i can use su- and sudo to perform root commands, but outside the terminal this doesn't work, and i do not know how to change disk permissions inside a terminal.

When i go to disk properties there is an option to give another user (me) acces to the disk so i can write on the disk. This allows me to use bittorrent clients.

I can't become root outside the terminal, that's the problem. Outside the terminal i am still peter (myself), not root. So i can't change disks permissions and therefore i am not able to write to my disk.

Do you have a solution to this?

thanks
Peter Witteveen
Level 1
Level 1
 
Posts: 36
Joined: Sat Mar 10, 2007 11:12 am

Postby Peter Witteveen on Sat Mar 10, 2007 12:41 pm

(addition)

Root appears to be the owner of the disk; sda1. I can only read, not write.
Using sudo and su commands don't allow me to change this.

please help.
Peter Witteveen
Level 1
Level 1
 
Posts: 36
Joined: Sat Mar 10, 2007 11:12 am

Postby Peter Witteveen on Sat Mar 10, 2007 2:48 pm

Thanks for your help, i can now login as root, but unfortunately i am still not able to write to my SATA disk.

It appears to be a `read only` disk... :(

Would anyone please help me solve this, I am getting quite crazy here.

(I can't change this at the disk properties)
Peter Witteveen
Level 1
Level 1
 
Posts: 36
Joined: Sat Mar 10, 2007 11:12 am

Postby scorp123 on Sat Mar 10, 2007 3:39 pm

Peter Witteveen wrote:Root appears to be the owner of the disk; sda1. I can only read, not write.
Can you please give me the result of this command? (the whole output please!)
Code: Select all
cat /etc/fstab


And while you are at it, also this please:
Code: Select all
sudo fdisk -l /dev/sda
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby Peter Witteveen on Sun Mar 11, 2007 4:54 am

I entered the commands you gave me and this is their output.


root@PETERW:~# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda10
UUID=e7a62976-bbad-410a-bf60-dcdb9510e489 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda1
UUID=1623-15E1 /media/hda1 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/sda1
UUID=06E86002E85FEF05 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda5
UUID=4c733df5-64bc-463d-a0d1-d14147116b6e /media/sda5 ext3 defaults 0 2
# /dev/sda6
UUID=7c4cb47a-746e-4890-8c29-ac3cd39290b8 /media/sda6 ext3 defaults 0 2
# /dev/sda8
UUID=fda6f256-2b01-4973-bbcf-650bb8a3cc23 /media/sda8 ext3 defaults 0 2
# /dev/sda9
UUID=976c9692-3709-4d89-b80b-d48db1f4e2f0 none swap sw 0 0
/dev/hdb /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/ /media/floppy0 auto rw,user,noauto 0 0
root@PETERW:~#

root@PETERW:~# sudo fdisk -l /dev/sda

Disk /dev/sda: 251.0 GB, 251000193024 bytes
255 heads, 63 sectors/track, 30515 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 20462 164360983+ 7 HPFS/NTFS
/dev/sda2 20463 30515 80750722+ 5 Extended
/dev/sda5 20463 21481 8185086 83 Linux
/dev/sda6 27897 28915 8185086 83 Linux
/dev/sda7 28916 29311 3180838+ 82 Linux swap / Solaris
/dev/sda8 29312 30515 9671098+ 83 Linux
/dev/sda9 21482 21990 4088511 82 Linux swap / Solaris
/dev/sda10 21991 27896 47439913+ 83 Linux

Partition table entries are not in disk order
root@PETERW:~#
Peter Witteveen
Level 1
Level 1
 
Posts: 36
Joined: Sat Mar 10, 2007 11:12 am

Postby scorp123 on Sun Mar 11, 2007 5:44 am

According to your fstab above /dev/sda1 is NTFS e.g. a Windows drive? Trying to write to it by force as you did is dangerous. Microsoft never really released the specifications for the NTFS filesystem, hence there are some "do's" and "dont's" ...

I suggest you use the safe methods for accessing your NTFS drive:

http://www.linuxmint.com/forum/viewtopic.php?p=3729&#3729
http://www.linuxmint.com/forum/viewtopic.php?p=8630&#8630
http://www.linuxmint.com/forum/viewtopic.php?p=8773#8773

You could have found that info yourself if you had used the "search" function here, e.g. searching for "ntfs" would have given you above results too.
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby Peter Witteveen on Sun Mar 11, 2007 6:01 am

I didn't know that NTFS could be the problem.

I have used a dual boot system in the past. I was using winXP and Linspire.
When i was in Linspire i was always able to write to an NTFS disk.
I never knew it was dangerous.

Anyway, many thanks for your help, i will read the links you have posted.
Peter Witteveen
Level 1
Level 1
 
Posts: 36
Joined: Sat Mar 10, 2007 11:12 am

Postby Peter Witteveen on Sun Mar 11, 2007 6:36 am

I have used some kind of tool which enabled write support on my SATA ntfs disk.

It works now. I am currently downloading to that NTFS disk.
Peter Witteveen
Level 1
Level 1
 
Posts: 36
Joined: Sat Mar 10, 2007 11:12 am

Postby scorp123 on Sun Mar 11, 2007 7:04 am

Peter Witteveen wrote: I didn't know that NTFS could be the problem.
There have been various attempts of "the Linux people" (e.g. various programmers) to reverse-engineer NTFS. There is a NTFS-module (= "driver") in the kernel but it was long (and probably still is) regarded as being totally unsafe for write access, as NTFS does some "strange" things and Microsoft won't tell us exactly why and how; typical "closed source" bullsh*t. Then there are other approaches to the problem. Currently you can use "ntfs-3g" and under Linux Mint you can use a nice GUI tool "mintDisk" which will work hand in hand with those new (but still totally unofficial) NTFS drivers. As I said previously those new approaches to the "NTFS problem" should be much safer than the old NTFS drivers which might still be in the Linux kernel (and those are normally "read only" with good reason!).

Peter Witteveen wrote: When i was in Linspire i was always able to write to an NTFS disk. I never knew it was dangerous.
See here what they say about this:
http://forum.linspire.com/viewtopic.php?p=562244&sid=5aac20e36d7fa441f4127948fdeeddc5#562244
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: JeremyB and 5 guests