Apt-get problems

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help

Apt-get problems

Postby moriancumer_12 on Tue Mar 13, 2007 2:56 pm

I run:
sudo apt-get -f install

and get:
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsasl2-2:
libsasl2-2 depends on libsasl2-modules (= 2.1.22.dfsg1-8ubuntu2) | libsasl2-modules-sql (= 2.1.22.dfsg1-8ubuntu2) | libsasl2-modules-gssapi-heimdal (= 2.1.22.dfsg1-8ubuntu2) | libsasl2-modules-kerberos-heimdal (= 2.1.22.dfsg1-8ubuntu2); however:
Package libsasl2-modules is not configured yet.
Package libsasl2-modules-sql is not installed.
Package libsasl2-modules-gssapi-heimdal is not installed.
Package libsasl2-modules-kerberos-heimdal is not installed.
dpkg: error processing libsasl2-2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libldap2:
libldap2 depends on libsasl2-2; however:
Package libsasl2-2 is not configured yet.
dpkg: error processing libldap2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsasl2:
libsasl2 depends on libsasl2-2 (= 2.1.22.dfsg1-8ubuntu2); however:
Package libsasl2-2 is not configured yet.
dpkg: error processing libsasl2 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
debconf
adduser
ifupdown
libssl0.9.8
libsasl2-modules
netbase
libpq5
libaprutil1
apache2-utils
ucf
php5-cgi
postfix
libsasl2-2
libldap2
libsasl2
E: Sub-process /usr/bin/dpkg returned an error code (1)

hopefully that gives you a picture of what's happen.

This all started after trying to install apache2.
Here are my repos:

## Add comments (##) in front of any line to remove it from being checked.
## Use the following sources.list at your own risk.

deb http://archive.ubuntu.com/ubuntu edgy main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu edgy main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu edgy-proposed main restricted universe multiverse

## MAJOR BUG FIX UPDATES produced after the final release
deb http://archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse

## UBUNTU SECURITY UPDATES
deb http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse

## BACKPORTS REPOSITORY (Unsupported. May contain illegal packages. Use at own risk.)
deb http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse

## PLF REPOSITORY (Unsupported. May contain illegal packages. Use at own risk.)
#deb http://packages.freecontrib.org/plf edgy-plf free non-free
#deb-src http://packages.freecontrib.org/plf edgy-plf free non-free

## CANONICAL COMMERCIAL REPOSITORY (Hosted on Canonical servers, not Ubuntu
## servers. RealPlayer10, Opera, DesktopSecure and more to come.)
deb http://archive.canonical.com/ubuntu edgy-commercial main

## AMAROK 1.4.5
deb http://kubuntu.org/packages/amarok-145 edgy main

#Bianca multimedia codecs
deb http://medibuntu.sos-sts.com/repo/ edgy free non-free

#Bianca Linux Mint applications
deb http://www.linuxmint.com/repository bianca/

#remastering script
#deb http://www.linuxmint.com/repository romeo/

#Automatix repo
deb http://www.getautomatix.com/apt edgy main

#AUTOMATIX REPOS START

deb http://archive.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
#AUTOMATIX REPOS END


Does anyone have any ideas what might be happening and how I might be able to fix it.

Thanks in advance.
moriancumer_12
Level 1
Level 1
 
Posts: 4
Joined: Thu Nov 16, 2006 12:37 am

Linux Mint is funded by ads and donations.
 

Postby sharke on Thu Mar 15, 2007 6:06 am

Install all the packages listed as not installed
Regards
Sharke
sharke
Level 1
Level 1
 
Posts: 14
Joined: Sat Mar 10, 2007 9:32 am

Postby moriancumer_12 on Thu Mar 15, 2007 12:03 pm

when I try to install packages listed as not installed, I get:

$ sudo apt-get install libsasl2-modules-gssapi-heimdal
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsasl2-modules-gssapi-heimdal: Depends: libsasl2 (= 2.1.19.dfsg1-0.2ubuntu3) but 2.1.22.dfsg1-8ubuntu2 is to be installed
E: Broken packages


How did I mess things up so bad? What did I do wrong? I know I added some new repositories, could that be what screwed things up? How can I avoid this from happening again? Would it just be easier to backup files and reinstall?
moriancumer_12
Level 1
Level 1
 
Posts: 4
Joined: Thu Nov 16, 2006 12:37 am

if

Postby zonamint on Thu Mar 15, 2007 7:24 pm

Use synaptic for that...its easier...Mint Bianca MENU , then Install software or just type in console:

$ sudo synaptic

cheers
User avatar
zonamint
Level 2
Level 2
 
Posts: 57
Joined: Sun Mar 11, 2007 1:00 am

Postby sharke on Sat Mar 17, 2007 9:16 pm

Sorry I havent replied earlier i have been away with work.
If you still need assistance please post your apt sources list.
Regards
Sharke
sharke
Level 1
Level 1
 
Posts: 14
Joined: Sat Mar 10, 2007 9:32 am


Return to Other topics

Who is online

Users browsing this forum: No registered users and 5 guests