Ruby, irb problem and kludgy solution

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Ruby, irb problem and kludgy solution

Postby allenm on Tue Mar 13, 2007 4:58 pm

I installed Ruby 1.8, irb 1.8 and all the associated stuff. Trouble is, when I try to invoke Ruby or irb by entering "Ruby" or "irb" at the command line I get a not found. My kludge was to go to /usr/bin and symlink ruby to ruby1.8 and irb to irb1.8.

I don't think this is optimal but I'm not sure what else to do about to get Ruby and irb running.
allenm
Level 1
Level 1
 
Posts: 21
Joined: Mon Mar 12, 2007 2:32 pm

Linux Mint is funded by ads and donations.
 

Re: Ruby, irb problem and kludgy solution

Postby jelem on Tue Mar 13, 2007 10:08 pm

I'm assuming you installed ruby this way. It will install ruby1.8, etc.

From http://www.ruby-lang.org:

...

For example, on Debian or Ubuntu apt-get provides an easy and elegant solution:

% sudo apt-get install ruby irb rdoc

For irb and rdoc you will need to enable the universe repository.

...
jelem
Level 1
Level 1
 
Posts: 1
Joined: Tue Mar 13, 2007 9:56 pm


Return to Other topics

Who is online

Users browsing this forum: No registered users and 7 guests