LinuxMint 17, can not install ia32-libs

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

LinuxMint 17, can not install ia32-libs

Postby detrix42 on Thu Jun 05, 2014 11:47 am

Anyone else having problems installing ia32-libs? I have added the i386 architecture, and still not installing. I need them for the Android SDK tools.
detrix42
Level 1
Level 1
 
Posts: 4
Joined: Sun Jan 05, 2014 3:50 am

Linux Mint is funded by ads and donations.
 

Re: LinuxMint 17, can not install ia32-libs

Postby Monsta on Fri Jun 06, 2014 5:56 am

What does "not installing" mean? Any error messages?

Also post the output of:
Code: Select all
inxi -Sr
Code: Select all
apt policy ia32-libs
Monsta
Level 8
Level 8
 
Posts: 2337
Joined: Fri Aug 19, 2011 3:46 am

Re: LinuxMint 17, can not install ia32-libs

Postby detrix42 on Fri Jun 06, 2014 7:57 am

Sorry for the shortness of the Question. When I tried to install ia32-libs, apt wants to uninstall the 64bit libs, and all apps that use them. Its either 64bit libs or 32bit libs, I can't seem to get both which I had no problems with getting with Linux Mint 16. I will now try your other suggestions.
detrix42
Level 1
Level 1
 
Posts: 4
Joined: Sun Jan 05, 2014 3:50 am

Re: LinuxMint 17, can not install ia32-libs

Postby detrix42 on Fri Jun 06, 2014 8:12 am

Here is the inxi output:
Code: Select all
System:    Host: NovasectorDT Kernel: 3.13.0-24-generic x86_64 (64 bit) Desktop: Gnome Distro: Linux Mint 17 Qiana
Repos:     Active apt sources in file: /etc/apt/sources.list.d/google-earth.list
           deb http://dl.google.com/linux/earth/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google-talkplugin.list
           deb http://dl.google.com/linux/talkplugin/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com petra main upstream import #id:linuxmint_main
           deb http://extra.linuxmint.com petra main #id:linuxmint_extra
           deb http://archive.ubuntu.com/ubuntu saucy main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu saucy-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ saucy-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ saucy partner
           Active apt sources in file: /etc/apt/sources.list.d/plexapp-plexht-saucy.list
           deb http://ppa.launchpad.net/plexapp/plexht/ubuntu saucy main
           deb-src http://ppa.launchpad.net/plexapp/plexht/ubuntu saucy main
           Active apt sources in file: /etc/apt/sources.list.d/steam.list
           deb http://repo.steampowered.com/steam/ precise steam
           deb-src http://repo.steampowered.com/steam/ precise steam
           Active apt sources in file: /etc/apt/sources.list.d/stebbins-handbrake-snapshots-saucy.list
           deb http://ppa.launchpad.net/stebbins/handbrake-snapshots/ubuntu saucy main
           deb-src http://ppa.launchpad.net/stebbins/handbrake-snapshots/ubuntu saucy main



and here is the apt policy ia32-libs:
Code: Select all
ia32-libs:
  Installed: (none)
  Candidate: 2013.11.25.2
  Version table:
     2013.11.25.2 0
        700 http://packages.linuxmint.com/ petra/main amd64 Packages

Does this mean only amd64 packages???
Last edited by Pilosopong Tasyo on Fri Jun 06, 2014 8:34 am, edited 1 time in total.
Reason: Please enclose program code and terminal output in [code]...[/code] tags to preserve any formatting, improve readability, and to prevent unnecessary scrolling. Thanks.
detrix42
Level 1
Level 1
 
Posts: 4
Joined: Sun Jan 05, 2014 3:50 am

Re: LinuxMint 17, can not install ia32-libs

Postby Monsta on Fri Jun 06, 2014 8:22 am

Did you try to upgrade from Mint 16 to 17? You have the wrong sources list.
Run Software Sources and choose any mirror there to correct it.
Monsta
Level 8
Level 8
 
Posts: 2337
Joined: Fri Aug 19, 2011 3:46 am

Re: LinuxMint 17, can not install ia32-libs

Postby jahid on Fri Jun 06, 2014 8:26 am

What do you mean by "adding i386 architecture"?

I haven't added anything, just installed ia32-libs and it worked without any problem.
jahid@HP ProBook 440 G1 Laptop
User avatar
jahid
Level 5
Level 5
 
Posts: 645
Joined: Sat Dec 07, 2013 4:07 pm
Location: Khulna, Bangladesh

Re: LinuxMint 17, can not install ia32-libs

Postby ecthelion on Mon Jun 30, 2014 11:54 am

Hi, I'm there with the same problem.

When I try to install ia32-libs, apt tries to uninstall some 64 bit packages without replacement:

Code: Select all
sudo apt-get install ia32-libs libcupsimage2:i386 libcupsfilters1:i386
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
  bluez-alsa:i386 foomatic-filters glib-networking:i386
  gstreamer0.10-plugins-base:i386 gstreamer0.10-plugins-good:i386
  gtk2-engines:i386 gtk2-engines-murrine:i386 gtk2-engines-oxygen:i386
  gtk2-engines-pixbuf:i386 gvfs:i386 gvfs-libs:i386 ibus-gtk:i386 libaa1:i386
  libacl1:i386 libaio1:i386 libao4:i386 libatk1.0-0:i386 libattr1:i386
  libaudiofile1:i386 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libavc1394-0:i386 libbz2-1.0:i386 libcaca0:i386
  libcairo-gobject2:i386 libcairo2:i386 libcanberra-gtk-module:i386
  libcanberra-gtk0:i386 libcanberra0:i386 libcap2:i386 libcapi20-3:i386
  libcdparanoia0:i386 libcroco3:i386 libcups2:i386 libcurl3:i386
  libdatrie1:i386 libdbus-glib-1-2:i386 libdrm-intel1:i386
  libdrm-nouveau2:i386 libdrm-radeon1:i386 libdv4:i386 libelf1:i386
  libesd0:i386 libfluidsynth1:i386 libgail-common:i386 libgail18:i386
  libgconf-2-4:i386 libgdbm3:i386 libgdk-pixbuf2.0-0:i386 libgettextpo0:i386
  libgl1-mesa-dri:i386 libgpm2:i386 libgraphite2-3:i386 libgssapi-krb5-2:i386
  libgtk2.0-0:i386 libgudev-1.0-0:i386 libharfbuzz0b:i386 libibus-1.0-5:i386
  libidn11:i386 libiec61883-0:i386 libieee1284-3:i386 libjasper1:i386
  libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386
  libllvm3.4:i386 libmad0:i386 libmikmod2:i386 libncursesw5:i386 libnspr4:i386
  libnss3:i386 libodbc1:i386 libpango-1.0-0:i386 libpango1.0-0:i386
  libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386 libpangox-1.0-0:i386
  libpangoxft-1.0-0:i386 libpciaccess0:i386 libpixman-1-0:i386 libproxy1:i386
  libpulse-mainloop-glib0:i386 libpulsedsp:i386 libqt4-designer:i386
  libqt4-qt3support:i386 libqt4-scripttools:i386 libqt4-svg:i386
  libqt4-test:i386 libraw1394-11:i386 libreadline6:i386 librsvg2-2:i386
  librsvg2-common:i386 librtmp0:i386 libsane:i386 libsdl-image1.2:i386
  libsdl-mixer1.2:i386 libsdl-net1.2:i386 libsdl-ttf2.0-0:i386
  libsdl1.2debian:i386 libsecret-1-0:i386 libshout3:i386 libslang2:i386
  libsoup-gnome2.4-1:i386 libsoup2.4-1:i386 libspeex1:i386 libssl0.9.8:i386
  libstdc++5:i386 libtag1-vanilla:i386 libtag1c2a:i386 libtdb1:i386
  libthai0:i386 libtheora0:i386 libunistring0:i386 libv4l-0:i386
  libv4lconvert0:i386 libvisual-0.4-0:i386 libvorbisfile3:i386
  libwavpack1:i386 libwebp5:i386 libxaw7:i386 libxcb-render0:i386
  libxcb-shm0:i386 libxcomposite1:i386 libxcursor1:i386 libxft2:i386
  libxinerama1:i386 libxmu6:i386 libxp6:i386 lprng odbcinst
  odbcinst1debian2:i386 odbcinst1debian2 xaw3dg:i386
Paquetes sugeridos:
  murrine-themes:i386 kde-config-gtk-style:i386 gvfs-backends-goa:i386
  libcanberra-pulse:i386 isdnutils-doc:i386 libdv-bin:i386 oss-compat:i386
  pulseaudio-esound-compat:i386 libglide3:i386 gpm:i386 krb5-doc:i386
  krb5-user:i386 libjasper-runtime:i386 libmyodbc:i386 odbc-postgresql:i386
  tdsodbc:i386 unixodbc-bin:i386 ttf-baekmuk:i386 ttf-arphic-gbsn00lp:i386
  ttf-arphic-bsmi00lp:i386 ttf-arphic-gkai00mp:i386 ttf-arphic-bkai00mp:i386
  libraw1394-doc:i386 librsvg2-bin:i386 hplip:i386 hpoj:i386
  libsane-extras:i386 speex:i386 magicfilter lprng-doc
Paquetes recomendados:
  gstreamer0.10-x:i386 libtxc-dxtn-s2tc0:i386 libtxc-dxtn0:i386
  libgtk2.0-bin:i386 musescore-soundfont-gm:i386 fluid-soundfont-gm:i386
  freepats:i386 libvisual-0.4-plugins:i386
Los siguientes paquetes se ELIMINARÁN:
  atril bluez-cups cups cups-bsd cups-client cups-core-drivers cups-filters
  cups-filters-core-drivers ghostscript ghostscript-x gimp hplip
  libcupsfilters1 libcupsimage2 libgs9 libspectre1 mint-meta-mate
  printer-driver-c2esp printer-driver-gutenprint printer-driver-hpcups
  printer-driver-pnm2ppa printer-driver-postscript-hp printer-driver-ptouch
  printer-driver-pxljr printer-driver-sag-gdi printer-driver-splix
Se instalarán los siguientes paquetes NUEVOS:
  bluez-alsa:i386 foomatic-filters glib-networking:i386
  gstreamer0.10-plugins-base:i386 gstreamer0.10-plugins-good:i386
  gtk2-engines:i386 gtk2-engines-murrine:i386 gtk2-engines-oxygen:i386
  gtk2-engines-pixbuf:i386 gvfs:i386 gvfs-libs:i386 ia32-libs ibus-gtk:i386
  libaa1:i386 libacl1:i386 libaio1:i386 libao4:i386 libatk1.0-0:i386
  libattr1:i386 libaudiofile1:i386 libavahi-client3:i386
  libavahi-common-data:i386 libavahi-common3:i386 libavc1394-0:i386
  libbz2-1.0:i386 libcaca0:i386 libcairo-gobject2:i386 libcairo2:i386
  libcanberra-gtk-module:i386 libcanberra-gtk0:i386 libcanberra0:i386
  libcap2:i386 libcapi20-3:i386 libcdparanoia0:i386 libcroco3:i386
  libcups2:i386 libcupsfilters1:i386 libcupsimage2:i386 libcurl3:i386
  libdatrie1:i386 libdbus-glib-1-2:i386 libdrm-intel1:i386
  libdrm-nouveau2:i386 libdrm-radeon1:i386 libdv4:i386 libelf1:i386
  libesd0:i386 libfluidsynth1:i386 libgail-common:i386 libgail18:i386
  libgconf-2-4:i386 libgdbm3:i386 libgdk-pixbuf2.0-0:i386 libgettextpo0:i386
  libgl1-mesa-dri:i386 libgpm2:i386 libgraphite2-3:i386 libgssapi-krb5-2:i386
  libgtk2.0-0:i386 libgudev-1.0-0:i386 libharfbuzz0b:i386 libibus-1.0-5:i386
  libidn11:i386 libiec61883-0:i386 libieee1284-3:i386 libjasper1:i386
  libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386
  libllvm3.4:i386 libmad0:i386 libmikmod2:i386 libncursesw5:i386 libnspr4:i386
  libnss3:i386 libodbc1:i386 libpango-1.0-0:i386 libpango1.0-0:i386
  libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386 libpangox-1.0-0:i386
  libpangoxft-1.0-0:i386 libpciaccess0:i386 libpixman-1-0:i386 libproxy1:i386
  libpulse-mainloop-glib0:i386 libpulsedsp:i386 libqt4-designer:i386
  libqt4-qt3support:i386 libqt4-scripttools:i386 libqt4-svg:i386
  libqt4-test:i386 libraw1394-11:i386 libreadline6:i386 librsvg2-2:i386
  librsvg2-common:i386 librtmp0:i386 libsane:i386 libsdl-image1.2:i386
  libsdl-mixer1.2:i386 libsdl-net1.2:i386 libsdl-ttf2.0-0:i386
  libsdl1.2debian:i386 libsecret-1-0:i386 libshout3:i386 libslang2:i386
  libsoup-gnome2.4-1:i386 libsoup2.4-1:i386 libspeex1:i386 libssl0.9.8:i386
  libstdc++5:i386 libtag1-vanilla:i386 libtag1c2a:i386 libtdb1:i386
  libthai0:i386 libtheora0:i386 libunistring0:i386 libv4l-0:i386
  libv4lconvert0:i386 libvisual-0.4-0:i386 libvorbisfile3:i386
  libwavpack1:i386 libwebp5:i386 libxaw7:i386 libxcb-render0:i386
  libxcb-shm0:i386 libxcomposite1:i386 libxcursor1:i386 libxft2:i386
  libxinerama1:i386 libxmu6:i386 libxp6:i386 lprng odbcinst
  odbcinst1debian2:i386 odbcinst1debian2 xaw3dg:i386
0 actualizados, 138 se instalarán, 26 para eliminar y 1 no actualizados.
Necesito descargar 35,2 MB de archivos.
Se utilizarán 106 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n]


I have to add libcupsimage2:i386 libcupsfilters1:i386 like dependencies.

This is important for me to install Google Earth and Zimbra Desktop

My system is Linux Mint 17 Mate

Sorry for my poor english
Regards,
ecthelion
Level 1
Level 1
 
Posts: 2
Joined: Mon Jun 30, 2014 11:40 am

Re: LinuxMint 17, can not install ia32-libs

Postby Monsta on Tue Jul 01, 2014 3:45 am

ecthelion wrote:Hi, I'm there with the same problem.

Then the same question for you - post the output of:
Code: Select all
inxi -Sr
Code: Select all
apt policy ia32-libs
Monsta
Level 8
Level 8
 
Posts: 2337
Joined: Fri Aug 19, 2011 3:46 am

Re: LinuxMint 17, can not install ia32-libs

Postby ecthelion on Wed Jul 02, 2014 12:39 pm

Monsta wrote:
ecthelion wrote:Hi, I'm there with the same problem.

Then the same question for you - post the output of:
Code: Select all
inxi -Sr
Code: Select all
apt policy ia32-libs


Ok, I forget to append that :lol: :lol: :lol:

The output is:

Code: Select all
# inxi -Sr
System:    Host: COOTELADSERE01 Kernel: 3.13.0-24-generic x86_64 (64 bit) Desktop: N/A Distro: Linux Mint 17 Qiana
Repos:     Active apt sources in file: /etc/apt/sources.list.d/dockbar-main-ppa-trusty.list                                                                                                               
           deb http://ppa.launchpad.net/dockbar-main/ppa/ubuntu trusty main                                                                                                                               
           Active apt sources in file: /etc/apt/sources.list.d/getdeb.list                                                                                                                                 
           deb http://archive.getdeb.net/ubuntu trusty-getdeb apps                                                                                                                                         
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list                                                                                                                         
           deb http://dl.google.com/linux/chrome/deb/ stable main                                                                                                                                         
           Active apt sources in file: /etc/apt/sources.list.d/google-earth.list                                                                                                                           
           deb http://dl.google.com/linux/earth/deb/ stable main                                                                                                                                           
           Active apt sources in file: /etc/apt/sources.list.d/google-talkplugin.list                                                                                                                     
           deb http://dl.google.com/linux/talkplugin/deb/ stable main                                                                                                                                     
           Active apt sources in file: /etc/apt/sources.list.d/libdvdcss.list
           deb http://download.videolan.org/pub/debian/stable/ /
           Active apt sources in file: /etc/apt/sources.list.d/libreoffice-ppa-trusty.list
           deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu trusty main
           deb-src http://ppa.launchpad.net/libreoffice/ppa/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/me-davidsansome-clementine-trusty.list
           deb http://ppa.launchpad.net/me-davidsansome/clementine/ubuntu trusty main
           deb-src http://ppa.launchpad.net/me-davidsansome/clementine/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/noobslab-icons-trusty.list
           deb http://ppa.launchpad.net/noobslab/icons/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/noobslab-themes-trusty.list
           deb http://ppa.launchpad.net/noobslab/themes/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com qiana main upstream import
           deb http://extra.linuxmint.com qiana main
           deb http://mirrors.liquidweb.com/ubuntu trusty main restricted universe multiverse
           deb http://mirrors.liquidweb.com/ubuntu trusty-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ trusty partner
           Active apt sources in file: /etc/apt/sources.list.d/teejee2008-ppa-trusty.list
           deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/ubuntu-wine-ppa-trusty.list
           deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/webupd8team-java-trusty.list
           deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main


Code: Select all
# apt policy ia32-libs
ia32-libs:
  Instalados: (ninguno)
  Candidato:  2014.05.14
  Tabla de versión:
     2014.05.14 0
        700 http://packages.linuxmint.com/ qiana/main amd64 Packages


Thanks Monsta.
ecthelion
Level 1
Level 1
 
Posts: 2
Joined: Mon Jun 30, 2014 11:40 am

Re: LinuxMint 17, can not install ia32-libs

Postby Monsta on Thu Jul 03, 2014 3:09 am

Your repositories look alright, but I suspect some PPAs might get in the way if they contain 32-bit packages (e.g. Wine PPA).
You might try disabling all the PPAs and the external repos and then installing ia32-libs again.
Monsta
Level 8
Level 8
 
Posts: 2337
Joined: Fri Aug 19, 2011 3:46 am

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: No registered users and 4 guests