broken packages

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

broken packages

Postby jmidd on Fri Jun 13, 2014 10:48 am

I am new to Linux. I installed Linux MATE 32x on my desktop and every time I try to udpate I get the same errors. It tells me I have 8 broken pages. When I try to install them or the latest updates I get the following error:

E: /var/cache/apt/archives/libqtgui4_4%3a4.8.4+dfsg-0ubuntu18.3_i386.deb: cannot copy extracted data for './usr/lib/i386-linux-gnu/libQtGui.so.4.8.4' to '/usr/lib/i386-linux-gnu/libQtGui.so.4.8.4.dpkg-new': unexpected end of file or stream
jmidd
Level 1
Level 1
 
Posts: 1
Joined: Fri Jun 13, 2014 10:12 am

Linux Mint is funded by ads and donations.
 

Re: broken packages

Postby karlchen on Fri Jun 13, 2014 11:38 am

Hello, jmidd.

The following steps are suggested: Plrease, open a terminal window and execute the following commands in the given order:
Code: Select all
sudo rm /var/cache/apt/archives/libqtgui4_4%3a4.8.4+dfsg-0ubuntu18.3_i386.deb
sudo apt-get update
sudo apt-get --fix-broken install
sudo apt-get upgrade

It would be nice if you posted the complete screen output, in particular if any error occurs, e.g. a complaint about broken packages.

Kind regards,
Karl
--
P.S.:
How To Fix Broken Packages Using The Terminal ...
Image
Endless legions of bigoted, brutal, bloodthirsty Orcs from the dark land of Mordor are bringing desolation, despair and death to the poor inhabitants of the Middle East. [1]
User avatar
karlchen
Level 10
Level 10
 
Posts: 3131
Joined: Sat Dec 31, 2011 7:21 am


Return to Other topics

Who is online

Users browsing this forum: No registered users and 5 guests