Beryl problem

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Beryl problem

Postby Galak6 on Mon Mar 19, 2007 10:20 am

Hello,

This is the second time I tried Linux mint, and I think that this time is THE time:) I think that I will definitively switch for mint.

I have also try beryl, find a thread talking about installing beryl on mint, I have done every step, but I don't have any 3D effect.

here is what I have in the terminal :



Code: Select all
Detected xserver                                : AIGLX

Checking Display :0.0 ...

Checking for XComposite extension               : passed (v0.3)
Checking for XDamage extension                  : passed
Checking for RandR extension                    : passed
Checking for XSync extension                    : passed

Checking Screen 0 ...

libGL warning: 3D driver claims to not support visual 0x42
Checking for GLX_SGIX_fbconfig                  : passed
Checking for GLX_EXT_texture_from_pixmap        : passed
Checking for non power of two texture support   : failed

Support for non power of two textures missing
galak6@galak6-laptop:~$ libGL warning: 3D driver claims to not support visual 0x42
beryl: Support for non power of two textures missing
beryl: Failed to manage screen: 0
beryl: No manageable screens found on display :0.0


there's one failed as you can see, but don't know if I can solve it or perhaps it's an hardware issue ?

Got a laptop with a S3 savageDDR and didn't find nothing about that, always talking about ATI and Nvidia cards. :(

I hope to find someone for helping me :p

thanks

ps : I got the emerald icon next to the date in the bottom bar of my screen, but it's metacity and not bery, when I check Beryl, there's that on my terminal :

Code: Select all
(emerald:8642): Gdk-CRITICAL **: gdk_drawable_unref: assertion `GDK_IS_DRAWABLE (drawable)' failed
Reloading...

Galak6
Level 1
Level 1
 
Posts: 5
Joined: Fri Feb 02, 2007 3:18 am

Linux Mint is funded by ads and donations.
 

Postby Husse on Tue Mar 20, 2007 7:36 am

laptop with a S3 savageDDR ??
That must be an old one - as far as I know S3 was discontinued in spring of 1999, and this means that you have limited graphics capability by todays standards.
You actually have the driver in synaptics. If it is not installed, install :)
The failures you see are hardware related. This is definitely hardware:
non power of two texture support : failed
and the beryl errors are most likely a related to that
A quick google "S3 savage laptop" reveals that there are lots of people with problems, so you might have to stay with Metacity.
This thread contains to a possible solution
http://ubuntuforums.org/showthread.php? ... eb&t=75393
but it includes recompiling the kernel.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Galak6 on Tue Mar 20, 2007 1:19 pm

well thanks for the answer, think I will stay with no "3D" desktop :p
Galak6
Level 1
Level 1
 
Posts: 5
Joined: Fri Feb 02, 2007 3:18 am


Return to Other topics

Who is online

Users browsing this forum: No registered users and 2 guests