update problem

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

update problem

Postby tyhee88 on Sun Jun 29, 2014 3:11 pm

Hi. I'm running Linux 13 32 bit with a Mate desktop on my laptop with a quad core AMD A6-3400 cpu, 4G of RAM (3 recognized).

When I try to do an Update using update manager I get a message saying:

E: Internal Error, No file name for libuuid1

My preference is to stick with Mint 13 for a while longer rather than upgrade to Mint 17.

Is anyone able and willing to let me know how to fix this?

Thanks, all.

Bob C.
tyhee88
Level 1
Level 1
 
Posts: 15
Joined: Mon Jun 14, 2010 8:53 pm

Linux Mint is funded by ads and donations.
 

Re: update problem

Postby karlchen on Mon Jun 30, 2014 8:40 am

Hello, tyhee88.

The error message
Code: Select all
E: Internal Error, No file name for libuuid1
alone is not really sufficient to analyze what is wrong and to tell hwo to solve the issue.

Please, open a terminal window. Execute the following commands in the given order. Post the complete screen output here so we can diagnose what is wrong.
  1. Is the file named in the error message really missing:
    Code: Select all
    dpkg --list libuuid1
  2. Which repositories will be queried?
    Code: Select all
    inxi -r
  3. Does querying these repositories work without error?
    Code: Select all
    sudo apt-get update
  4. Provided no error has occurred so far, you might try the third command as well. Note: this commandline will try to install all found updates:
    Code: Select all
    sudo apt-get upgrade
Kind regards,
Karl
Image
User avatar
karlchen
Level 10
Level 10
 
Posts: 3152
Joined: Sat Dec 31, 2011 7:21 am

Re: update problem

Postby tyhee88 on Mon Jun 30, 2014 11:15 am

Thanks Karl.

1. To dpkg --list libuuid1:

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
iU libuuid1 2.20.1-1ubuntu Universally Unique ID library

2. To inxi -r:

Repos: Active apt sources in file: /etc/apt/sources.list
deb http://packages.linuxmint.com/ maya main upstream import
deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ precise partner

3. To apt-get update:

Get:1 http://packages.linuxmint.com maya Release.gpg [198 B]
Get:2 http://packages.linuxmint.com maya Release [18.6 kB]
Hit http://archive.canonical.com precise Release.gpg
Hit http://archive.ubuntu.com precise Release.gpg
Get:3 http://archive.ubuntu.com precise-updates Release.gpg [198 B]
Hit http://security.ubuntu.com precise-security Release.gpg
Get:4 http://packages.linuxmint.com maya/main i386 Packages [18.2 kB]
Hit http://security.ubuntu.com precise-security Release
Hit http://archive.canonical.com precise Release
Hit http://archive.ubuntu.com precise Release
Hit http://security.ubuntu.com precise-security/main i386 Packages
Get:5 http://packages.linuxmint.com maya/upstream i386 Packages [10.6 kB]
Get:6 http://packages.linuxmint.com maya/import i386 Packages [42.0 kB]
Get:7 http://archive.ubuntu.com precise-updates Release [49.6 kB]
Hit http://archive.canonical.com precise/partner i386 Packages
Hit http://security.ubuntu.com precise-security/restricted i386 Packages
Hit http://security.ubuntu.com precise-security/universe i386 Packages
Hit http://security.ubuntu.com precise-security/multiverse i386 Packages
Hit http://security.ubuntu.com precise-security/main TranslationIndex
Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex
Hit http://security.ubuntu.com precise-security/restricted TranslationIndex
Hit http://security.ubuntu.com precise-security/universe TranslationIndex
Ign http://packages.linuxmint.com maya/import TranslationIndex
Ign http://archive.canonical.com precise/partner TranslationIndex
Hit http://security.ubuntu.com precise-security/main Translation-en
Hit http://security.ubuntu.com precise-security/multiverse Translation-en
Hit http://security.ubuntu.com precise-security/restricted Translation-en
Ign http://packages.linuxmint.com maya/main TranslationIndex
Hit http://security.ubuntu.com precise-security/universe Translation-en
Ign http://packages.linuxmint.com maya/upstream TranslationIndex
Hit http://archive.ubuntu.com precise/main i386 Packages
Hit http://archive.ubuntu.com precise/restricted i386 Packages
Hit http://archive.ubuntu.com precise/universe i386 Packages
Hit http://archive.ubuntu.com precise/multiverse i386 Packages
Hit http://archive.ubuntu.com precise/main TranslationIndex
Hit http://archive.ubuntu.com precise/multiverse TranslationIndex
Hit http://archive.ubuntu.com precise/restricted TranslationIndex
Hit http://archive.ubuntu.com precise/universe TranslationIndex
Get:8 http://archive.ubuntu.com precise-updates/main i386 Packages [846 kB]
Ign http://packages.linuxmint.com maya/import Translation-en_CA
Ign http://archive.canonical.com precise/partner Translation-en_CA
Ign http://packages.linuxmint.com maya/import Translation-en
Ign http://packages.linuxmint.com maya/main Translation-en_CA
Ign http://archive.canonical.com precise/partner Translation-en
Ign http://packages.linuxmint.com maya/main Translation-en
Ign http://packages.linuxmint.com maya/upstream Translation-en_CA
Ign http://packages.linuxmint.com maya/upstream Translation-en
Get:9 http://archive.ubuntu.com precise-updates/restricted i386 Packages [13.7 kB]
Get:10 http://archive.ubuntu.com precise-updates/universe i386 Packages [251 kB]
Get:11 http://archive.ubuntu.com precise-updates/multiverse i386 Packages [15.5 kB]
Get:12 http://archive.ubuntu.com precise-updates/main TranslationIndex [3,564 B]
Get:13 http://archive.ubuntu.com precise-updates/multiverse TranslationIndex [2,605 B]
Get:14 http://archive.ubuntu.com precise-updates/restricted TranslationIndex [2,461 B]
Get:15 http://archive.ubuntu.com precise-updates/universe TranslationIndex [2,850 B]
Hit http://archive.ubuntu.com precise/main Translation-en_CA
Hit http://archive.ubuntu.com precise/main Translation-en
Hit http://archive.ubuntu.com precise/multiverse Translation-en
Hit http://archive.ubuntu.com precise/restricted Translation-en
Hit http://archive.ubuntu.com precise/universe Translation-en_CA
Hit http://archive.ubuntu.com precise/universe Translation-en
Hit http://archive.ubuntu.com precise-updates/main Translation-en_CA
Get:16 http://archive.ubuntu.com precise-updates/main Translation-en [358 kB]
Hit http://archive.ubuntu.com precise-updates/multiverse Translation-en
Hit http://archive.ubuntu.com precise-updates/restricted Translation-en
Hit http://archive.ubuntu.com precise-updates/universe Translation-en_CA
Get:17 http://archive.ubuntu.com precise-updates/universe Translation-en [142 kB]
Fetched 1,776 kB in 5s (334 kB/s)
Reading package lists... Done

4. To apt-get upgrade (which I'd previously tried):

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
linux-generic linux-headers-generic linux-image-generic
The following packages will be upgraded:
apt-transport-https apt-utils base-files dbus dbus-x11 firefox
firefox-locale-en fonts-opensymbol gir1.2-dbusmenu-glib-0.4
gir1.2-dbusmenu-gtk-0.4 iproute libapt-inst1.4 libavcodec53 libavformat53
libavutil51 libblkid1 libdbus-1-3 libdbus-glib-1-2 libdbusmenu-glib4
libdbusmenu-gtk3-4 libdbusmenu-gtk4 libdrm-intel1 libdrm-nouveau1a
libdrm-radeon1 libdrm2 libgnutls26 libjson0 libmount1 libpostproc52
libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-common
libreoffice-core libreoffice-draw libreoffice-emailmerge libreoffice-gnome
libreoffice-gtk libreoffice-help-en-us libreoffice-impress
libreoffice-java-common libreoffice-math libreoffice-style-human
libreoffice-style-tango libreoffice-writer libsmbclient libssl1.0.0
libswscale2 libwbclient0 libxml2 linux-firmware linux-libc-dev
linux-sound-base mountall openssl python-libxml2 python-uno samba
samba-common samba-common-bin smbclient thunderbird
thunderbird-gnome-support uno-libs3 ure uuid-runtime xorg xserver-xorg
xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev
xserver-xorg-input-synaptics xserver-xorg-input-vmmouse
xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-intel
xserver-xorg-video-nouveau xserver-xorg-video-openchrome
xserver-xorg-video-qxl xserver-xorg-video-vmware
80 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
2 not fully installed or removed.
Need to get 136 kB/241 MB of archives.
After this operation, 10.8 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com/ubuntu/ precise-updates/main libdrm2 i386 2.4.52-1~precise1 [27.5 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ precise-updates/main libdrm-intel1 i386 2.4.52-1~precise1 [65.9 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ precise-updates/main libdrm-nouveau1a i386 2.4.52-1~precise1 [14.2 kB]
Get:4 http://archive.ubuntu.com/ubuntu/ precise-updates/main libdrm-radeon1 i386 2.4.52-1~precise1 [28.6 kB]
Fetched 136 kB in 1s (119 kB/s)
E: Internal Error, No file name for libuuid1


Thanks for anything you can do to help.

b
tyhee88
Level 1
Level 1
 
Posts: 15
Joined: Mon Jun 14, 2010 8:53 pm

Re: update problem

Postby karlchen on Mon Jun 30, 2014 2:48 pm

Hello, Bob C.

Found this thread. Someone reported the same error message as you. Affected software package in that case libc6, not libuuid1. Yet, this should not have any effect on the steps which finally solved the problem for that guy: update errors, advice given by blackwolf.

The problem is that in your case the software package libuuid1 is in an half-installed state. The way to solve this problem is by forcing dkpg to start all over from the scratch with this software package and potentially dependent packages as well.

Kind regards,
Karl
Image
User avatar
karlchen
Level 10
Level 10
 
Posts: 3152
Joined: Sat Dec 31, 2011 7:21 am

Re: update problem

Postby zorman32 on Mon Jun 30, 2014 9:27 pm

I'm using mint 16, so I'm not quite sure if what I'm suggesting will work or not, but on my system 'apt-get -f install' will fix half installed packages, there might be a dpkg switch to do the same, but as I understand the two, dpkg is mainly for packages that make use of debconf, while apt is a broader reaching manager that handles packages not necessarily handled by debconf. I think the main difference is that apt is more ancient, while dpkg is an adaptation of it specifically designed for packages under debian's systems that offer configuration options during installation. Anyway, if apt-get -f install doesn't do it, it will at least tell you what command you should run under dpkg to straighten out the issues that won't let it fix the problem entirely. Good luck (it may be that the half installed packages were waiting for choices to be made, and apparentlly did not recieve the instructions they were looking for to fully set them up? - if this is the case, then find out which packages are half installed (apt-get -f install) and then try dpkg-reconfigure *filename*

all else fails try man dpkg, or man apt-get for better options that may be available for your box.

Good luck
zorman32
Level 1
Level 1
 
Posts: 1
Joined: Mon Jun 30, 2014 4:08 pm

Re: update problem

Postby tyhee88 on Wed Jul 02, 2014 1:37 pm

1. @karlchen-Thanks. I went through the advice from Blackwolf on another thread but it didn't solve things for me. Essentially Blackwolf made 3 tries.

The first one involved sudo-dpkg --purge. That won't work on libuuid1 because of dependency problems (the first one mentioned being util-linux, but there are several others.)

His second group of commands contained among other commands apt-get install -fy. That failed with the same error message about the libuuid1 name as mentioned in my first post.

His third group of suggestions started with dpkg -i /var/cache/apt/archive/*.deb. That fails with a No such file or directory error. Changing archive to archives didn't help, nor did adding /partial after archives.

2. @zorman32-Thanks. I tried your suggestions. apt-get -f install fails with the same error message referred to in my original post without any information about any other packages. i.e. there was no information that would tell me what packages I needed to use dpkg on. The full output was:
$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 87 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
E: Internal Error, No file name for libuuid1

I tried the 2nd command you mentioned on libuuid1 and got another error:

sudo dpkg-reconfigure libuuid1
/usr/sbin/dpkg-reconfigure: libuuid1 is broken or not fully installed

Any more ideas?

Thanks all for your help.

b
tyhee88
Level 1
Level 1
 
Posts: 15
Joined: Mon Jun 14, 2010 8:53 pm

Re: update problem

Postby SMarais on Tue Jul 08, 2014 12:27 pm

you could try a
Code: Select all
sudo apt-get purge libuuid1
and then followed by
Code: Select all
sudo apt-get install libuuid1
Do not accept the purge if it removes more than just the lib.
SMarais
Level 3
Level 3
 
Posts: 103
Joined: Mon Jan 21, 2013 5:47 pm

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: xenopeek and 3 guests