Nvidia screen resolution max 1024 x 768?

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Nvidia screen resolution max 1024 x 768?

Postby ambertone on Tue Mar 20, 2007 7:52 am

Hi all,

Using an Nvidia FX-5500 I've downloaded the latest drivers using:

sudo apt-get install nvidia-glx nvidia-kernel-common
sudo nvidia-xconfig

and the best res I can get is 1024 x 768 @ 75hz. I can change the res down but no option for 1280 x 1024 (which I need) Also the refresh rate is stuck on 75hz (and this monitor is a 60hz unit)

Any ideas?

Cheers

Rod
User avatar
ambertone
Level 3
Level 3
 
Posts: 146
Joined: Thu Jan 04, 2007 6:12 am

Linux Mint is funded by ads and donations.
 

Postby Husse on Tue Mar 20, 2007 9:36 am

Mint comes with envy, so to get the latest nVidia or ATI driver you just log out to a terminal and type "envy" :)
Do you have "nVidia X server settings" under System tools in Mint menu? Have you tried to set the values there?
If not - use envy. If you have that option and it doesn't help you have to edit xorg.conf. Move to etc/X11 and open xorg.conf Look at Section "Screen" and the resolutions you have there.
If 1024 x 768 is max, just add the resolution(s) you want.
Look at Section "Monitor" and the values for VertRefresh
You probably have to change that to something like 43 - 60
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby hairy_Palms on Tue Mar 20, 2007 11:11 am

75Hz is perfectly fine if its less than your max resolution, if i put my lcd down to 640x480 i can up it to 85hz (at 1440x900 its 57Hz)
User avatar
hairy_Palms
Level 4
Level 4
 
Posts: 297
Joined: Mon Nov 27, 2006 10:46 am

Postby ambertone on Wed Mar 21, 2007 7:22 am

OK, I can't find "system tools". Here is the content of the xorg.conf. I not that the 6800le is my old card and is no longer in this machine. It now has an FX5500. Envy only gives me option to install or uninstall the driver.

Section "Device"
Identifier "NVIDIA Corporation NV40.2 [GeForce 6800 LE]"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV40.2 [GeForce 6800 LE]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection


Cheers

Rod
User avatar
ambertone
Level 3
Level 3
 
Posts: 146
Joined: Thu Jan 04, 2007 6:12 am

Postby ambertone on Wed Mar 21, 2007 7:23 am

Also, when editing xorg.conf I can't save what I have changed. The save option is "greyed" out.

Rod
User avatar
ambertone
Level 3
Level 3
 
Posts: 146
Joined: Thu Jan 04, 2007 6:12 am

Postby clem on Wed Mar 21, 2007 7:36 am

Code: Select all
gksu gedit /etc/X11/xorg.conf &
User avatar
clem
Level 15
Level 15
 
Posts: 5545
Joined: Wed Nov 15, 2006 8:34 am

Postby ambertone on Wed Mar 21, 2007 8:06 am

No good, I get:

Fine day to work off excess energy. Steal something heavy.
rod@rod-desktop:~$ gksu gedit /etc/x11/xorg.conf &
[1] 6920
rod@rod-desktop:~$
(gedit:6921): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

Rod
User avatar
ambertone
Level 3
Level 3
 
Posts: 146
Joined: Thu Jan 04, 2007 6:12 am

Postby ambertone on Wed Mar 21, 2007 8:15 am

OK, when I put the x11 as X11 it opened, I was able to edit and it saved. I had to reboot. Now the res comes up in the menu but selecting it does not change the monitor to the resolution. Is this possibly a bug or an I missing something? Refresh is still stuck on 75hz.

Also in xorg.conf my old 6800LE is showing, not the current FX5500.

Rod
User avatar
ambertone
Level 3
Level 3
 
Posts: 146
Joined: Thu Jan 04, 2007 6:12 am

Postby ambertone on Wed Mar 21, 2007 8:23 am

Fixed, after doing the editing you need to run:

sudo dpkg-reconfigure -phigh xserver-xorg

Thanks to all for putting me on the right track. I've learned something new :-)

Rod
User avatar
ambertone
Level 3
Level 3
 
Posts: 146
Joined: Thu Jan 04, 2007 6:12 am

Postby Husse on Wed Mar 21, 2007 8:40 am

The error you got was because of the & that trailed the command. (And as you solved x not X)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Elthium on Mon Mar 26, 2007 1:20 am

I have the same problem as the OP, except that I can type in new resolution but when I try to save it tells me that I don't have permission to do so. How do I log in as root/admin to do the above? I thought that with ubuntu you always logged in as root?

Thx.
Elthium
Level 1
Level 1
 
Posts: 19
Joined: Mon Mar 26, 2007 1:04 am

Postby telic on Mon Mar 26, 2007 1:34 am

How do I log in as root/admin to do the above?


I just go to Terminal and type sudo gedit /etc/X11/xorg.conf to launch gEdit in SuperUser mode.

BTW, if you want to hard-code your monitor refresh rate for specific screen resolutions, you can do that in xorg.conf too. For example, to set 1280x1024 at 75Hz and 1024x768 at 60Hz...


SubSection "Display"
Depth 24
Modes "1280x1024
_75" "1024x768_60" "800x600" "640x480"
EndSubSection



----
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby Elthium on Mon Mar 26, 2007 2:51 am

Telic, I do a cut and paste of the command you posted, then hit enter and I'm asked for a password. The cursor just sits and blinks at me. There is no way I can input my password.

Any ideas?

Thx.
Elthium
Level 1
Level 1
 
Posts: 19
Joined: Mon Mar 26, 2007 1:04 am

Postby telic on Mon Mar 26, 2007 3:11 am

Any ideas?


You can also try gksu gedit /etc/X11/xorg.conf in Terminal. You need to be a SuperUser on that PC, of course.

Note that unlike the main Mint login, the Terminal password input won't echo anything for each character that you type, and the cursor just blinks without moving, so it looks like nothing is happening -- until you finish typing the password and then press the Enter key. Then gEdit should open in a separate window.

If that doesn't happen for you, I don't know what to suggest.


----
Last edited by telic on Mon Mar 26, 2007 6:15 am, edited 2 times in total.
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby ambertone on Mon Mar 26, 2007 3:40 am

BTW, if you want to hard-code your monitor refresh rate for specific screen resolutions, you can do that in xorg.conf too. For example, to set 1280x1024 at 75Hz and 1024x768 at 60Hz...


SubSection "Display"
Depth 24
Modes "1280x1024_75" "1024x768_60" "800x600" "640x480"

That's nice, cheers

Rod
User avatar
ambertone
Level 3
Level 3
 
Posts: 146
Joined: Thu Jan 04, 2007 6:12 am

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: No registered users and 7 guests