Problem After OpenGL Driver Installation

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help

Problem After OpenGL Driver Installation

Postby Frank_Licea on Tue Mar 27, 2007 3:36 pm

Hi,

I downloaded using the synaptic package manager an OpenGL driver for an NVIDIA graphics card. I guess I picked the wrong one because my Gnome desktop no longer loads.

Please be patient with me because I don't remember what exactly I downloaded. But here are the comands I used.

After installation I typed:

Code: Select all
nvidia-glx-config-enable


I got a message said someting about "If the configuration does not work correctly type in this command" :

Code: Select all
cp /var/backups/xorg/xorg.conf.2007-03-27-09:55:00/etc/x11/xorg.conf


After that I restarted, The Linux Mint load screen apears but before the OS fully loads I get a blue screen that says:

"Failed to start the X server (Your graphical interface). It is likely that it is not set up correctly. Would you like to view the X server output to diagnose the problem?"

When I press yes I get this info:

Code: Select all
X Window System Version 7.1.1
Release date: 12 May 2006
X Protocol Version 11, REvision 0, Release 7.1.1
Build Operating system: Linux flicea-laptop 2.6.17-11-generic #2 SMP
Thu Feb 1 19:52:28 UTC 2007 i686

Build Date: 07 July 2006
....
Module Loader present
Markers:(--)probed, (**) from config file, (==) default setting (++)
from command line, (!!) notice, (II) informational, (ww warning, (ee) error, (NI) not implemented, (??) unknown.

(==) Log File: "/var/log/Xorg.0.0.log" Time Tue Mar 27 13:22:55 2007
(==) Using config file: "/etc/x11/xorg.conf"
(WW) No matching Device section for instance (Bus ID PCI:1:0:0)
found
(EE) No devices detected.
Fatal server error: No screens found


After that Only the comand line loads, not the GUI.

Here is what I tried to do so far:

I typed:

Code: Select all
nvidia-glx-config-disable


then I rebooted but that did not work, I got the same result.

I tried typing in the comand I was given after enabling the driver but I'm not sure what to copy that file too.

I'm completly new at this I've only had Linux a few days. I'm not sure what to try next.
Frank_Licea
Level 1
Level 1
 
Posts: 2
Joined: Fri Mar 23, 2007 5:22 pm

Linux Mint is funded by ads and donations.
 

Postby Boo on Tue Mar 27, 2007 6:45 pm

boot into a text mode (run level 3) or if your desktop is not working you will be in text mode anyway.
Run envy. envy does all that video driver stuff for you. it should have been using nvidia drivers from the install.

# sudo envy

and choose option 1. (load nvidia drivers) hit enter.
then choose the last option to restart your desktop or exit and go to run level 5 if you were in run level 3.

# sudo init 5

Or reboot if you are paranoid about a clean start.

:D
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am


Return to Other topics

Who is online

Users browsing this forum: Google Adsense [Bot] and 7 guests