Can't get back to gnome from a "TTY terminal"

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Can't get back to gnome from a "TTY terminal"

Postby Husse on Tue Apr 03, 2007 10:10 am

No big deal, let's hope nothing serious lurks in the darkness here.
Ctrl+Alt+F1 (to F6) brings you to TTY1 (to 6)
To get back into gnome and your desktop you do Ctrl+Alt+F7
That brings me to a black screen with just a cursor - cursing my bad luck :)
I should see the desktop - right?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Postby NiksaVel on Tue Apr 03, 2007 11:09 am

yes you should :) maybe it's a screensaver gone bad or something?
User avatar
NiksaVel
Level 5
Level 5
 
Posts: 806
Joined: Wed Feb 28, 2007 4:06 am
Location: Croatia

Postby sanguinemoon on Tue Apr 03, 2007 3:05 pm

How weird. I can't get a virtual consoles either, but I used to be able to. With Metacity as the window manager, I could get back to Gnome, but with Beryl I couldn't.

I disabled screensavers, but got the same result.
User avatar
sanguinemoon
Level 2
Level 2
 
Posts: 77
Joined: Tue Mar 20, 2007 5:08 am

Postby telic on Wed Apr 04, 2007 8:03 am

This appears to be another manifestation of a known bug in the current nVidia drivers, which can cause a black screen. I've experienced this glitch with Bianca running Beryl 0.2.0 Emerald, and also with PCLinuxOS 2007 TR3 running Beryl 0.1.9999 Emerald. In both cases, the nVidia driver is version 1.0-9755.

I had a text editor open in X when I did CTRL-ALT-F1 to go TTY. I then did CTRL-ALT-F7 and got a black screen with an I-beam cursor. So, on a hunch, I blindly tapped a few keys and then CTRL-S. After restarting X, I reopened the text file and saw the letters that I had blindly typed at the black screen. Evidently, the earlier X session context had indeed resumed after TTY, but it wasn't displayed because of the nVidia driver glitch.

This test went the same on Bianca (GNOME) and PCLinuxOS (KDE).

The Beryl Manager applet allows easy switching to the Metacity (or KWin) window manager, so the immediate solution is to right-click on the taskbar ruby icon and select Switch Window Manager to enable Metacity (or KWin) before going to TTY, then re-enable Beryl upon return to X.

------
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby Husse on Wed Apr 04, 2007 9:54 am

Hi telic
That did not work for me (disabling beryl) But after I removed beryl completely F1 to 7 works the way they should.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby NiksaVel on Wed Apr 04, 2007 10:34 am

I also had problems with Beryl screwing up my keyboard... wasted some three weeks of forum surfing to get all the buttons working properly.... thought the problems were due to non standard (croatian) codepage...

In the end I realised that I lost the ability to control screensavers while beryl was on... i.e. I had them turned off but still the screensaver came on every 10 minutes or so... very annoying while you're watching a movie... that was the final straw so I removed beryl
User avatar
NiksaVel
Level 5
Level 5
 
Posts: 806
Joined: Wed Feb 28, 2007 4:06 am
Location: Croatia

Postby telic on Wed Apr 04, 2007 1:34 pm

Beryl can be twitchy, but it has me hooked on the glass (translucency) effect. It's a terrific visual enhancement for a stacked-windows multimedia GUI.

I don't play video games on my PC, so it's high time for the pixel-shader to get off of the pogey. And what a spiffy 3D-accelerated sight it is. Going back to a 2D desktop feels as maladroit as using a web browser that doesn't sport mouse-gestures.

Though I'm sure if my PC got as jiggered as yours had, I'd escort Beryl to the bit bucket.

-------
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby sanguinemoon on Sat Apr 07, 2007 3:56 am

Husse wrote:Hi telic
That did not work for me (disabling beryl) But after I removed beryl completely F1 to 7 works the way they should.


When I removed Beryl from my Startup Programs, it still didn't fix things and that seems like it should have had the seem effect of removing Beryl?
User avatar
sanguinemoon
Level 2
Level 2
 
Posts: 77
Joined: Tue Mar 20, 2007 5:08 am

Postby sanguinemoon on Sat Apr 07, 2007 4:04 am

I tried removing Beryl completely, but I still can't get a console with ctrl-alt f1-f8 :(
User avatar
sanguinemoon
Level 2
Level 2
 
Posts: 77
Joined: Tue Mar 20, 2007 5:08 am

Postby sanguinemoon on Sat Apr 07, 2007 4:10 am

Confirmed. It's the Nvidia driver. In my xorg.conf file, I changed to the nv driver, and now I can get consoles. But running like this means no 3D acceleration :roll:

Or if it's a bug just in the newest drivers, I could just remove the driver Envoy installed and use the driver the repositories. That means no Beryl without having to do some extra steps, but I can take or leave Beryl.
User avatar
sanguinemoon
Level 2
Level 2
 
Posts: 77
Joined: Tue Mar 20, 2007 5:08 am

Postby NiksaVel on Sat Apr 07, 2007 12:20 pm

have you tried simply uninstalling and reinstalling the driver through envy?
User avatar
NiksaVel
Level 5
Level 5
 
Posts: 806
Joined: Wed Feb 28, 2007 4:06 am
Location: Croatia

Postby sanguinemoon on Sat Apr 07, 2007 3:38 pm

That doesn't work
User avatar
sanguinemoon
Level 2
Level 2
 
Posts: 77
Joined: Tue Mar 20, 2007 5:08 am

Postby sanguinemoon on Sat Apr 07, 2007 7:16 pm

Just using the driver in the repositories does work though :)
User avatar
sanguinemoon
Level 2
Level 2
 
Posts: 77
Joined: Tue Mar 20, 2007 5:08 am

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: DTJ and 7 guests