slow down DHCP!

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

slow down DHCP!

Postby bodker on Sat Apr 07, 2007 9:46 pm

I'm running Mint via Parallels on a MacBook Pro. (Works great by the way! Parallels rocks!)

The only problem is that the network does not connect automatically. I have to click the network icon and select the wired network manually. In reality, this is not big deal. one click and I have internet...

The problem is I like to use enlightenment e17 as a window manager and there is no nice and easy network icon to click and fix the problem. Currently I have to boot in to gnome and connect to the net, log out, and then log in to e17.

I am no where near a linux expert so this may seem ridiculous, but it feels like mint just boots too fast (due to the nature of it being a virtual machine) for the DHCP connection to take hold.

Feel free to ridicule me if this is way off base. :D

Is there a way to delay the DHCP script so it will wait for a connection?

If not, what would the CLI command be to do the equivalent of selecting the wired network in network manager?

I'd like to able to set the default session to Enlightenment and fix the network directly from there.

Thanks!

/drew
bodker
Level 1
Level 1
 
Posts: 10
Joined: Sat Mar 10, 2007 1:39 am
Location: Chicago

Linux Mint is funded by ads and donations.
 

Postby telic on Sun Apr 08, 2007 1:49 am

The only problem is that the network does not connect automatically. I have to click the network icon and select the wired network manually.


Me too, and I'm running Mint on a regular PC. This little nuisance appears to be a feature that Bianca inherits from Ubuntu Edgy, and it's also passed along to Feisty. It arrived with Network Manager.

I wonder if Ubuntu has implemented it as a security measure, to prevent us Linux newbies from having an open Internet connection by default at boot-up?

I found the following instructions, which kick Network Manager to the curb without interfering with my ethernet Internet connection...

Disabling network manager in your gnome session will not work as that is just the 'notification area' for the network-manager service. To disable network-manager, either uninstall it (which will break ubuntu-desktop package) or do this:

Stop network manager...

sudo /etc/dbus-1/event.d/26NetworkManagerDispatcher stop
sudo /etc/dbus-1/event.d/25NetworkManager stop

Create two files with only the word 'exit' in them. These files are:

/etc/default/NetworkManager
/etc/default/NetworkManagerDispatcher



Reboot.

https://launchpad.net/ubuntu/+source/ne ... omments/19


------
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby bodker on Sun Apr 08, 2007 11:32 am

That's odd. I created this VM with the same ISO I used to dual boot my work laptop and my desktop at home. Neither of those machines have problems connecting automatically to the net.

Network manager works like I expect it would. It's only the Parallels install that gives me problems.

If you stop Network Manager what do you use to make the initial connection?

thanks for the input.

/drew
bodker
Level 1
Level 1
 
Posts: 10
Joined: Sat Mar 10, 2007 1:39 am
Location: Chicago

Postby telic on Sun Apr 08, 2007 12:21 pm

If you stop Network Manager what do you use to make the initial connection?


Bianca takes care of that. I don't ask, she don't tell. ;-)

My system settings -- found under the Bianca > Administration > Networking menu -- still specify Automatic Configuration (DHCP).

The only functional difference is that Network Manager is no longer an additional step that needs my attention. This means that my firewall (Firestarter) can now be a StartUp Program without complaining that there's no available connection. And I just blissfully call upon Firefox to cruise the Web, as usual.

I've read quite a bit of princess' about Network Manager within the Ubuntu herd.

Most other distros that I've played with (e.g. PCLinuxOS) don't use Network Manager. The port configuration and connection are made transparent by Linux. Now my Bianca does likewise.


-------
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby Red Knuckles on Sun Apr 29, 2007 2:32 pm

telic wrote:
The only problem is that the network does not connect automatically. I have to click the network icon and select the wired network manually.


Me too, and I'm running Mint on a regular PC. This little nuisance appears to be a feature that Bianca inherits from Ubuntu Edgy, and it's also passed along to Feisty. It arrived with Network Manager.

I wonder if Ubuntu has implemented it as a security measure, to prevent us Linux newbies from having an open Internet connection by default at boot-up?

I found the following instructions, which kick Network Manager to the curb without interfering with my ethernet Internet connection...

Disabling network manager in your gnome session will not work as that is just the 'notification area' for the network-manager service. To disable network-manager, either uninstall it (which will break ubuntu-desktop package) or do this:

Stop network manager...

sudo /etc/dbus-1/event.d/26NetworkManagerDispatcher stop
sudo /etc/dbus-1/event.d/25NetworkManager stop

Create two files with only the word 'exit' in them. These files are:

/etc/default/NetworkManager
/etc/default/NetworkManagerDispatcher



Reboot.

https://launchpad.net/ubuntu/+source/ne ... omments/19


------


Hey, Thanks. That worked for me in Bianca KDE.
Thanks,
Red Knuckles
Linux Mint KDE, Ubuntu Feisty, Debian Lenny, and Gentoo 2007.0
AMD64:AMD64 X2 4800+:4x1GB DDR2
800:GeForce 6150 256MB:ASUS M2NPV-VM:2x320GB
User avatar
Red Knuckles
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 07, 2007 2:57 am

Postby Boo on Sun Apr 29, 2007 8:03 pm

Sort of related... well it was network-manager.
I installed fiesty on my laptop.
setup wireless networking (admn-->networking) but it would not connect though i could see the network. :shock:

network-manager (icon next to the clock) did not work properly.
the solution I found was to delete/remove all non lo network devices found in :
/etc/network/interfaces
then use the network-manager (icon next to clock) to set up wireless.

I found this solution in the Ubuntu forum and it has been around since herd...
I suspect that the solution is to not use admin-->networking (wich is not network-manager) at all and just use the icon which is network manager.

by default all your interfaces are set to a roaming profile in 7.04, could this be your parallels network problem??

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am


Return to Other topics

Who is online

Users browsing this forum: karlchen and 6 guests