How to Autostart KNetworkManager. SOLVED!!!

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

How to Autostart KNetworkManager. SOLVED!!!

Postby Red Knuckles on Sun Apr 29, 2007 12:24 pm

How to get KNetworkManager to start automatically at login? I have clicked on >Options>Configure Autostart but I stall have start internet manually every time I log in. In other words whether I use KNetworkManager or not how do I get internet to start automatically upon login??? I have the Davicom Tulip Ethernet device which is problematic in some Linux distros. :?: :?: :?:
Last edited by Red Knuckles on Sun Apr 29, 2007 2:36 pm, edited 1 time in total.
Thanks,
Red Knuckles
Linux Mint KDE, Ubuntu Feisty, Debian Lenny, and Gentoo 2007.0
AMD64:AMD64 X2 4800+:4x1GB DDR2
800:GeForce 6150 256MB:ASUS M2NPV-VM:2x320GB
User avatar
Red Knuckles
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 07, 2007 2:57 am

Linux Mint is funded by ads and donations.
 

Postby telic on Sun Apr 29, 2007 2:14 pm

Check this other thread, to see if it might apply to your situation...

http://linuxmint.com/forum/viewtopic.php?p=13301

------
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby Red Knuckles on Sun Apr 29, 2007 2:31 pm

telic wrote:Check this other thread, to see if it might apply to your situation...

http://linuxmint.com/forum/viewtopic.php?p=13301

------


Holy Crap! That works. The KNetworkManager icon still pops up though I'd like to figure out how to stop that. Or I'll just hide it in system tray. Here's the instructions:

Disabling network manager in your gnome session will not work as that is just the 'notification area' for the network-manager service. To disable network-manager, either uninstall it (which will break ubuntu-desktop package) or do this:

Stop network manager...

sudo /etc/dbus-1/event.d/26NetworkManagerDispatcher stop
sudo /etc/dbus-1/event.d/25NetworkManager stop

Create two files with only the word 'exit' in them. These files are:

/etc/default/NetworkManager
/etc/default/NetworkManagerDispatcher

Reboot.

I know he's talking about Gnome but it worked for me in KDE. :lol:

That's one problem solved and two to go.
Thanks,
Red Knuckles
Linux Mint KDE, Ubuntu Feisty, Debian Lenny, and Gentoo 2007.0
AMD64:AMD64 X2 4800+:4x1GB DDR2
800:GeForce 6150 256MB:ASUS M2NPV-VM:2x320GB
User avatar
Red Knuckles
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 07, 2007 2:57 am

Postby Red Knuckles on Sun Apr 29, 2007 9:02 pm

Moderator should this be moved to 'Networking Forum'? Sorry if I posted in wrong forum. :oops:
Thanks,
Red Knuckles
Linux Mint KDE, Ubuntu Feisty, Debian Lenny, and Gentoo 2007.0
AMD64:AMD64 X2 4800+:4x1GB DDR2
800:GeForce 6150 256MB:ASUS M2NPV-VM:2x320GB
User avatar
Red Knuckles
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 07, 2007 2:57 am


Return to Other topics

Who is online

Users browsing this forum: Bing [Bot] and 4 guests