VIM and Syntax

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

VIM and Syntax

Postby pinger on Wed May 09, 2007 11:56 am

New install of Mint, when opening files in vi, I cannot enable the syntax option. Error:

Code: Select all
E319: Sorry, the command is not available in this version


The problem that I also have is that this machine does NOT have network connectivity. I do have access to the internet on another machine and can download any packages from the ubuntu repo that I need. Which packages do I need?

UPDATE: Nevermind. It needs vim (not tiny or common) and vim-runtime. Works! :)
pinger
Level 1
Level 1
 
Posts: 1
Joined: Wed May 09, 2007 11:53 am

Linux Mint is funded by ads and donations.
 

Re: VIM and Syntax

Postby scorp123 on Wed May 09, 2007 4:22 pm

pinger wrote:New install of Mint, when opening files in vi, I cannot enable the syntax option.
I see you found the solution yourself :wink: Yes, you need the full vim installation.

If you want the syntax highlighting to be always on by default you can modify the main config file:
Code: Select all
KDE: sudo kate /etc/vimrc
GNOME: sudo gedit /etc/vimrc
vi: vim /etc/vimrc

Add or edit this line so that it looks like this:
Code: Select all
...
syntax on
...
If you knew all of this already ... Oh well. Someone else will hopefully appreciate this info :wink:
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby Boo on Thu May 10, 2007 12:28 am

I love vi!

and vim!

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am


Return to Other topics

Who is online

Users browsing this forum: No registered users and 3 guests