Power management

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Power management

Postby dal on Fri May 11, 2007 10:12 am

Greetings all....

First I'd like to say...installed Mint Bianca-2.2 last night on my HP ZV5000 laptop, and everything is working great :) I'm impressed with Mint thus far.

The only odd behavior seems to be regarding power management/cpu throttling. I'm using the Gnome version and It's my first time using Gnome and most Gnome-based desktop tools.

Problem is that when the screen blanks (no screensaver set) my fans start cranking up to full, as if I was playing a graphics intensive game. It leads me to believe the the cpu (AMD Athlon 3200+) is throttled up full. It seems that with the screen blanked it should be throttled down.

Is there a power management app installed out of the box with Mint?

Thanks

~regards

Dal
dal
Level 1
Level 1
 
Posts: 7
Joined: Fri May 11, 2007 9:59 am

Linux Mint is funded by ads and donations.
 

Postby dal on Fri May 11, 2007 11:07 am

Hmmm...after more searching here on the forums I discovered this "Beagle" issue. I'll have to take a look at that tonight.

I'm still wondering if there is a power management app installed by default.
dal
Level 1
Level 1
 
Posts: 7
Joined: Fri May 11, 2007 9:59 am

Power management

Postby nick on Fri May 11, 2007 11:55 am

Hi
Copied from synaptic:

Powernowd

control cpu speed and voltage using 2.6 kernel interface
This simple client controls CPU speed and voltage using the sysfs interface
to the CPUFreq driver in v2.6 Linux kernels. It does not depend on APM or
ACPI, and it doesn't try to do anything other than control the CPU.

The name is somewhat misleading, as any CPUfreq capable processor will work,
not just those from AMD. However, it works better on CPUs that support more
than two speed steps, like those with AMD's PowerNow! or Intel's Pentium M
series.

This daemon is less complicated than cpufreqd or cpudyn, at the cost of
absolutely depending on a 2.6 kernel with the userspace governor and sysfs
support enabled.
Not sure is it is installed by default,(I always install KDE), but it is in my 3 AMD boxes, and for instance my 3.4ghz always sits at 1ghz when just surfing etc, then pulls up to fullspeed when burning DVD etc I have never had the symtoms you describe, but I know others have.
I have not removed beagle, but as you say it has cured some other peoples faults
Nick
To disable just type powernow=off
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby dal on Fri May 11, 2007 12:19 pm

Thanks nick for your suggestion. I'll give it a try when I get home.
(I wasn't being lazy, I'm at work and couldn't check with Synaptic...lol.)
dal
Level 1
Level 1
 
Posts: 7
Joined: Fri May 11, 2007 9:59 am

Postby nick on Fri May 11, 2007 12:39 pm

Hi
I did not think you were being lazy :)

In Bianca KDE, there is kpowersave:
frontend to powersave for setting user specific policies
KPowersave is the KDE frontend for the powersave daemon. It provides
battery monitoring, suspend/standby triggers and many more features
for KDE (and GNOME).

Current feature list:
* support for ACPI and APM
* trigger suspend to disk/ram and standby
* switch cpu frequency policy (between: performance, dynamic and powersave)
* applet icon with information about AC state, battery fill and battery
(warning) states
* applet tooltip with information about battery fill and remaining battery
time/percentage
* autosuspend (to suspend the machine if the user is a defined time inactive)
* a global configurable blacklist with programmes which prevent autosuspend
(e.g. videoplayer and cd burning tools)
* trigger lock screen and select the lock method
* sound for: battery states, AC adapter events and autosuspend
* online help
* localisations for many languages
KPowersave support schemes with following configurable specific
settings for:
* screensaver
* DPMS
* autosuspend
* scheme specific blacklist for autosuspend
* notification settings

Very handy, you can just click on the "frequency" you wish your processor to run at.


Maybe worth giving Biaca KDE a try?

Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby dal on Fri May 11, 2007 1:30 pm

nick wrote:Maybe worth giving Biaca KDE a try?
Nick


Yeh, you may be right...I have always been a Kde user, but wanted to give Gnome a try when I installed Mint. I am familiar with kpowersave, from my Mepis install on my other comp. One of the reasons I am trying Mint and Gnome was because of sluggish Kde performance with Mepis 6.5 on both my desktop and laptop. I think I will give Bianca Kde a spin before I invest too much time with Gnome...lol.

Thanks again

~regards

Dal
dal
Level 1
Level 1
 
Posts: 7
Joined: Fri May 11, 2007 9:59 am

Power management

Postby nick on Fri May 11, 2007 1:46 pm

Hi
About to install it myself, immediatly added KDE to Bianca when it came out,
(apt-get install kde), now when I try to add Kpowersave, I get told by Synaptic
I must uninstall KDE :)

Good luck

Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby dal on Sat May 12, 2007 4:12 pm

Hmmm...still having the same problem after removing Beagle...not really seeing any disk activity when idle anyways. I guess I'll have to play around some more with the powersave daemons.
dal
Level 1
Level 1
 
Posts: 7
Joined: Fri May 11, 2007 9:59 am

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: No registered users and 2 guests