Problems with sound card (Dell E1705)

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Postby klr279 on Sat May 19, 2007 6:19 pm

Hi,

I've actually got the exact same sound card (Dell E1705) and I've got a slightly different problem.

Just to verify, my lspci output is the following:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01),
which seems to be exactly the same as yours.

My problem is this that I can't get Audacity 1.2.6 to recognize my sound card for playback, although I am able to choose it for recording. However, when I try to record, it doesn't pick up anything, even when I've got music playing in the background. I'm using the ALSA drivers (which I assume you are too) and I realize that Audacity claims to not be compatible with ALSA without compiling with a special option (PortAudio v19), so I compiled the current beta version to use this newer version. I still can't get it to recognize my card for playback, but I can get it to (try to) use it for recording. But on the beta version, it doesn't even try to record (the red indicator just stays at 0 and spazzes out until I hituse stop).

Are there any special options that you're using for Audacity or your ALSA drivers that may help me out? Strangely, I'm not able to get it working in Virtualbox either (which I'm not too surprised or worried about), but booting into Windows XP Pro deals with it just fine.

Thanks for your help in advance!
klr279
Level 1
Level 1
 
Posts: 1
Joined: Sat May 19, 2007 6:03 pm

Linux Mint is funded by ads and donations.
 

Postby Husse on Sun May 20, 2007 3:58 pm

Please make a new post when you have a new problem or you risk never being answered and it's also better for the forum. I moved your post but run out of time to answer you directly
I've had some problems with audacity (and all other sound apps)
You have to check in preferences the source for your sound both in and out .
You can't use two different apps at a time - like Skype and audacity.
If you use an USB sound card (like for a headset) this can get switched of if you have speakers plugged into your normal sound card and you have to check preferences again.
It is correct that support for ALSA is being developed but it should work.
The 82801G is a bit of a problem, as you can see from the various posts in the forum.
One owner of a Thinkpad discovered that you can't turn off modem in your BIOS. As there is a similarity this migtht be valid for you too
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Other topics

Who is online

Users browsing this forum: No registered users and 9 guests