Problem with installing Gtk2 Themes

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Problem with installing Gtk2 Themes

Postby dosenpfand on Fri May 25, 2007 11:46 am

First of all this is the first Gnome Distribution i use , so please be patient ^^


I installed Cassandra Beta 2 , and everythings works fine , i love eyecandy and so i installed
kiba-dock , screenlets for composite manager and so on, everything works, accept i cant install any theme anymore, it worked
at the beginning , but now it always says "invalid file format" even with the themes i installed before.

I tried it with the tarball,the uncompressed folder , and the .rc files , but always the same error message .
As i said iam new to gnome and i hope that iam just to stupid to see the reason for this ^^


Grüße
dosenpfand
Level 1
Level 1
 
Posts: 1
Joined: Thu May 24, 2007 5:39 am

Linux Mint is funded by ads and donations.
 

Postby exploder on Fri May 25, 2007 2:37 pm

Are all of your packages up to date? If I remember there was an updated package for gtk2 themes not long ago.
exploder
Level 15
Level 15
 
Posts: 5871
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA

Postby exploder on Fri May 25, 2007 2:45 pm

Just checked and I have gtk-engine 1:2.10.1. You might try removing and re-installing the package. I do not have the problem on my system, but this might make a good starting point.
exploder
Level 15
Level 15
 
Posts: 5871
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA

Re: Problem with installing Gtk2 Themes

Postby D1Wayne on Sat May 26, 2007 3:27 am

dosenpfand wrote: i love eyecandy and so i installed
kiba-dock


for latest bleeding stuff try the following http://3v1n0.tuxfamily.org/dists/feisty/eyecandy/index.html

I have run these on both Bianca and Cassandra beta012, these are nightly builds, though the dates seem to be the same since 05/09/2007 as of this post

I would Suggest uninstall all existing beryl/compiz/akamaru items before using the above and use synaptic, else suffer from dependecy issues :D :shock:
D1Wayne
Level 3
Level 3
 
Posts: 198
Joined: Tue Apr 24, 2007 6:11 am
Location: Pacific North West

Postby D1Wayne on Sat May 26, 2007 4:35 am

Just did the fastest update to beryl 3 svn to date:

Method:
in gnome-terminal rename sources.list
Code: Select all
sudo mv /etc/apt/sources.list  /etc/apt/goodsources.list

gedit new sources.list
Code: Select all
gksu gedit /etc/apt/sources.list


In browser of choice go to
http://3v1n0.tuxfamily.org/dists/feisty/eyecandy/index.html

copy repositiries uri's
Code: Select all
deb http://download.tuxfamily.org/3v1deb feisty eyecandy
deb-src http://download.tuxfamily.org/3v1deb feisty eyecandy


Code: Select all
Paste the above into empty sources,list and save it


Start software installer sysnaptic
or Install Software from MintMenu
Code: Select all
click on reload

search for beryl
Code: Select all
click on Mark all upgrades

add or remove components as desired
repeat search for compiz akamaru etc..
when you're done selecting
then click on
Code: Select all
Apply


Just one or two more thing
back in gnome-terminal
Code: Select all
sudo mv /etc/apt/sources.list /etc/apt/beryl3.list
sudo mv  /etc/apt/goodsources.list  /etc/apt/sources.list 

put your orig repositories back :twisted:
D1Wayne
Level 3
Level 3
 
Posts: 198
Joined: Tue Apr 24, 2007 6:11 am
Location: Pacific North West

Postby D1Wayne on Sat May 26, 2007 6:47 am

well, since I broke down and used the terminal a few times in the earlier method :shock:

here is a bit faster method

caution this is tested on my machine from Cassandra Beta014 beryl 3.0 svn + Kiba-Dock,

While I have found them (on Nvidia geForce 6150) to run better than Beryl 2, they are not production

if you are unfamiliar with beryl 3.0 and compiz research before doing this, your milage may vary :twisted:

Code: Select all
cd /etc/apt
sudo mv sources.list goodsources.list
sudo mv beryl3.list x.sources
echo "deb http://download.tuxfamily.org/3v1deb feisty eyecandy\ndeb-src http://download.tuxfamily.org/3v1deb feisty eyecandy" > sources.list
sudo apt-get update
sudo apt-get upgrade
gksu synaptic
sudo mv sources.list  beryl3.list
sudo mv goodsources.list  sources.list
sudo apt-get update


run as a sudo sh shell script or paste into terminal
when synaptics launches do your searches select.remove components as you need apply then close synaptics the above will restore your original sources.list and re-update them for future auto updates.
D1Wayne
Level 3
Level 3
 
Posts: 198
Joined: Tue Apr 24, 2007 6:11 am
Location: Pacific North West

Postby exploder on Sat May 26, 2007 8:03 am

Wow! Nice attention to detail D1Wayne! I am tempted to give that a try! How is the newer version feature wise?

Again, great set of instructions!
exploder
Level 15
Level 15
 
Posts: 5871
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA

Postby D1Wayne on Sat May 26, 2007 8:20 am

I have been running beryl3 on Bianca since around May 10th, great performance increases on my config, Cassandra beta012 +beryl3 much smoother and lower cpu usage than beryl2. just did it here on Cassandra Beta014.

example with annote seom and vidcap beta012
http://www.isnbiz.com/lm/m3b3.avi
Example on Bianca
http://www.isnbiz.com/lm/beryl3.avi

then of course if you add vidcap and seom and text annotate gets fun.
Akamaru Kiba-Dock + physics is a real cpu hog. uses more cpu than everything else combined including gnome and beagle :shock:

:arrow: but have nasty problem if mini-viewport is turned on in Extras (xserver really likes to crash on my config if it is checked)

Have not attempted it on my 256mb Dell 8100 @ 1.3ghz P4 geforce2 mx400 (it can not even handle 1280x1024 + beryl 2), Think i'll try replace it with a ATI Radeon 9550 and see if that is any better for that dog bone.
D1Wayne
Level 3
Level 3
 
Posts: 198
Joined: Tue Apr 24, 2007 6:11 am
Location: Pacific North West

Postby D1Wayne on Sat May 26, 2007 9:05 am

btw:
just installed CrystalSphere GTK+2 theme switch to Helidor and nothing.
switched back to meta-city, closed beryl
restarted beryl and switched to helidor and it works,

Switched back to emerald and it works
seems 1st time helidor is used beryl needs more than reloads
so if problems, switch to meta-city and exit beryl then relaunch it
D1Wayne
Level 3
Level 3
 
Posts: 198
Joined: Tue Apr 24, 2007 6:11 am
Location: Pacific North West

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: Wick and 5 guests