Killing a Program

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Killing a Program

Postby jbaerbock on Thu Jun 07, 2007 11:09 pm

I sometimes am stuck with a fullscreen program frozen and cannot use alt+f4 to close it. Is there a keyboard combo to kill the program? I tried alt+tab and alt+space and nothing did it, Linux was not frozen but since I was in fullscreen couldn't do anything. Also is there a shortcut key to bring up a task manager sort of like what windows has so I can view and kill processes? Thanks.
jbaerbock
Level 4
Level 4
 
Posts: 309
Joined: Tue Jun 05, 2007 11:31 pm
Location: St. Peter, MN

Linux Mint is funded by ads and donations.
 

Postby Boo on Thu Jun 07, 2007 11:36 pm

you could ctl-alt-F1 to get to a terminal session and then find and kill off your program using the ps and kill commands. and ctl-alt-F7 to get back to Gnome.

OR

you could Restart the Gnome Session with Ctl-alt-backspace.
then login again.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby roseway on Fri Jun 08, 2007 2:10 am

In KDE you can do Ctrl+Alt+Esc then click on the program you want to kill, but I don't know if it works with Gnome.

Eric
User avatar
roseway
Level 1
Level 1
 
Posts: 9
Joined: Tue Jun 05, 2007 11:23 am
Location: Kent, UK

Postby nick on Fri Jun 08, 2007 4:02 am

Hi
You can (if not totally frozen) open terminal, type xkill and drag skull and crossbones to program you wish to kill

Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby jbaerbock on Fri Jun 08, 2007 10:56 am

I tried the ctrl+alt+f1 command and got a black screen and that's it. Is there a command for opening a terminal window? Thanks
jbaerbock
Level 4
Level 4
 
Posts: 309
Joined: Tue Jun 05, 2007 11:31 pm
Location: St. Peter, MN

Postby 900i on Fri Jun 08, 2007 12:36 pm

Right click Panel > Add to Panel, double click Force Quit. Hey presto, Force Quit applet is added to panel.

System Preferences > Keyboard Shorttcuts, scroll down to Run a Terminal, then pick your shortcut keys.

Alternately, install Yakuake or Tilda, both drop down terminals like the one in Quake.
Intel i7 3770 LMDE Mate 64
User avatar
900i
Level 6
Level 6
 
Posts: 1014
Joined: Sat Nov 18, 2006 9:30 am
Location: Wakefield, UK

Postby Husse on Fri Jun 08, 2007 5:57 pm

tried the ctrl+alt+f1 command and got a black screen

You should not! You should get a TTY, but I remember having this problem (or something like it) when I had Beryl installed a couple of months ago
http://www.linuxmint.com/forum/viewtopi ... ryl&t=1963
Don't know if that helps you as it talks of completely removing Beryl
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: No registered users and 7 guests