Mint XP Dual Boot Trouble

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Mint XP Dual Boot Trouble

Postby Pryme on Tue Jul 03, 2007 1:53 am

Ok so I am trying to set up a Linux/XP dual boot on my machine. I am using this guide for the installation. Everything goes fine until the very end. After I get windows up and working I set it back to LM and re-setup the GRUB loader. If I choose LM it works fine but if I pick XP off the list it will start loading (Xp logo and everything comes up) then flash the BSOD (too fast for me to read anything) and the system will restart. Windows works fine until I start up LM and set up the GRUB. Windows will still work in safe mode, however. This is the second time I have tried this and I achieved the same results both times. Here is a copy of my grub menu.lst

Code: Select all
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default      0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=e04f57a6-23cb-4c79-bbcd-9071ef8afcf8 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## ## End Default Options ##

title      Linux Mint, kernel 2.6.20-15-generic
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.20-15-generic root=UUID=e04f57a6-23cb-4c79-bbcd-9071ef8afcf8 ro quiet splash
initrd      /boot/initrd.img-2.6.20-15-generic
quiet
savedefault

title      Linux Mint, kernel 2.6.20-15-generic (recovery mode)
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.20-15-generic root=UUID=e04f57a6-23cb-4c79-bbcd-9071ef8afcf8 ro single
initrd      /boot/initrd.img-2.6.20-15-generic

title      Linux Mint, memtest86+
root      (hd0,0)
kernel      /boot/memtest86+.bin
quiet

title      Windows XP
root      (hd0,1)
makeactive
chainloader   +1

### END DEBIAN AUTOMAGIC KERNELS LIST


Having this happen is very annoying (because windows takes like 6 years to install :shock: ) so any help would be very much appreciated.

Thanks in advanced for the help,
Pryme
Pryme
Level 1
Level 1
 
Posts: 3
Joined: Tue Jul 03, 2007 1:31 am

Linux Mint is funded by ads and donations.
 

Postby Husse on Tue Jul 03, 2007 6:03 am

For a dual boot you really only need to have Windows installed first, and then Mint and it should just work. The other way round its a bit more complicated as Windows destroys grub.
One thing - do you have Windows in h(s)da2?
Your grub/menu.lst looks OK
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19713
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Pryme on Tue Jul 03, 2007 3:16 pm

Yes, I have windows as sda2. Setting the grub back up isn't too hard, it tells you how to set it back up in the guide. Like I said everything works fine until I boot up in LM after installing windows, then windows dies. I would really hate to have to reinstall LM again...I have already had to about 16 times since I started using it (long story). But I will if I have to, I just want to make sure their is no other way.
Pryme
Level 1
Level 1
 
Posts: 3
Joined: Tue Jul 03, 2007 1:31 am

Postby Husse on Tue Jul 03, 2007 6:47 pm

This is a Windows error - there's nothing wrong with your menu.lst as far as I can see I have savedefault in the Windows section, but that's got nothing to do with your problem
I used to be a Windows guru (almost at least). You can log into safe mode. Do that and make an adjustment.
Right click on "My computer" and select properties. One of the tabs......
Nah I'll have to boot into Windows (this pc is dual boot) and get the exact facts before I post it here. Will perhaps not be done untill tomorrow - it's late now
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19713
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Pryme on Tue Jul 03, 2007 9:19 pm

...and the plot thickens. So I was going to try and figure this problem out on my own by going into safe mode but before I did I thought I would try out the "Last know good configuration" as a joke (not like it ever fixed any of my other windows problems back when I used it :? ), and to my amazement it worked...kind of. XP starts up now but after a few seconds the icons and menu bar vanish. If I check the processes list their is no explorer.exe running. I know this is more of a windows problem but I thought I would post it here in hope someone would help anyway. I would also like to thank you for your help so far.

Thanks in advanced for any future help,
Pryme

Edit: Whenever I start up LM it mounts my windows partition and whenever I unmount it, it just remounts again. How do I make it so LM dose not mount my windows partition. Also whenever I set it to give me read-only access to that partition (since I read a warning about giving LM write access to my windows partition) it gets set back to read-write access whenever I restart. Sorry I am still new to linux :wink:
Pryme
Level 1
Level 1
 
Posts: 3
Joined: Tue Jul 03, 2007 1:31 am

Postby Boo on Tue Jul 03, 2007 10:22 pm

mintdisk is mounting your windows partition.

look in administration--> mintdisk

you can uncheck it mounting ntfs and fat partitions.

:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby Husse on Wed Jul 04, 2007 9:20 am

Now I've had the time to check in Windows - then I had to spend a few hours to change telephone and power cables so they are out of the way for a sofa my wife wanted to move to a new position. Yes, I do have a life :lol:
Anyway if you can get into Windows in safe mode
right click "My computer"
select the Advanced tab
select Information about systemstart errors ... Something like that...
It's the bottom one of three buttons "Settings"
Untick "Restart on errors"
This should make Windows stop at the BSOD so you can read it.
It's such an odd error that I have difficulties believing it - I don't distrust you - rather Windows :)

It used to be a bad idea to write to NTFS but with ntfs-3g it's quite safe
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19713
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: Bing [Bot] and 4 guests