gui login issue

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help

gui login issue

Postby freedomphon on Fri Jul 13, 2007 12:07 pm

i added a splash screen to grub rebooted and i am now unable to login with my username and pass. i used ctrl+alt+2 to open a none gui and i am able to login there just fine. i also added a new user account and i am able to login with the new user name and pass.

any thoughts?
freedomphon
Level 1
Level 1
 
Posts: 12
Joined: Mon Jul 09, 2007 5:52 pm

Linux Mint is funded by ads and donations.
 

Postby Husse on Fri Jul 13, 2007 1:00 pm

A change in grub should not result in this - but could :)
(I think)
Please post your /boot/grub/menu.lst
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby freedomphon on Fri Jul 13, 2007 1:44 pm

here it is:

Code: Select all
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default      0

splashimage=(hd0,3)/boot/grub/freedom.xpm.gz

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      5

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=7fbbb682-a89c-4865-b604-7689f7839359 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,3)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## ## End Default Options ##

title      Linux Mint, kernel 2.6.20-16-generic
root      (hd0,3)
kernel      /boot/vmlinuz-2.6.20-16-generic root=UUID=7fbbb682-a89c-4865-b604-7689f7839359 ro quiet splash
initrd      /boot/initrd.img-2.6.20-16-generic
quiet
savedefault

title      Linux Mint, kernel 2.6.20-16-generic (recovery mode)
root      (hd0,3)
kernel      /boot/vmlinuz-2.6.20-16-generic root=UUID=7fbbb682-a89c-4865-b604-7689f7839359 ro single
initrd      /boot/initrd.img-2.6.20-16-generic

title      Linux Mint, memtest86+
root      (hd0,3)
kernel      /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Professional
root (hd0,1)
savedefault
makeactive
chainloader +1
freedomphon
Level 1
Level 1
 
Posts: 12
Joined: Mon Jul 09, 2007 5:52 pm

Re: gui login issue

Postby scorp123 on Fri Jul 13, 2007 2:14 pm

freedomphon wrote:any thoughts?
Sounds like you messed around with the permissions of your original account and now GNOME can't read its settings anymore. Non-GUI logins still work because those files are most likely ignored for shell-only logins.

I suggest you compare the permissions of all the GNOME-relevant files and sub-directories (and all the files underneath those), e.g.
    .config
    Desktop
    .dmrc
    .gconf
    .gconfd
    .gnome
    .gnome2
    .gnome2_private
    .gtkrc-1.2-gnome2
    .metacity
Please note that this is obviously from my system, so it could be that you may not have all items listed above.

So please compare that file list and the permissions between the account that works and the one that doesn't work anymore.

Directories should be owned by your normal user and your user's group (both could have the same name), and permissions on those directories should be 755 (or 750 if you want to be restrictive); permissions on normal files should be 644 (or 640 if you want to be restrictive). And in case you don't understand what those numbers mean:
Code: Select all
man chmod
man chown


And please: Do not use the "-R" parameter (see the man page) and do not recursively change permissions unless one of the local gurus here tells you to, OK? :wink: People often get tempted to use a "chmod -R ..." in all the wrong places. :wink:
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby Husse on Fri Jul 13, 2007 7:21 pm

It's not the grub - I thought that you could have made recovery mode the standard choice or added some parameters that should not be there...
So check permissions, and it can't be emphasized enough - be careful.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Other topics

Who is online

Users browsing this forum: No registered users and 4 guests