Beryl/Compiz/Compiz Fusion, Freezing randomly(?)

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Beryl/Compiz/Compiz Fusion, Freezing randomly(?)

Postby FenrirVII on Mon Jul 23, 2007 9:05 pm

Starting off-
Nvidia Gforce MX 4000
Pentium 4 1.7ghz
512mb ram

Currently running: LinuxMint: Cassandra

Ive been across all the forums, have done all the manuals and have been apart of that GIGANTIC 50 page long thread on the ubuntu forums where everyone is having problems of Beryl/compiz/compiz fusion just randomly freezing in Fiesty Fawn. Thats where my problem began. So i thought maybe i should try Fedora 7. Then Ubuntu 6.06, 6.10( i gave up before i got anywhere with beryl), KDE Gutsy Gibbon, and now LinuxMint.

The basics-

Before starting any windows mangers, Linux works Wonderfully. Just as good as XP, Then i start the managers.. and..

Direct rendering is YES, Nvidia drivers all installed, and beryl works PERFECTLY seemingly at first.. I can browse forums, play games, change settings, watch videos.. anything.. But sooner or later it freezes. I have the ability to move my mouse, and the keyboard is unresponsive**.
I test by browsing the internet, then going to forums, and trying to get to youtube.. (youtube is the ultimate problem which caused the biggest % of freezing).

(**i say unresponsive because NOthing works on the keyboard except for that hardcore manual shutdown where you hold down like 6 buttons (printscreen+ctr+ etc some others i forget, i did it the second time try on Fiesty 2 days ago (seems like forever ago since trying all this crap)..)

Here are my trials:

Ubuntu Fiesty Fawn 7.04 and Fedora 7 (basically same for each one)
=Enabled Restricted Drivers- Enabled Desktop Effects. They work for a while but ultimately Freeze
=Installed NVidia drivers manually -Enabled Desktop Effects. Same result with it freezing.
=Envy installed- Same result
=Envy installed Drivers with Compiz Fusion- Compiz freezes just like before, after a little time of use.
[[[Fedora 7 Seemed a little more stable than Ubuntu 7.04]]]

Ubuntu 6.06-6.10-
=Nvidia Drivers all working, Glxgears up, DR YEs etc, I could never get Beryl any different then above results for 6.06. And by 6.10 i was sick of Ubuntu and it not working so i gave up.

Gutsy Gibbon-
=Embarrassingly it was too gutsy for me.

LinuxMint-
=Nvidia Direct Rendering = YES, loaded beryl.. Worked Very Stable and perfectly for by far the most stability.. yet it still froze after some time.. though more like a long time

[[[Youtube has a Destruction plot in Each trial, stupid video stream site]]]

So I know the obvious that it could easily Easily be the Graphics card no supported, but i had a few people on the Ubuntu forums tell me otherwise- let alone the visibility that Beryl WORKED. It loaded up fine and never had any errors in any of these.. And for that im a bit on doubting the reason of its the graphics card.. And also becuase alot of these freezes have been like 90% in Youtube. Browsing the forums and whatnot all usually were great until i got to youtube- and because i use youtube alot.. This is where i stand: Frozen.

SO it comes down to this: Could Youtube have something run maybe in the background that somehow freezes compiz-fusion or beryl? There is something up here and it doesnt look like its just my graphics card as the ubuntu forums have a thread about beryl "Fiesty Fawn freeze ! driving me insane"...So does anyone have any idea what could be going wrong? Nvidia? Installation? P4 not powerful enough? Anything tips/ideas would be greatly appreciated- Though i might go and buy a new graphics card just to see how that would effect it.
FenrirVII
Level 1
Level 1
 
Posts: 3
Joined: Mon Jul 23, 2007 8:27 pm

Linux Mint is funded by ads and donations.
 

Postby linuxviolin on Mon Jul 23, 2007 10:07 pm

I have also this problem: http://www.linuxmint.com/forum/viewtopic.php?t=3944

I have no answers for the moment.

I am not sure that comes from youtube. My PC freezes at the end of a few minutes as soon as I install the nvidia drivers and even without going on the Web nor using Beryl.

Thus for the moment I remain with “nvâ€￾ and everything functions perfectly.
Last edited by linuxviolin on Wed Aug 01, 2007 10:27 am, edited 1 time in total.
K.I.S.S. ===> "Keep It Simple, Stupid"
"Simplicity is the ultimate sophistication." (Leonardo da Vinci)
"Everything should be made as simple as possible, but no simpler." (Albert Einstein)
User avatar
linuxviolin
Level 8
Level 8
 
Posts: 2055
Joined: Tue Feb 27, 2007 6:55 pm
Location: France

Postby FenrirVII on Mon Jul 23, 2007 10:31 pm

Well I can browse online for a quite a while. Sometimes its frozen without me doing anything, but like 95% of every time i watched a youtube video it froze.
FenrirVII
Level 1
Level 1
 
Posts: 3
Joined: Mon Jul 23, 2007 8:27 pm

Postby OU812 on Mon Jul 23, 2007 11:04 pm

It could be that your xorg.conf was not properly edited when your drivers were installed. Read through this thread, especially the second post by merlwiz79

http://linuxmint.com/forum/viewtopic.php?t=3840

john
OU812
Level 3
Level 3
 
Posts: 151
Joined: Fri Jun 29, 2007 8:01 pm
Location: California, USA

Postby FenrirVII on Wed Jul 25, 2007 1:42 am

Fixxed, MX 4000 = BAD. Future Reference, if you have these kinds of symptoms -keyboard doesnt work, Desktop frozen, mouse can still move, id suggest trying out another graphics card- as of right now i have a 7600 GS and its working perfectly :D
FenrirVII
Level 1
Level 1
 
Posts: 3
Joined: Mon Jul 23, 2007 8:27 pm


Return to Other topics

Who is online

Users browsing this forum: No registered users and 5 guests