Exaile Not Working in Cassandra XFCE 3.0 Final

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Exaile Not Working in Cassandra XFCE 3.0 Final

Postby dgittler on Wed Aug 08, 2007 2:19 am

Before I describe my problem, just have to say I loved Ubuntu, it made me a Linux user; I loved the gnome version of Mint and how it made everything easier; but dear sweet gods on high I can't get over how insanely elated I am with Cassandra XFCE! I mostly use Linux on my laptop and while it could handle gnome, XFCE just makes this thing fly! Finally a full featured lightweight version that is a joy to use! Goodbye gnome, Ubuntu, DreamLinux, Xubuntu, and VectorLinux. Mint Cassandra XFCE beats them all!

Ok, there is one small problem . . .

Exaile simply won't start. When I click on the link in the menu or try to start it from the command line, the splash screen flashes very briefly and then nothing. The process isn't even listed in the Task Manager.

I've deleted the .exaile folder in my home directory and restarted the program; I've tried sudo apt-get remove/install, and always get the same thing - a brief flash of the splash screen and then nothing.

The sound on my laptop works - I can play MP3 files perfectly with the default Mint installations of MPlayer and Xfmedia. It's just Exaile that won't load.

My laptop is a 1.2GHz Dell Inspiron 8200 and the internal sound card is an Intel 82801CA-ICH3 AC'97 Audio Controller.

exaile.log contains only:
Code: Select all
[02:27:01] Importing sql changes file changes0001.sql
[02:27:01] Importing sql changes file changes0002.sql


Any ideas what the problem might be?
dgittler
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 08, 2007 1:57 am

Linux Mint is funded by ads and donations.
 

Postby Lolo Uila on Wed Aug 08, 2007 4:23 pm

You might want to try installing it from the Mint Software Portal. There might be some dependancy issue that apt isn't handling properly.

Aloha, Tim
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Postby dgittler on Wed Aug 08, 2007 6:11 pm

Lolo Uila wrote:You might want to try installing it from the Mint Software Portal. There might be some dependancy issue that apt isn't handling properly.

Aloha, Tim


Good thought. I tried it a few times, however that didn't work either.

Before trying the MintInstall version I removed the program with apt-get remove and deleted the .exaile folder from my home directory again. When I used MintInstall the notification box said "Success," but the results were the same: A brief flash of the Exaile splash screen and then nothing, not even a left over process running as far as I can tell.

I wish I could provide more information that would held diagnose this problem, but honestly I have no idea what to look at or even where to begin looking.

Damn. It would be nice to get this working, but even without it Mint is one hell of an amazing distro. I'll be sticking with it regardless, but I'd love to hear any other suggestions that may help fix this problem.
dgittler
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 08, 2007 1:57 am

Postby dgittler on Wed Aug 08, 2007 6:21 pm

After I tried installing the .mint version from the software page, I noticed that there were 2 versions of Exaile: Exaile and Exaile (Backport)

I tried installing Exaile (Backport) as well. That didn't work either (same results when I tried to start the program) but during the install phase I did notice that the program installed python-cddb and python-gpod, things that as far as I know were not installed before.

Possibly you were right that there is some dependency missing, but I have no idea what it might be. Given that the 2 newly installed packages were both python-xxx, could it be that there is something wrong with Python in my installation?

What package could I install with apt-get to ensure that I have Python and all it's dependencies? (sudo apt-get install python claims that python is already fully installed and is the latest version.)
dgittler
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 08, 2007 1:57 am

Postby merlwiz79 on Wed Aug 08, 2007 7:19 pm

dgittler wrote:I tried installing Exaile (Backport) as well. That didn't work either (same results when I tried to start the program) but during the install phase I did notice that the program installed python-cddb and python-gpod, things that as far as I know were not installed before.

Those were install in XFCE by default, python-cddb, is for playing cds, and python-gpod, is for the iPod plugin.

Maybe it is a bad install or CD-R.
Does it work on the LiveCD?
What speed did you burn it at? (2x recommended, 4x is should be fine)
I have installed the final many times and never had any problems. :?
Try
Code: Select all
sudo aptitude -purge exaile
Then use the Exaile (Backport)
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Postby dgittler on Wed Aug 08, 2007 7:44 pm

merlwiz79 wrote:Maybe it is a bad install or CD-R.
Does it work on the LiveCD?
What speed did you burn it at? (2x recommended, 4x is should be fine)


No, it doesn't work on the LiveCD either. I guess some dependency didn't burn properly - I did burn it at 40X - never seemed to be a problem before.

I'll try to fix it later with a fresh CD burned at a lower speed. Until then, amarok seemed to install well without issue.

Thanks for your help. This is one amazing distribution you have. Keep up the incredible work!
dgittler
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 08, 2007 1:57 am

Postby dgittler on Fri Aug 17, 2007 3:47 pm

I finally got around to burning a new install CD and reinstalling Cassandra XFCE. Unfortunately I'm still having the exact same problem.

Before I burned the new install CD I checked the MD5 sum of the iso against the one posted on the Linux Mint site and they match.

This time, instead of burning the install CD in Windows like I did last time, I burned it under Cassandra on my main system using GnomeBaker. I set the CD to burn at 2x, but after the burn I noticed that GnomeBaker reported the burn occurred at 7x (Still maybe too fast?)

I reinstalled Cassandra XFCE on my laptop and everything is working perfectly except Exaile won't start up beyond that very brief flash of the splash screen. The same thing happens when I try to run it off of the Live CD.

Every other CD I've burned from this batch of blanks has been fine, so I don't think it's the CDs, but just in case it is, I'm using Memorex 52x CD-R. Would that be an issue?

I also tried installing Exaile (Backport) .mint file from Linuxmint.com and that's not working either.

For the life of me I can't figure out why this one program simply won't run. Any other suggestions?
Last edited by dgittler on Fri Aug 17, 2007 4:05 pm, edited 1 time in total.
dgittler
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 08, 2007 1:57 am

Postby merlwiz79 on Fri Aug 17, 2007 3:59 pm

Launch it from Terminal by using the command exaile.
What does the output say?
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Postby dgittler on Fri Aug 17, 2007 4:02 pm

Code: Select all
me@mycomputer:~$ exaile
Traceback (most recent call last):
  File "/usr/share/exaile/xl/xlmisc.py", line 36, in <module>
    from xl import mozembed
  File "/usr/share/exaile/xl/mozembed.py", line 29, in <module>
    import gtkmozembed
ImportError: No module named gtkmozembed
/usr/share/exaile/xl/xlmisc.py:1717: GtkWarning: gdk_drawable_set_colormap: assertion `cmap == NULL || gdk_drawable_get_depth (drawable) == cmap->visual->depth' failed
  pixmap.set_colormap(colormap)
/usr/share/exaile/xl/xlmisc.py:1740: GtkWarning: Using Cairo rendering requires the drawable argument to
have a specified colormap. All windows have a colormap,
however, pixmaps only have colormap by default if they
were created with a non-NULL window argument. Otherwise
a colormap must be set on them with gdk_drawable_set_colormap
  pixmap.draw_layout(gc, x, y, layout)
/usr/share/exaile/xl/xlmisc.py:1740: GtkWarning: No colormap in gc_get_foreground
  pixmap.draw_layout(gc, x, y, layout)
/usr/share/exaile/xl/xlmisc.py:1744: GtkWarning: gdkpixbuf-drawable.c:1255: Depth of the source drawable is 24 where as the visual depth of the colormap passed is 16
  0, width, height)
Traceback (most recent call last):
  File "exaile.py", line 2635, in <module>
    main()
  File "exaile.py", line 2627, in main
    exaile = ExaileWindow(options, fr)
  File "exaile.py", line 202, in __init__
    self.setup_left()
  File "exaile.py", line 1036, in setup_left
    self.collection_panel = panels.CollectionPanel(self)
  File "/usr/share/exaile/xl/panels.py", line 235, in __init__
    self.setup_widgets()
  File "/usr/share/exaile/xl/panels.py", line 257, in setup_widgets
    self.create_popup()
  File "/usr/share/exaile/xl/panels.py", line 352, in create_popup
    icon_set = gtk.IconSet(pixbuf)
TypeError: pixbuf should be a GdkPixbuf
me@mycomputer:~$
dgittler
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 08, 2007 1:57 am

Postby merlwiz79 on Fri Aug 17, 2007 5:16 pm

You have the color depth of 16 apparently this causes a lot of problems with some applications including Exaile.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Postby dgittler on Fri Aug 17, 2007 5:57 pm

Oh hell. It's always the simplest thing, isn't it?

I changed the setting and all is well!

Thank you so very much! I have music!
dgittler
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 08, 2007 1:57 am

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: No registered users and 4 guests