How to disable IPv6 in Linux Mint

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

How to disable IPv6 in Linux Mint

Postby zelda on Wed Jan 10, 2007 4:18 pm

Hi, Ive tried to disable IPv6. Ive had a few people in #ubuntu help me. They have gave me links to support documents and tutorials of how to disable IPv6. Ive followed directions to the "T" I've edited bad_list with the correct lines. Ive edited aliases with other lines from the help forums. I've also edited about:config. With all the help I have received when I type in terminal ip a |grep inet6. Its still there. I would appreciate some help. If you need me to post stuff let me know. Thanks in advance!
zelda
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 10, 2007 4:06 pm

Linux Mint is funded by ads and donations.
 

Postby clem on Wed Jan 10, 2007 6:20 pm

Hi Zelda,

Are you running Barbara ?? ipv6 is disabled in Bea..

Clem
User avatar
clem
Level 15
Level 15
 
Posts: 5548
Joined: Wed Nov 15, 2006 8:34 am

Re: How to disable IPv6 in Linux Mint

Postby scorp123 on Wed Jan 10, 2007 6:26 pm

zelda wrote:Hi, Ive tried to disable IPv6.
Hmmm ... I could have sworn that IPv6 is already disabled by default in Mint?? Can you please post the output of this command:
Code: Select all
lsmod | grep ip
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby clem on Wed Jan 10, 2007 6:30 pm

Scorp: To be precise, enabled in Ada beta007, Barbara final and Bea beta023. Disabled in Bea final.

Clem
User avatar
clem
Level 15
Level 15
 
Posts: 5548
Joined: Wed Nov 15, 2006 8:34 am

Postby scorp123 on Wed Jan 10, 2007 6:48 pm

clem wrote:Scorp: To be precise, enabled in Ada beta007, Barbara final and Bea beta023. Disabled in Bea final.
Yes, I was talking of Bea. That's what most people use around here. There are only few stubborn ones left still using Barbara ... as myself :D
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby zelda on Fri Jan 12, 2007 11:58 pm

Well I was using "Barbara" Then I just reformatted to "Bea" I checked the about:config and its disabled, yet my internet connection is still slow. I will post the output here later. Im working!
-Thanks in advance
zelda
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 10, 2007 4:06 pm

Postby zelda on Sat Jan 13, 2007 11:18 am

lsmod | grep ip doesnt output anything. And how do I get rid of the "extra" quotes in terminal? I think thats lame!
zelda
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 10, 2007 4:06 pm

Postby scorp123 on Sat Jan 13, 2007 11:56 am

zelda wrote: lsmod | grep ip doesnt output anything.
Good. If IPv6 were active then you'd get something like this:
Code: Select all
~> lsmod | grep ip
ipv6                  263584  24
So no response means that the ipv6 module (= "driver") was not loaded. In my example it's loaded so that's why I get something back here.

zelda wrote: And how do I get rid of the "extra" quotes in terminal? I think thats lame!
You should develop some sense for humour :wink:
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby zelda on Sat Jan 13, 2007 12:00 pm

I have a sense of humor. I dont want the quotes. Will you tell me how to disable or get rid of them please? If not, I will go back to "Barbara"
zelda
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 10, 2007 4:06 pm

Postby scripted on Sat Jan 13, 2007 12:54 pm

Open up /etc/bash.bashrc then just comment these lines

Code: Select all
# if the command-not-found package is installed, use it
if [ -x /usr/bin/command-not-found ]; then
   function command_not_found_handle {
                /usr/bin/command-not-found $1
                return $?
   }
fi

/usr/games/fortune


then just remove fortune ?
sudo apt-get remove fortune

i don't know if its safe to do this because im a newbie to linux :oops:

Edit: ooops :P
Last edited by scripted on Sat Jan 13, 2007 1:08 pm, edited 1 time in total.
scripted
Level 1
Level 1
 
Posts: 4
Joined: Sat Dec 02, 2006 3:03 am

Postby scorp123 on Sat Jan 13, 2007 1:03 pm

scripted wrote:then just remove fortune ?
sudo apt-get fortune
sudo apt-get remove fortune :wink:
User avatar
scorp123
Level 8
Level 8
 
Posts: 2287
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby clem on Sat Jan 13, 2007 6:58 pm

You can leave fortune, all you need to do is remove the line calling it in bashrc.rc.

Clem
User avatar
clem
Level 15
Level 15
 
Posts: 5548
Joined: Wed Nov 15, 2006 8:34 am

Postby zelda on Mon Jan 15, 2007 1:24 am

Thanks clem. It worked!
zelda
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 10, 2007 4:06 pm

Postby Frijolie on Wed Jan 17, 2007 11:51 am

did you finally get ipv6 disabled or just get fortune to stop displaying in the terminal?
User avatar
Frijolie
Level 1
Level 1
 
Posts: 44
Joined: Mon Dec 04, 2006 2:41 am

Postby zelda on Thu Feb 01, 2007 11:38 pm

yes I did thanks
zelda
Level 1
Level 1
 
Posts: 6
Joined: Wed Jan 10, 2007 4:06 pm

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: Bing [Bot] and 6 guests