Boot display on external monitor solved

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Boot display on external monitor solved

Postby oliverjames on Mon Nov 12, 2007 6:28 am

I am running Celena on a laptop. I use an external monitor - Viewsonic VP191b.

When I boot up, if anything happens to push the Mint boot sequence out of the splash screen (for example checking file systems) I can't see what is happening, the textual information sent to monitor is displayed as an illegible stream of white markings.

Does anyone know how to fix this?

If I try to switch the display to the laptop's (Acer Travelmate 4052 LMi) LCD screen the system freezes requiring reboot so this is not an option.

Oliverjames
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Linux Mint is funded by ads and donations.
 

Postby Husse on Mon Nov 12, 2007 4:57 pm

This seems a bit odd. Video output that early in the boot process should be "just there".
How do you connect the external monitor? Dock or directly?
What do you to to change (back) to the "normal monitor"
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby oliverjames on Tue Nov 13, 2007 4:01 am

I agree, very odd. I have a vague memory that this started when I switched from Lilo to Grub? I suspect it has something to do with setting screen resolution. Could be a glich with Menu-1st settings?

If I boot without the external monitor connected - it's just plugged in directly so I just unplu it - then all video output is visible on the laptop screen.

I have notice that requesting detailed boot information from the system splash screen (in Grub or in Lilo) results in the external monitor video output during boot being legible.

Oliverjames
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Postby Husse on Tue Nov 13, 2007 6:50 am

Try to add vga=788 as a boot option
List of vga options here
http://www.linuxmint.com/forum/viewtopi ... vga&t=5931
You add vga=788 to the line in menu.lst that contains the kernel
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby oliverjames on Wed Nov 14, 2007 11:25 am

Thanks Husse, It worked.

Oliverjames
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Postby Husse on Wed Nov 14, 2007 3:39 pm

I should mention that this vga="something" option has no bearing on X, it's just for pure command line
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Other topics

Who is online

Users browsing this forum: No registered users and 4 guests