dependency problem updating kernel to 2.6.35-28 -SOLVED-

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

dependency problem updating kernel to 2.6.35-28 -SOLVED-

Postby micronaut on Mon Mar 21, 2011 9:28 am

Hi,

I have been attempting to install the latest kernel update and I get the following error:

Code: Select all
Setting up linux-image-2.6.35-28-generic-pae (2.6.35-28.49) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.35-28-generic-pae
Warning: No support for locale: en_GB.utf8
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 2.6.35-28-generic-pae /boot/vmlinuz-2.6.35-28-generic-pae
 * dkms: running auto installation service for kernel 2.6.35-28-generic-pae                                                                                     
 *       nvidia-current (270.29)...                                      [ OK ]
 *       bcmwl (5.60.4[quote][/quote]8.36+bdcom)...                                     [ OK ]
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 2.6.35-28-generic-pae /boot/vmlinuz-2.6.35-28-generic-pae
run-parts: executing /etc/kernel/postinst.d/pm-utils 2.6.35-28-generic-pae /boot/vmlinuz-2.6.35-28-generic-pae
run-parts: executing /etc/kernel/postinst.d/update-notifier 2.6.35-28-generic-pae /boot/vmlinuz-2.6.35-28-generic-pae
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 2.6.35-28-generic-pae /boot/vmlinuz-2.6.35-28-generic-pae
/etc/default/grub: 9: profile: not found
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 127
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.35-28-generic-pae.postinst line 1010.
dpkg: error processing linux-image-2.6.35-28-generic-pae (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-generic-pae:
 linux-image-generic-pae depends on linux-image-2.6.35-28-generic-pae; however:
  Package linux-image-2.6.35-28-generic-pae is not configured yet.
dpkg: error processing linux-image-generic-pae (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic-pae:
 linux-generic-pae depends on linux-image-generic-pae (= 2.6.35.28.36); however:
  Package linux-image-generic-pae is not configured yet.
dpkg: error processing linux-generic-pae (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-2.6.35-28-generic-pae
 linux-image-generic-pae
 linux-generic-pae


Does anybody know how to correct this?

Thanks for any assistance.
Last edited by micronaut on Mon Mar 21, 2011 3:28 pm, edited 2 times in total.
micronaut
Level 1
Level 1
 
Posts: 8
Joined: Thu Oct 29, 2009 8:02 am

Linux Mint is funded by ads and donations.
 

Re: dependency problem updating kernel to 2.6.35-28

Postby viking777 on Mon Mar 21, 2011 12:35 pm

I think the error is telling you that /etc/default/grub has been altered so as to make it no longer functional. So you have to replace it. Luckily there is a virgin copy of this file lurking at /usr/share/grub/default/grub.

So using a root terminal or file manager, rename your existing copy of /etc/default/grub then replace it with the version from the location above. It won't contain any of the mods that you have made to that file, but those mods are probably what caused your update to fail in the first place.

When you have replaced this file try the update again.

If it doesn't work replace the latest /etc/default/grub with the backup you made earlier and you will be back to where you started.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: dependency problem updating kernel to 2.6.35-28

Postby micronaut on Mon Mar 21, 2011 12:53 pm

Thanks for the reply :)

Copied default grub from etc folder into /usr/share/grub/default/ but error message persists

Code: Select all
Setting up linux-image-2.6.35-28-generic-pae (2.6.35-28.49) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.35-28-generic-pae
Warning: No support for locale: en_GB.utf8
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 2.6.35-28-generic-pae /boot/vmlinuz-2.6.35-28-generic-pae
 * dkms: running auto installation service for kernel 2.6.35-28-generic-pae                                                                                     
 *       nvidia-current (270.29)...                                      [ OK ]
 *       bcmwl (5.60.48.36+bdcom)...                                     [ OK ]
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 2.6.35-28-generic-pae /boot/vmlinuz-2.6.35-28-generic-pae
run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.35-28-generic-pae /boot/vmlinuz-2.6.35-28-generic-pae
run-parts: executing /etc/kernel/postinst.d/pm-utils 2.6.35-28-generic-pae /boot/vmlinuz-2.6.35-28-generic-pae
run-parts: executing /etc/kernel/postinst.d/update-notifier 2.6.35-28-generic-pae /boot/vmlinuz-2.6.35-28-generic-pae
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 2.6.35-28-generic-pae /boot/vmlinuz-2.6.35-28-generic-pae
/etc/default/grub: 9: profile: not found
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 127
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.35-28-generic-pae.postinst line 1010.
dpkg: error processing linux-image-2.6.35-28-generic-pae (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-generic-pae:
 linux-image-generic-pae depends on linux-image-2.6.35-28-generic-pae; however:
  Package linux-image-2.6.35-28-generic-pae is not configured yet.
dpkg: error processing linux-image-generic-pae (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic-pae:
 linux-generic-pae depends on linux-image-generic-pae (= 2.6.35.28.36); however:
  Package linux-image-generic-pae is not configured yet.
dpkg: error processing linux-generic-pae (--configure):
 dependency problems - leaving uncNo apport report written because the error message indicates it's a follow-up error from a previous failure.
                                                              No apport report written because the error message indicates it's a follow-up error from a previous failure.
          onfigured
Errors were encountered while processing:
 linux-image-2.6.35-28-generic-pae
 linux-image-generic-pae
 linux-generic-pae
E: Sub-process /usr/bin/dpkg returned an error code (1)


I also get the error "/etc/default/grub: 9: profile: not found" when I try update-grub with my own or the original grub file. I haven't made any edits to grub since the initial installation.
micronaut
Level 1
Level 1
 
Posts: 8
Joined: Thu Oct 29, 2009 8:02 am

Re: dependency problem updating kernel to 2.6.35-28

Postby viking777 on Mon Mar 21, 2011 1:24 pm

Copied default grub from etc folder into /usr/share/grub/default/


I am not sure if this is a typo or not, but what you have written is the exact opposite of what I suggested that you do.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: dependency problem updating kernel to 2.6.35-28

Postby micronaut on Mon Mar 21, 2011 3:25 pm

viking777 wrote:
Copied default grub from etc folder into /usr/share/grub/default/


I am not sure if this is a typo or not, but what you have written is the exact opposite of what I suggested that you do.


sorry, sorry! yes, I had not read your post properly and mixed up the files. Copying the default grub file in place of the old one enabled the installation of the updated kernel and then grub rebuilt the boot loader.

Thank you very much for your help. I will now go and hide under a rock for a while :oops:
micronaut
Level 1
Level 1
 
Posts: 8
Joined: Thu Oct 29, 2009 8:02 am

Re: dependency problem updating kernel to 2.6.35-28 -SOLVED-

Postby viking777 on Tue Mar 22, 2011 5:15 am

No need to hide micronaut, I am forever getting hold of the wrong end of the stick, it is far too easy to do :lol:

One thing interests me though, you claim never to have manually edited etc/default/grub and yet the copy that you were using was clearly faulty. So why? If you haven't deleted the old file yet, can you see a difference between the two (particularly around line #9)? And if you really haven't altered that file yourself, can you think of something else that has? The purpose of the file is for editing grub settings like default entry to boot, menu timeout, splashscreen options and other boot options so have you ever altered any of those things or used a third party tool in order to do so?

Just interested to know how the file got corrupted that is all.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am


Return to Other topics

Who is online

Users browsing this forum: Google [Bot] and 4 guests