Probem with killerhorse.eu [solved]

deb http://debian.linuxmint.com

Probem with killerhorse.eu [solved]

Postby a_pat on Thu Jul 31, 2014 11:12 am

Hello Mint Forum! (my first post here, sorry if i screw something up)
Hi I'm running LMDE for quite a while now without any major problems, but now I'm stuck with the following problem:

`apt-get upgrade` informs me about missing indices from killerhorse.eu (the mirror I'm using for updates). Also I can't install any packages that don't come from packages.linuxmint.com (d'uh).

when i run `mintsources` I get the following error message:

Code: Select all
glibtop: Non-standard uts for running kernel:
release 3.11-2-amd64=3.11.0 gives version code 199424


I have seen that others seem to use some kind of graphical tool to choose their mirrors but I haven't found one (I'm using the XFCE desktop with compiz, maybe that's a problem here).

my sources.list:

Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
deb http://linuxmint-apt.killerhorse.eu/debian/latest testing main contrib non-free
deb http://linuxmint-apt.killerhorse.eu/debian/latest/security testing/updates main contrib non-free
deb http://linuxmint-apt.killerhorse.eu/debian/latest/multimedia testing main non-free


Strangely `synaptic` seems to pull the google chrome repository from somewhere else, since I can update chrome from within synaptic and it is listed there under `other software`.

What are the addresses for the other mirrors, or how can I fix my system to get my repositories being updated again?

The only change that was made to the kernel that I am aware of, was intalling the non-free amd drivers,
Last edited by a_pat on Fri Aug 01, 2014 1:59 pm, edited 1 time in total.
a_pat
Level 1
Level 1
 
Posts: 6
Joined: Thu Jul 31, 2014 10:47 am

Linux Mint is funded by ads and donations.
 

Re: Probem with killerhorse.eu

Postby karlchen on Thu Jul 31, 2014 11:53 am

Hello, a_pat.

Visit this base URL: http://linuxmint-apt.killerhorse.eu/ Looks like you will have to select a different mirror. - Cannot tell you which one, because LMDE is not my game.
By the way in order to see all configured repository addresses use the command
Code: Select all
inxi -r
Only looking at the file /etc/ap/sources.list may not be sufficient.

Kind regards,
Karl
User avatar
karlchen
Level 11
Level 11
 
Posts: 3509
Joined: Sat Dec 31, 2011 7:21 am

Re: Probem with killerhorse.eu

Postby py-thon on Thu Jul 31, 2014 12:56 pm

As karlchen mentioned, there is currently no mirror service from killerhorse.
Don't worry about the error message. I get that as well when trying to change mirrors via terminal.

The command to change mirrors via terminal is mintsources or software-sources, but there should be an entry at Menü > Systemverwaltung > Software-Quellen (translates into something like menu > system settings > software sources). This should let you change your sources.
There has been no recent change of mint-mirrors, so I suppose it still contains rts-informatique, which stopped service yesterday but will still be on the list (won't turn up at the top though, if you choose mirror by speed).

A list of current mirrors can be found at http://www.linuxmint.com/mirrors.php (LMDE-sources at the bottom "Package mirrors for LMDE"), in case you have to change the sources file some other way.
Tower: LMDE Mate 64bit - Netbook: LMDE Mate 32bit
py-thon
Level 4
Level 4
 
Posts: 242
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: Probem with killerhorse.eu

Postby a_pat on Thu Jul 31, 2014 1:02 pm

The domain is not reachable. But that's not my concern, although it is sad. I want to change my mirror and want to know the urls.

Thanks, I was on that page, but haven't scrolled all the way down.

Now I'll only have to find a way to get mintsources to work again.
a_pat
Level 1
Level 1
 
Posts: 6
Joined: Thu Jul 31, 2014 10:47 am

Re: Probem with killerhorse.eu

Postby py-thon on Thu Jul 31, 2014 1:24 pm

Check whether /var/cache/apt/archives contains mintsources_1.2.4_all.deb
If so, you can reinstall mintsources using synaptic. That should fix it.
If it is not cached you can download it manually from http://packages.linuxmint.com/pool/main ... .4_all.deb and install with gdebi.
Tower: LMDE Mate 64bit - Netbook: LMDE Mate 32bit
py-thon
Level 4
Level 4
 
Posts: 242
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: Probem with killerhorse.eu

Postby a_pat on Thu Jul 31, 2014 4:02 pm

Sorry, have already tried that but it didn't work. Does someone know what the error message means?
a_pat
Level 1
Level 1
 
Posts: 6
Joined: Thu Jul 31, 2014 10:47 am

Re: Probem with killerhorse.eu

Postby py-thon on Thu Jul 31, 2014 4:48 pm

Forget about the error message.
It's just some package complaining that the kernel version is called 3.11-2 instead of 3.11.2 or 3.11.0-2 or something like that. You can google stuff like that :wink: (or use another search engine) and find hundreds of pages, for example https://bugs.debian.org/cgi-bin/bugrepo ... bug=732136 .

What happens when you start software-sources? Just the mentioned error message without the program starting? Or does the program start but not work like you expect it to work?
Tower: LMDE Mate 64bit - Netbook: LMDE Mate 32bit
py-thon
Level 4
Level 4
 
Posts: 242
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: Probem with killerhorse.eu

Postby Monsta on Fri Aug 01, 2014 8:22 am

a_pat wrote:when i run `mintsources` I get the following error message:

Code: Select all
glibtop: Non-standard uts for running kernel:
release 3.11-2-amd64=3.11.0 gives version code 199424

That's not an error message. That's a silly warning that's been around for a few months (or maybe even a year) and can be ignored.
Does mintsources run or not?
Monsta
Level 8
Level 8
 
Posts: 2447
Joined: Fri Aug 19, 2011 3:46 am

Re: Probem with killerhorse.eu

Postby a_pat on Fri Aug 01, 2014 9:16 am

Monsta wrote:Does mintsources run or not?

No it doesn't.
I'm running it as superuser via gksudo. i had to edit the sources.list by hand.
a_pat
Level 1
Level 1
 
Posts: 6
Joined: Thu Jul 31, 2014 10:47 am

Re: Probem with killerhorse.eu

Postby py-thon on Fri Aug 01, 2014 9:51 am

a_pat wrote:i had to edit the sources.list by hand.

/etc/apt/sources.list not used in LMDE anymore. It was replaced half a year ago (see http://debian.linuxmint.com/latest/update-pack.html ). Sources are in /etc/apt/sources.list.d/official-package-repositories.list now.

Can you access repos now or can't you?

Btw: you don't have to start mintsources with gksudo, starting it normally via terminal or menu will call the password window.
Tower: LMDE Mate 64bit - Netbook: LMDE Mate 32bit
py-thon
Level 4
Level 4
 
Posts: 242
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: Probem with killerhorse.eu

Postby a_pat on Fri Aug 01, 2014 11:13 am

Yes I can access the repositories now, but mintsources is still not working.

If i don't start it with gksudo, i get an error that /usr/share/python-apt/templates/LinuxMint.mirrors is missing (LinuxMint.info in that directory seems to have been update by the reinstall).

I have reinstalled mintsources and rechecked if i am on the newest update pack (update pack 8). I can live without it, but it is a little annoying.
a_pat
Level 1
Level 1
 
Posts: 6
Joined: Thu Jul 31, 2014 10:47 am

Re: Probem with killerhorse.eu

Postby py-thon on Fri Aug 01, 2014 12:20 pm

Is package mint-mirrors installed? It replaced the old mint-debian-mirrors and the current version came a few days ahead of UP8.
See http://blog.linuxmint.com/?p=2544 comment #34 and viewtopic.php?f=187&t=156044&start=160#p816854 .
Tower: LMDE Mate 64bit - Netbook: LMDE Mate 32bit
py-thon
Level 4
Level 4
 
Posts: 242
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: Probem with killerhorse.eu

Postby a_pat on Fri Aug 01, 2014 1:59 pm

A, thanks that solved it.
a_pat
Level 1
Level 1
 
Posts: 6
Joined: Thu Jul 31, 2014 10:47 am

Re: Probem with killerhorse.eu [solved]

Postby Monsta on Tue Aug 05, 2014 9:17 am

Today's update of mint-mirrors package should have this mirror removed.
Monsta
Level 8
Level 8
 
Posts: 2447
Joined: Fri Aug 19, 2011 3:46 am

Re: Probem with killerhorse.eu [solved]

Postby killerhorse on Wed Aug 06, 2014 10:22 am

Hi,

im VERRY SORRY about the problems with my mirror.
Everything startet with a faulty Harddisk wich was changed. Then a couple of mischances and unlucky occurrences caused the Server to be down for several Days.
Now it is up and running again.
Currently I'm synchronizing the mirror with one of the rsync mirrors. I will answer again if the mirror is ready to be added to the list again.

Best regards,
Christian
killerhorse
Level 1
Level 1
 
Posts: 6
Joined: Wed May 08, 2013 4:41 pm

Re: Probem with killerhorse.eu [solved]

Postby killer de bug on Wed Aug 06, 2014 3:13 pm

That's a really good news if this mirror is not discontinued. I will definitely use it as soon as it is available since it's really closed to my country :wink:
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1795
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: Probem with killerhorse.eu [solved]

Postby Monsta on Thu Aug 07, 2014 2:59 am

killerhorse wrote:I will answer again if the mirror is ready to be added to the list again.

This is good news. Visit Mint IRC developer channel (irc.spotchat.org, #linuxmint-dev) and ask Clem to re-add your mirror to the list. Or send an email via his profile.
Monsta
Level 8
Level 8
 
Posts: 2447
Joined: Fri Aug 19, 2011 3:46 am

Re: Probem with killerhorse.eu [solved]

Postby killerhorse on Tue Aug 12, 2014 4:18 am

The mirror is up again:
ISO images:
http://linuxmint-iso.killerhorse.eu

Linux Mint repositories:
http://linuxmint-apt.killerhorse.eu/packages/

Linux Mint Debian repositories:
http://linuxmint-apt.killerhorse.eu/debian/

I have already sent a mail to Clem.
killerhorse
Level 1
Level 1
 
Posts: 6
Joined: Wed May 08, 2013 4:41 pm

Re: Probem with killerhorse.eu [solved]

Postby killer de bug on Tue Aug 12, 2014 4:52 am

Thanks a lot for this mirror. :wink:
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1795
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: Probem with killerhorse.eu [solved]

Postby Monsta on Fri Aug 22, 2014 2:19 am

Yesterday's update of mint-mirrors package brings this mirror back.
Monsta
Level 8
Level 8
 
Posts: 2447
Joined: Fri Aug 19, 2011 3:46 am

Linux Mint is funded by ads and donations.
 
Next

Return to Update Packs Repositories

Who is online

Users browsing this forum: No registered users and 2 guests