UPDATE PACK 5 FEEDBACK THREAD

deb http://debian.linuxmint.com/incoming testing main contrib non-free
deb-src http://debian.linuxmint.com/incoming testing main contrib non-free
Forum rules
Before you post please read this

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby chemicalfan on Wed Aug 08, 2012 8:28 am

Right, sorry this is my first update, so I'm noob here :oops:

This is the thread I'm talking about - viewtopic.php?f=197&t=91405
Specifically:

- incoming repos:

Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import incoming
deb http://debian.linuxmint.com/incoming testing main contrib non-free
deb http://debian.linuxmint.com/incoming/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/incoming/multimedia testing main non-free

(your thread, I believe Zerozero! :D)

Has it always said that (at least, since UP4), or has that been changed recently?
chemicalfan
Level 2
Level 2
 
Posts: 64
Joined: Fri Mar 02, 2012 7:51 am
Location: Portsmouth, UK

Linux Mint is funded by ads and donations.
 

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby uglyone on Wed Aug 08, 2012 9:08 am

My disk run out of space.... and the upgrade continued witiut stoping. Any ideas on how to reinstall the upgrade???
uglyone
Level 1
Level 1
 
Posts: 10
Joined: Thu Nov 30, 2006 10:00 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby Schoelje on Wed Aug 08, 2012 9:20 am

@uglyone
To state the obvious, first make sure to free enough space on your disk (8G should do it). You won't be able to successfully end the upgrade process when you don't have enough disk space.

When you're convinced you have enough room, simply:
Code: Select all
sudo apt-get -f install && sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby uglyone on Wed Aug 08, 2012 9:21 am

I know that... however the update continued to the finish. Without stating that it had "no space left"
uglyone
Level 1
Level 1
 
Posts: 10
Joined: Thu Nov 30, 2006 10:00 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby Schoelje on Wed Aug 08, 2012 9:25 am

But did it end successfully?
Is your system working as expected (even after a reboot)?
If so, it seems that the upgrade finished just before running out of space.
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby uglyone on Wed Aug 08, 2012 9:27 am

Not everything is working: cinnamon logs me out right after login.
uglyone
Level 1
Level 1
 
Posts: 10
Joined: Thu Nov 30, 2006 10:00 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby Schoelje on Wed Aug 08, 2012 9:33 am

Please run this an post the results:
Code: Select all
apt policy cinnamon
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby uglyone on Wed Aug 08, 2012 9:44 am

Code: Select all
apt policy cinnamon
cinnamon:
  Installed: 1.4.0-lmde2UP3
  Candidate: 1.4.0-lmde2UP3
  Version table:
 *** 1.4.0-lmde2UP3 0
        700 http://packages.linuxmint.com/ debian/incoming amd64 Packages
        100 /var/lib/dpkg/status
     1.4.0-lmde1 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages
uglyone
Level 1
Level 1
 
Posts: 10
Joined: Thu Nov 30, 2006 10:00 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby Schoelje on Wed Aug 08, 2012 9:53 am

Looks good.
If you verified that your /etc/apt/sources.list looks exactly as stated in the first post of this thread, you could try to reinstall:
Code: Select all
apt-get install cinnamon --reinstall


In this same thread I read several issues with cinnamon, so read them carefully. There might be a hint to the solution of your problem.
e.g.: viewtopic.php?p=614674#p614674
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby uglyone on Wed Aug 08, 2012 10:19 am

I don't use "apt-get". I use aptitude. Howvever... tried that and didn't worked.
I got this message when i try to login (on gnome and cannamon): "failed to start session cinnamon"
uglyone
Level 1
Level 1
 
Posts: 10
Joined: Thu Nov 30, 2006 10:00 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby uglyone on Wed Aug 08, 2012 10:34 am

Problem solved. It finnaly gave me an option to read x11 error log and i notice that it complained about graphics card and 3d acelaration. So i wen back to nvidia current (with upgrade to sp5 it installed a beta driver).
Everything is runnign fine now :) Thanks very much for your help Schoelje . :)
Last edited by uglyone on Wed Aug 08, 2012 10:51 am, edited 1 time in total.
uglyone
Level 1
Level 1
 
Posts: 10
Joined: Thu Nov 30, 2006 10:00 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby Schoelje on Wed Aug 08, 2012 10:36 am

It sounds like an issue with your 3D card drivers...
Could you post the results of this:
Code: Select all
inxi -SGxrxxx
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby zerozero on Wed Aug 08, 2012 10:38 am

aptitude is usually more aggressive in the removals and trying to solve conflicts;
check carefully the removals you got in your system.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby uglyone on Wed Aug 08, 2012 11:01 am

Code: Select all
System:    Host uglyone Kernel 3.4.0-7.dmz.1-liquorix-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
Graphics:  Card NVIDIA C51 [GeForce Go 6150] X.Org 1.12.1.902 Res: 1280x800@60.0hz
           GLX Renderer GeForce Go 6150/integrated/SSE2 GLX Version 2.1.2 NVIDIA 304.32 Direct Rendering Yes
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com debian main upstream import incoming
           deb http://debian.linuxmint.com/incoming testing main contrib non-free
           deb http://debian.linuxmint.com/incoming/security testing/updates main contrib non-free
           deb http://debian.linuxmint.com/incoming/multimedia testing main non-free
           deb http://ppa.launchpad.net/hotot-team/ppa/ubuntu maverick main
           deb-src http://ppa.launchpad.net/hotot-team/ppa/ubuntu maverick main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google-talkplugin.list
           deb http://dl.google.com/linux/talkplugin/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/liquorix.list
           deb http://liquorix.net/debian sid main

When i switched to nvidia-current cinnamon worked just fine
Thanks you for your help :)
uglyone
Level 1
Level 1
 
Posts: 10
Joined: Thu Nov 30, 2006 10:00 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby chemicalfan on Wed Aug 08, 2012 3:59 pm

Got it working with the apt source update with incoming after a couple of upgrades & dist-upgrades. My only issue now is with the font colours in the windows now - the title bars are black font on black background, and a lot of the text within the window body is white on a grey background. This seems like the sort of thing I should be able to change via a GUI setting, but I can't find it (doh, noob failure). I suspect it could be changed in a config file too, but I don't know where cinnamon's settings are (another noob failure :()

Edit: Oh, and the menu is screwed up a bit - duplicate entries, the "Install Linux Mint" option. Oh, and the minimize and maximize buttons are invisible in the window decoration. The joys of unstable software! :D :roll:
chemicalfan
Level 2
Level 2
 
Posts: 64
Joined: Fri Mar 02, 2012 7:51 am
Location: Portsmouth, UK

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby mockturtl on Wed Aug 08, 2012 8:36 pm

chemicalfan wrote:Got it working with the apt source update with incoming after a couple of upgrades & dist-upgrades. My only issue now is with the font colours in the windows now - the title bars are black font on black background, and a lot of the text within the window body is white on a grey background. This seems like the sort of thing I should be able to change via a GUI setting, but I can't find it (doh, noob failure). I suspect it could be changed in a config file too, but I don't know where cinnamon's settings are (another noob failure :()

Oh, and the minimize and maximize buttons are invisible in the window decoration. The joys of unstable software! :D :roll:
Look for the ^ icon in the bottom right, or run cinnamon-settings from a terminal. Set "Themes -> Other Settings -> GTK+ theme" to Adwaita.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 442
Joined: Sat Oct 09, 2010 8:51 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby chemicalfan on Thu Aug 09, 2012 4:19 am

mockturtl wrote:Look for the ^ icon in the bottom right, or run cinnamon-settings from a terminal. Set "Themes -> Other Settings -> GTK+ theme" to Adwaita.


Thanks mate, will give it a go when I get in from work :)
chemicalfan
Level 2
Level 2
 
Posts: 64
Joined: Fri Mar 02, 2012 7:51 am
Location: Portsmouth, UK

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby ptruchon on Thu Aug 09, 2012 12:59 pm

First, thanks to everybody for helping out with LMDE. At home, we run latest on our two computers, but we also have incoming running on one partition so as to get ready for potential problems before they hit our main computers. Here is one (which is not LMDE's fault, but which I need to figure out at some point):

I use the fglrx-driver (ATI) for one of the computers (or else the fan runs full speed at 50 *C). But apparently, it works with xserver-xorg-core 2:1.11.4-1 of latest but not 2:1.12 of incoming. (See http://wiki.debian.org/ATIProprietary) Later today, I will reinstall LMDE on my testing partition and try to upgrade it to UP5 while keeping back the xserver-xorg-core packages to see if I can then install the fglrx-driver packages.

Since this isn't a problem with LMDE, I suspect that this problem will make its way into latest at some point. Does anyone have advice on how to best deal with this (short of staying with UP4 that is)? If not, I'll report back later today or tomorrow.

Cheers!
ptruchon
Level 1
Level 1
 
Posts: 22
Joined: Sun Nov 20, 2011 10:25 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby ketoth on Fri Aug 10, 2012 4:21 am

ptruchon wrote:First, thanks to everybody for helping out with LMDE. At home, we run latest on our two computers, but we also have incoming running on one partition so as to get ready for potential problems before they hit our main computers. Here is one (which is not LMDE's fault, but which I need to figure out at some point):

I use the fglrx-driver (ATI) for one of the computers (or else the fan runs full speed at 50 *C). But apparently, it works with xserver-xorg-core 2:1.11.4-1 of latest but not 2:1.12 of incoming. (See http://wiki.debian.org/ATIProprietary) Later today, I will reinstall LMDE on my testing partition and try to upgrade it to UP5 while keeping back the xserver-xorg-core packages to see if I can then install the fglrx-driver packages.

Since this isn't a problem with LMDE, I suspect that this problem will make its way into latest at some point. Does anyone have advice on how to best deal with this (short of staying with UP4 that is)? If not, I'll report back later today or tomorrow.

Cheers!

Yes by lacking precise hardware specs, the fans tend to fullspeed with the free drivers. Actually a noisy fan helps me to find out the proprietary driver isn't taking over control :D After installing fglrx and fglrx-control, run the control center with "sudo amdcccle". If you have to run "sudo aticonfig --initial", it will tell you. A reboot later and normally everything's fine with the fan. (actually, a reboot is always necessary after fglrx install).

And oh, please double-check: an idling GPU should be at lower than 50°C. Isn't it the CPU fan who runs crazy ? (it isn't unlikely that a loop bug in the desktop environment keeps a core working for nothing)
Proud Linux Mint Debian user since 04/2011
mirror.rts-informatique.fr mirror tech maintainer

Likes GPL and Creative Commons and people using them
Somewhere between Linus Torvalds and Richard Stallman
ketoth
Level 2
Level 2
 
Posts: 81
Joined: Sat Dec 31, 2011 8:01 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby appye on Mon Aug 13, 2012 5:56 pm

REBOOT prompt. Something. It is unnerving when a major system update (especially a UP, which should REQUIRE a reboot) just blinks out like that. I run the updates, and then the whole thing blinks out and changes the mintupdate-debian icon to the standard green checkbox. Why is there no dialogue of any kind after mintupdate is finished running? This seems like a silly oversight to me.
appye
Level 1
Level 1
 
Posts: 23
Joined: Mon Sep 12, 2011 12:22 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Linux Mint Debian Incoming

Who is online

Users browsing this forum: No registered users and 2 guests