UPDATE PACK 4 FEEDBACK THREAD

deb http://debian.linuxmint.com/incoming testing main contrib non-free
deb-src http://debian.linuxmint.com/incoming testing main contrib non-free
Forum rules
Before you post please read this

UPDATE PACK 4 FEEDBACK THREAD

Postby clem on Thu Feb 23, 2012 9:05 am

Update Pack 4 is ready for you to test ;)

Sources:

deb http://debian.linuxmint.com/incoming testing main contrib non-free
deb http://debian.linuxmint.com/incoming/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/incoming/multimedia testing main non-free

Rules:

- This thread is for users of the Linux Mint Debian Incoming repository only.
- This thread is for users of the Linux Mint Debian Incoming repository to report problems to the team, so that the team can relay them towards all LMDE users via the Update Manager.
- If you're pointing to the Debian repositories, do not post in here.
- If you're looking for support, answers or information, do not post in here.

When posting about a regression or tricky upgrade, please include the following:

- The package update which is problematic.
- If you can, analyse the cause of the problem and why it is happening.
- If you solved it or found a workaround, please post it as well.
- Include any information you think might help the team solve the problem for others, or that might help others to work around the problem.

Any post not following these rules will be deleted.

The Update Pack repositories were created to help people help each others identify regressions coming from Debian Testing and to give the team the opportunity to fix things at regular intervals. I'd like to thank all the people who will somehow act as guinea pigs while using the Incoming update-packs and thanks to whom users of the Latest update-packs will have an easier life.

Important updates in this Update Pack:

- Gnome 2 is no longer available and replaced with Gnome Shell
- Cinnamon 1.3.1 is being made available from the Linux Mint repositories
- MATE 1.2 is being made available from the Linux Mint repositories
- There's a new Kernel in town (3.2)
- New versions of xorg and impacts on dkms

The purpose of this thread is to do the following:

- Establish whether or not what's in incoming is "stable" enough for us to push it to "latest". So if you find critical problems, do let us know here.
- Gather information about workarounds and tricks so that we can document these and ensure "latest" users have a smoother upgrade than you did with "incoming".

Good luck. Thanks for choosing Mint and thanks for helping out!
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5566
Joined: Wed Nov 15, 2006 8:34 am

Linux Mint is funded by ads and donations.
 

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby Ronis_BR on Thu Feb 23, 2012 9:31 am

Hi Clem,

Thanks for this!

When I try to update, the following packages are marked to be removed:

aptdaemon capplets-data compiz-gnome console-terminus deskbar-applet dropbox g++-4.3 gcc-4.3 gnome-about libbrasero-media0 libepc-1.0-2 libepc-ui-1.0-2 libevince3 libgcr-3-0 libgnome-desktop-3-0 libmetacity-private0 libnautilus-extension1 libperl5.12 libpulse-browse0 libstdc++6-4.3-dev mint-meta-codecs mint-meta-common mint-meta-debian mintinstall mintmenu nautilus-dropbox nautilus-gksu python-aptdaemon python-docky xchat

gcc-4.3, g++-4.3, and libstdc++-6-4.3 was installed manually from debian testing repositories because I need this gcc version to compile a source code here. Excluding that, is everything fine?

Thanks,
Ronan
Ronis_BR
Level 1
Level 1
 
Posts: 7
Joined: Thu Feb 23, 2012 9:23 am

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby clem on Thu Feb 23, 2012 10:19 am

Note to self: xchat and xchat-common need to be recompiled and repinned for UP4.
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5566
Joined: Wed Nov 15, 2006 8:34 am

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby clem on Thu Feb 23, 2012 11:08 am

Cinnamon 1.3.1 and muffin 1.0.1 are now in the repository.
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5566
Joined: Wed Nov 15, 2006 8:34 am

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby msm on Thu Feb 23, 2012 11:26 am

Do I replace or add these repositories with the ones already inserted?
msm
Level 3
Level 3
 
Posts: 138
Joined: Tue Mar 23, 2010 7:40 am
Location: Dublin, Ireland

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby kwisher on Thu Feb 23, 2012 11:28 am

Imaging my disk with CloneZilla as I type and will pull the trigger on this shortly. I will report back if I find any issues.

Thanks Clem, for your efforts with this update and all the other work you do.
The instructions suggested Windows XP or better, so I installed Linux :)
User avatar
kwisher
Level 5
Level 5
 
Posts: 642
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby aljoriz on Thu Feb 23, 2012 11:29 am

Using Debian XFCE

I change the sources to point to the one posted by clem, did a reboot (the longest time in my life) but wasn't able to log in, rebooted again but used the recovery kernel and did a "sudo dpkg --configure -a"

The 3rd reboot I was able to log in checked the update manager but it says I have 5 broken packages:
eog
libperl5.14
libpurple0
perl
pidgin

(memo to self, always backup data before doing risky stuff like these)

need advise on what to do with broken packages.
aljoriz
Level 4
Level 4
 
Posts: 269
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby zerozero on Thu Feb 23, 2012 11:54 am

msm wrote:Do I replace or add these repositories with the ones already inserted?

it depends, if you already have the incoming repos, you do nothing, they are the same :) inxi -r in the terminal should tell you.

as a general note (for everybody using gnome mainly) before issuing the update check if you have compiz in the startup-app, if so remove it from there otherwise gnome-shell won't start (and i believe cinnamon neither, but i didn't test this) - this of course if you are interested in trying gnome-shell :lol:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby hellfire695 on Thu Feb 23, 2012 12:57 pm

this is exciting XD is mate included?
User avatar
hellfire695
Level 3
Level 3
 
Posts: 129
Joined: Thu Jan 19, 2012 4:25 pm

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby BenNZ on Thu Feb 23, 2012 1:17 pm

Running lmde xfce 32 bit
Gdm3 just has a plain blue background , and i believe it should have a blue with vertical lines
The mint menu icons have moved to /usr/share/linuxmint/mintinstall/icons/mintmenu.png
If i boot into tty1 , ie appending 'text' to the kernel arguement , login then type startx , i just get a blank screen , yet if i boot normally i can get into x -- was able to fix by removing ~/.Xauthority
/etc/modprobe.d/blacklist.conf also seemed to have been deleted, i was able to cp a backup , just thought it was odd that it was removed
had to reinstall the nvidia driver again , for some reason i was able to sh NVIDIA-Linux-x86-295.20.run , but was able to chmod +x NVIDIA-Linux-x86-295.20.run && ./NVIDIA-Linux-x86-295.20.run
xchat was removed and now i cant reinstall it , i get
The following packages have unmet dependencies:
xchat : Depends: libperl5.12 (>= 5.12.3) but it is not installable
Last edited by BenNZ on Thu Feb 23, 2012 1:38 pm, edited 1 time in total.
BenNZ
Level 1
Level 1
 
Posts: 5
Joined: Thu Feb 23, 2012 12:56 pm

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby timbo on Thu Feb 23, 2012 1:29 pm

After changing sources to incoming I ran the updates (~733mb) and except for some minor glitches everything is running nicely.

* VLC keeps crashing when I use its browser to open directories
Code: Select all
~$ vlc
VLC media player 1.1.13 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x25c7120] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Blocked: call to setlocale(6, "")
Blocked: call to setenv("ORBIT_SOCKETDIR", "/tmp/orbit-timbo", 1)
Warning: call to srand(1330495179)
Warning: call to rand()
Blocked: call to setlocale(6, "")

(process:19184): Gtk-WARNING **: Locale not supported by C library.
   Using the fallback 'C' locale.
libdvdnav: Using dvdnav version 4.2.0
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdread: Couldn't find device name.
libdvdnav:DVDOpenFilePath:findDVDFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFilePath:findDVDFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
libdvdnav: Using dvdnav version 4.2.0
libdvdread: Using libdvdcss version 1.2.10 for DVD access
Segmentation fault


* Thunderbird was removed while Firefox stayed (I changed back to latest and reinstalled it)

* the new sudoers file was missing the following lines
Code: Select all
Defaults env_reset
Defaults secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"


That's all specific to my system I guess but sharing it couldn't hurt I thought.

Lastly let me express my huge gratitude to the people who keep LMDE going. It's the best concept of a Linux distro that I've been using and I am glad to have that choice.
timbo
Level 2
Level 2
 
Posts: 52
Joined: Sun Oct 09, 2011 5:06 pm

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby zerozero on Thu Feb 23, 2012 1:32 pm

still preparing to update, but these xorg held back are worrying
Code: Select all
The following packages have been kept back:

  xserver-xorg xserver-xorg-core xserver-xorg-input-evdev

  xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-apm

  xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips

  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-i128

  xserver-xorg-video-i740 xserver-xorg-video-intel xserver-xorg-video-mach64

  xserver-xorg-video-mga xserver-xorg-video-neomagic

  xserver-xorg-video-nouveau xserver-xorg-video-openchrome

  xserver-xorg-video-r128 xserver-xorg-video-radeon

  xserver-xorg-video-rendition xserver-xorg-video-s3

  xserver-xorg-video-s3virge xserver-xorg-video-savage

  xserver-xorg-video-siliconmotion xserver-xorg-video-sis

  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident

  xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware

  xserver-xorg-video-voodoo

http://pastebin.com/MSS3580M
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby kwisher on Thu Feb 23, 2012 1:56 pm

Just did a full update. Immediately installed Cinnamon after signing into the default gnome3 desktop.

1) zerozero - also seeing all the xserver-xorg packages being held back
2) how do I install Mate? I search for it in synaptic and nothing is found? Is there another repo that needs to be added?
3) Dropbox was removed and will not reinstall with synaptic
4) Right clicking a menu application icon and choosing "Add to Desktop" does not work in Cinnamon
5) Nvidia dual monitors - when trying to switch desktops only one desktop on one monitor changes. Previously this used to switch to new desktop on both monitors. This is happening on Cinnamon.

EDIT:
6) Last straw for me before I had to restore back to UP3 - used the "Lock Screen" from menu as I would normally when leaving my work machine. Came back and login screen would not come back up by moving mouse or tapping keyboard. Had to "ctrl-alt-bksp" to get back in.
Last edited by kwisher on Thu Feb 23, 2012 3:49 pm, edited 1 time in total.
The instructions suggested Windows XP or better, so I installed Linux :)
User avatar
kwisher
Level 5
Level 5
 
Posts: 642
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby grizzler on Thu Feb 23, 2012 2:10 pm

You should not have ignored https://bugs.launchpad.net/bugs/881916

It's a good thing I decided to create a copy of my installation on another partition and update that instead of my real installation.

I have some further comments, but they will have to wait until I have found a way to work around the message from grub that it cannot find the kernel file.

Edit: forget that. All my other comments have to do with the deficient sh*t that we were given by the Gnome developers. Gnome3 is an absolute abomination created by failed Apple fanboys - Cinnamon looks promising; thanks Clem (pity it's too slow to keep up with my typing and clicking though - looks like I will not be updating my main system just yet).

Edit2: where's MATE? Cinnamon just isn't working for me (yet). Too slow and missing too many things I NEED (like being able to edit settings - dconf-editor won't allow me to set up the panels properly).
Last edited by grizzler on Thu Feb 23, 2012 5:59 pm, edited 2 times in total.
grizzler
Level 4
Level 4
 
Posts: 462
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby squeezy on Thu Feb 23, 2012 2:21 pm

Hi, signed up to the forum just because of this announcement. Been using LMDE since Nov '11 and I love it. Was really waiting for this UP! I've installed LMDE at least a dozen times, trying Gnome and XFCE, different configs, customizations, etc. The whole shot.

My last install was highly customized and UP4 wanted to reinstall some of the things I'd removed, like avahi, bluez, pulse to name a few. Heck, I had it down to 1017 packages installed and still fully functional for me. I thought, if I have to recustomize everything, I'd do a more standard install and report on the upgrade experience.

So, just did a fresh install of the Gnome version. Am updating against Latest right now to bring it up to speed, then will update to Incoming. Haven't added, removed any software, changed any system settings, etc. Will report on the results.

Thanks for a great distro, Clem and crew! :D
squeezy
Level 5
Level 5
 
Posts: 567
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby squeezy on Thu Feb 23, 2012 3:38 pm

Running the update against Incoming right now. Perhaps useful info for some:

Against a dead stock LMDE UP3 install, cleaned up using the upgrade-system package (try it!), UP4 consists of:

Code: Select all
890 upgraded, 272 newly installed, 26 to remove and 34 not upgraded.
Need to get 937 MB of archives.
After this operation, 171 MB of additional disk space will be used.
Do you want to continue [Y/n]? y


You will loose Thunderbird, Mint Install, Mint Menu, X-Chat, aptdeamon, some Mint meta packs.

34 X-org packages not updated as mentioned previously.

Will report on success of UP4 update in about an hour and a half :D
squeezy
Level 5
Level 5
 
Posts: 567
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby whirly on Thu Feb 23, 2012 5:01 pm

fully updated
nvidia 290 kernel 3.2
five big apt listbugs warnings before going forward with yes or no. they were for stuff that never works anyway like evolution and nautilus
i seem to have lost my backslash éé looks like keyboard thinks i french canadian éé
je nas parlez mon keyboard en anglais sil vous
it's up on the fresh shell panel /////
merci
network gets updated so it will go down
the smart guy uses a wired connection
not me
I check system settings and fixed it before i rebooted
then i checked if everything went as it should in terminal
rebooted
here i am
synaptics is showing a bunch of xorgs held back for me too
like 31 actually
so as i've learned, i commented out the mints and away they go all updated couple new font confs
apt says lib cairo makes it all go rectangles ignoring those two for now
bob is my uncle
all updated
no giant issues
nice work
wish i had an exciting crash or something
whirly
Level 2
Level 2
 
Posts: 68
Joined: Tue Jul 05, 2011 7:20 pm

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby Ronis_BR on Thu Feb 23, 2012 5:12 pm

Hi Clem,

The update here occurred flawlessly!
Although, with the update, the font rendering is much worse than it was before. I have already checked hinting and anti-aliasing but I just can't have the quality I had with gnome 2. Is there any way to fix it?

Thanks,
Ronan
Ronis_BR
Level 1
Level 1
 
Posts: 7
Joined: Thu Feb 23, 2012 9:23 am

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby ragesoss on Thu Feb 23, 2012 5:40 pm

I did a safe upgrade first, and then started going through with Synaptic to do as many upgrades as I could find that didn't look like they'd cause major breakage.

On my system, there are a few dozen packages it wants to remove for a full update, similar to what squeezy notes above (plus a bunch of libraries and assorted gnome packages that are probably supposed to be removed).

Dropbox is the one thing that pops up that I know I don't want to remove. It looks like the Nautilus upgrade conflicts with nautilus-dropbox (which I notice is an lmde-specific version).
ragesoss
Level 1
Level 1
 
Posts: 10
Joined: Mon Aug 22, 2011 12:13 pm

Re: UPDATE PACK 4 FEEDBACK THREAD

Postby zerozero on Thu Feb 23, 2012 5:41 pm

fully updated and in the system again (so nothing broke)

- even with all those xorg held back, no problems with nvidia (smooth transition from 280 to 290 with dkms)
Code: Select all
amadeu@zerozero:~$ apt-cache policy nvidia-glx
nvidia-glx:
  Installed: 290.10-1
  Candidate: 290.10-1
  Version table:
 *** 290.10-1 0
        500 http://debian.linuxmint.com/incoming/ testing/non-free amd64 Packages
        100 /var/lib/dpkg/status


- about the xserver issues i hope this helps
Code: Select all
amadeu@zerozero:~$ apt install xserver-xorg-core
[sudo] password for amadeu:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-core : Depends: libpixman-1-0 (>= 0.21.6) but 0.20.2-0ubuntu1 is to be installed
E: Broken packages


- dropbox (it's a known issue in testing for some time)
Code: Select all
amadeu@zerozero:~$ apt-cache policy nautilus-dropbox
nautilus-dropbox:
  Installed: (none)
  Candidate: 0.6.7-lmde
  Version table:
     0.7.1-2 0
        500 http://debian.linuxmint.com/incoming/ testing/non-free amd64 Packages
     0.6.7-lmde 0
        700 http://packages.linuxmint.com/ debian/import amd64 Packages
        100 /var/lib/dpkg/status
version 0.7.1-2 works but is hidden

- kwisher, Mate is not yet available (at this moment) and add to desktop works in cinnamon but first you need to have the file manager handle the desktop (you find that setting in cinnamon-settings > desktop

- xchat is removed in the update and not installable
Code: Select all
amadeu@zerozero:~$ apt install xchat
[sudo] password for amadeu:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xchat : Depends: libperl5.12 (>= 5.12.3) but it is not installable
E: Broken packages
amadeu@zerozero:~$
but xchat-gnome (ugly as sin :shock: ) works for now and picks the .xchat2 settings
Code: Select all
amadeu@zerozero:~$ apt-cache policy xchat-gnome
xchat-gnome:
  Installed: 1:0.30.0~git20110821.e2a400-0.2+b2
  Candidate: 1:0.30.0~git20110821.e2a400-0.2+b2
  Version table:
 *** 1:0.30.0~git20110821.e2a400-0.2+b2 0
        500 http://debian.linuxmint.com/incoming/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Linux Mint Debian Incoming

Who is online

Users browsing this forum: No registered users and 1 guest