lmde home folder issue

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

lmde home folder issue

Postby bramete on Wed Apr 25, 2012 7:53 am

Hi!!
if anyone knows the answer...
i'm coming from mint ubuntu and wanted to go to lmde, i've got my home folder in a diferent drive, with the ubuntu edition no problem, but wit lmde i can't make the installation asigning home to a diferent drive.
any workaround/solution?
thx in advance
bramete
Level 1
Level 1
 
Posts: 1
Joined: Wed Apr 25, 2012 7:45 am

Linux Mint is funded by ads and donations.
 

Re: lmde home folder issue

Postby stingray on Tue May 01, 2012 10:48 pm

I have the same problem. I have two hard drives and I want to use sda for the OS and sdb (which is already /home for another installation) for /home.

It looks like you can do it the way discussed here by editing fstab but you should have the option to do it during the install. I just want to make sure I don't wipe out what I already have on sdb.
stingray
Level 1
Level 1
 
Posts: 11
Joined: Thu Oct 28, 2010 11:54 am

Re: lmde home folder issue

Postby stingray on Sun May 06, 2012 11:23 am

I followed the advice in that thread and everything seems fine. Here's what I did:

Restart in recovery mode

Copy all the data from the current /home to the desired /home location. This includes hidden and system files. You can delete this stuff from the current /home location to save some space (probably around 100MB).

Edit fstab to mount /home on the new drive (in a terminal enter "sudo pluma /etc/fstab"). I followed the format already in fstab where they go by UUID. The options I used are "nodev,nosuid,relatime". Save and close fstab.

Restart the computer and login.

When I first logged in I got a message:
User's $HOME/.dmrc file is being ignored. This prevents the default session and language from being saved. File should be owned by user and have 644 permissions. User's $HOME directory must be owned by user and not writable by other users.
This seemed easy enough to fix, I just changed the home folder (/home/$USERNAME) permissions to Owner: read and write, Group: read, Others: read.

This is probably really easy obvious stuff for some but I only half know what I'm doing with some of this stuff so I have to look everything up and I'm sure there are those who know less than me. If you see a glaring mistake please let me know.

Some helpful links:
Using UUID - Ubuntu help
About Fstab - Ubuntu help
How to Fstab - Ubuntu forums
How to edit and understand /etc/fstab - tuxfiles
Fstab - LinuxQuestions
fstab - Wikipedia
stingray
Level 1
Level 1
 
Posts: 11
Joined: Thu Oct 28, 2010 11:54 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 8 guests