Minimal install problems

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

Minimal install problems

Postby TheLastStud on Sun May 20, 2012 11:28 am

Hi, I'm trying to do a minimal install of Debian testing. However, instead of using the official wheezy repos, I want to use the Latest repository of Mint (because I want to be safe from random breakages). I'm first trying it on VirtualBox. after the minimal installation, this is what i've done so far:

-intall sudo => apt-get install sudo

-set up sudo => visudo => beneath the “root ALL=(ALL) ALL" type “YOURUSERNAME ALL=(ALL) ALL” => save and exit

-change /etc/apt/sources.list file as follows:
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free

-fix update expired error:
touch /etc/apt/apt.conf.d/80mintupdate-debian
add line : ` Acquire::Check-Valid-Until "false"; `

-sudo apt-get update

when I now try to install xorg, it complains about missing dependency xserver-xorg. Please help.
TheLastStud
Level 1
Level 1
 
Posts: 12
Joined: Sun Apr 24, 2011 6:50 am

Linux Mint is funded by ads and donations.
 

Re: Minimal install problems

Postby zerozero on Sun May 20, 2012 1:12 pm

- did you start with a testing-iso (net-install?) or ...?
zerozero
Level 16
Level 16
 
Posts: 6474
Joined: Tue Jul 07, 2009 2:29 pm

Re: Minimal install problems

Postby TheLastStud on Sun May 20, 2012 1:32 pm

I used the one labelled: debian-wheezy-DI-a1-i386-netinst.iso
TheLastStud
Level 1
Level 1
 
Posts: 12
Joined: Sun Apr 24, 2011 6:50 am

Re: Minimal install problems

Postby zerozero on Sun May 20, 2012 3:02 pm

well, of course both (xorg and xserver-xorg) are in debian's ftp;
so what happens here?
- my guess is that with net-install and consequent change of repos to latest you have a mismatch: latest was frozen around the 20th march http://forums.linuxmint.com/viewtopic.php?f=187&t=95434&hilit=sync&start=120#p557152, your net-install pulled the newest pkgs from debian's servers .
- solutions: none perfect i'm afraid, but:
  • you could try to set up the system while using the debian repos and then change to the mint repos afterwards (but you would end up with a system with higher v. of almost all pkgs and lib and that could be also problematic)
  • you could install squeeze and upgrade from there to the mint repos directly (but that is a very long and complicated upgrade at the moment)

but just out of curiosity what is the output of both apt-cache policy? and if you try to install xserver-xorg first?
zerozero
Level 16
Level 16
 
Posts: 6474
Joined: Tue Jul 07, 2009 2:29 pm

Re: Minimal install problems

Postby squeezy on Sun May 20, 2012 3:15 pm

I believe zerozero has it nailed. You used a current wheezy ISO which has newer packages than Mint's 'latest' repo. That's going to cause dependency issues. You want to do upgrades from a lower version release to a higher version, not the other way around.

The way I start my minimal installs is with a squeeze live ISO that provides a console-only installation, then perform your steps to convert to Mint repos and do your dist-upgrade. You'll download about ~140 MB for the upgrade. Using the live ISO negates the need to download the initial install, except for when it updates the repos.

You can find various Live ISOs here, http://www.debian.org/CD/live/

The one I use is called debian-live-6.0.4-i386-standard.iso. The 'standard' release doesn't install any desktops or anything like that, just a barebones command line installation.
squeezy
Level 5
Level 5
 
Posts: 567
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: Minimal install problems

Postby TheLastStud on Sun May 20, 2012 4:16 pm

thanks for your replies :)
Here's the output I get when I try to install xorg:

The following packages have unmet dependencies:
xorg: Depends: xserver-xorg ( >= 1:7.6+12) but it is not going to be installed
E: Broken packages


If I try to install xserver-xorg first, it shows:

The following packages have unmet dependencies:
xserver-xorg: Depends: xserver-xorg-input-all but it is not going to be installed or
xserver-driver-input
Depends: xserver-xorg-input-evdev but it is not going to be installed
E: Broken packages


I'll try again with the squeeze iso and post the results. Thanks again for your help!!

BTW what is the difference between the standard live iso and the netinst iso?
TheLastStud
Level 1
Level 1
 
Posts: 12
Joined: Sun Apr 24, 2011 6:50 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 5 guests