nouveau stopping me dead.

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

nouveau stopping me dead.

Postby RatCamper on Thu Jun 21, 2012 2:23 am

I know this is not a new problem but I haven't seen any real workarounds that work for me. nouveau just simply doesn't seem to work on anything, causing hangups and just plain lockups due to GPU lockups. I've experienced this across a few computers with Geforce 4, 6, 7 and 8 derivatives. A while back I slowly struggled through an install, taking hours and a lot of guesswork to get it installed. Manage dthat a couple of times barely.

I just got a nice new SSD and wanted to put LMDE on it. I tried installing both XFCE and Cinnamon variants (x64) and they were unusable because of the GPU lockups. I tried passing xforcevesa and nomodeset and removing quiet splash, and all that yielded was a black screen instead of lockup and garbage.

Currently I'm using Debian because it has a plain installer which I'm guessing uses vesa. I installed it, made a few changes so I could boot without nouveau caused lockups using a USB hard drive, got the nvidia binaries on there and it was all good.

This debian install is only tentative and if possible I'd like to replace it with LMDE before I shift my stuff in. I like Mint and I like Debian, but am not overly fond of Ubuntu, so LMDE seemed perfect. But I can't install it because of stupid graphics drivers. I can fix it if I can install it, but if I can't install it I don't stand a chance.

What are my options here?
RatCamper
Level 1
Level 1
 
Posts: 4
Joined: Wed Jan 25, 2012 8:07 pm

Linux Mint is funded by ads and donations.
 

Re: nouveau stopping me dead.

Postby dwainehead on Thu Jun 21, 2012 10:45 am

Check out my install fix for my 550TI it might help you.

viewtopic.php?f=189&t=101086

in the last post of the thread.
LMDE x64 20120409 UP5 AMD FX 4100 x4 3.6gHz Gigabyte GA-970A-UD3 16g Corsair Vengeance PC1600 Hitachi 750gig sata 3 EVGA Geforce 550Ti 1g kernel 3.2.0-3
User avatar
dwainehead
Level 2
Level 2
 
Posts: 56
Joined: Tue Jan 10, 2012 2:03 pm

Re: nouveau stopping me dead.

Postby RatCamper on Fri Jun 22, 2012 2:40 am

I'll give that a shot and post results. Nothing worth saving on this debian install anyway. It's only a couple of days old and was just an experiment. Glad the Debian philosophy hasn't changed much. Hope I'll be replying next from LMDE.
RatCamper
Level 1
Level 1
 
Posts: 4
Joined: Wed Jan 25, 2012 8:07 pm

Re: nouveau stopping me dead.

Postby RatCamper on Fri Jun 22, 2012 4:07 am

Posting from LMDE!
Mostly copypasted this from another forum I put this in. Sorry about that!

Code: Select all
acpi=off noacpi xforcevesa nomodeset

nouveau never gets a single toe in and no GPU locks occur. Didn't have to deal with any options or prompts. Do the install and reboot. If it does what it did to me it'll drop back to a shell. That's okay. Install nvidia-glx and let it do its magic. That should install all the dependencies. You could reboot after that I guess. I just logged in as root and did
Code: Select all
mdm --restart


Wouldn't do that on a commercial machine but I'm happy to do that to get a system on its feet.

Unfortunately I used the xfce disc instead of the cinnamon disc but it's only an
Code: Select all
apt-get install cinnamon
away.

Now to go through and apply everything I worked out in the debian install before to be a little bit more SSD friendly.

While I'm here I'll add that if you are doing a multi partition install on a system with partitions that you want to recycle, from the partition selection screen, not gparted, right click on the partitions to assign them their functions. These options are disabled in gparted in the installer for some reason.
RatCamper
Level 1
Level 1
 
Posts: 4
Joined: Wed Jan 25, 2012 8:07 pm


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 4 guests