Live installer hangs in KDE [Solved]

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

Live installer hangs in KDE [Solved]

Postby Schoelje on Wed Jun 27, 2012 2:54 pm

I'm working on a custom live DVD: LMDE KDE.
The live DVD works perfectly but when I try to install, the live-installer hangs when setting the hostname.

Starting live installer:
gksu live-installer --debug | tee live_debug_file
Shows that the installer hangs while "Processing triggers for menu ...":

Code: Select all
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
950976 inodes, 3803388 blocks
190169 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=3896508416
117 block groups
32768 blocks per group, 32768 fragments per group
8128 inodes per group
Superblock backups stored on blocks:
   32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208

Allocating group tables:   ...

Removing user `mint' ...
Warning: group `mint' has no more members.
Done.
Reading package lists...
Building dependency tree...
Reading state information...
Package live-initramfs is not installed, so not removed
The following packages will be REMOVED:
  live-boot* live-boot-initramfs-tools* live-config* live-config-sysvinit*
  live-installer*
0 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
After this operation, 1,251 kB disk space will be freed.
(Reading database ... 123943 files and directories currently installed.)
Removing live-boot ...
Purging configuration files for live-boot ...
Removing live-boot-initramfs-tools ...
Removing live-config ...
Purging configuration files for live-config ...
Removing live-config-sysvinit ...
Purging configuration files for live-config-sysvinit ...
Removing live-installer ...
Purging configuration files for live-installer ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-2-486
Processing triggers for desktop-file-utils ...
Processing triggers for menu ...


In a normal LMDE install:

Code: Select all
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
952848 inodes, 3807405 blocks
190370 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=3900702720
117 block groups
32768 blocks per group, 32768 fragments per group
8144 inodes per group
Superblock backups stored on blocks:
   32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208

Allocating group tables:   ...

Removing user `mint' ...
Warning: group `mint' has no more members.
Done.
Reading package lists...
Building dependency tree...
Reading state information...
Package live-initramfs is not installed, so not removed
The following packages will be REMOVED:
  live-boot* live-boot-initramfs-tools* live-config* live-config-sysvinit*
  live-installer*
0 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
After this operation, 1,251 kB disk space will be freed.
(Reading database ... 168492 files and directories currently installed.)
Removing live-boot ...
Purging configuration files for live-boot ...
Removing live-boot-initramfs-tools ...
Removing live-config ...
Purging configuration files for live-config ...
Removing live-config-sysvinit ...
Purging configuration files for live-config-sysvinit ...
Removing live-installer ...
Purging configuration files for live-installer ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-2-amd64
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for menu ...
Generating locales (this might take a while)...
  en_US.UTF-8... done
  en_US.UTF-8... done
Generation complete.
Installation finished. No error reported.
 ## INSTALLATION
 --> Installation started
EXECUTING: 'mkfs.ext4 /dev/sda2'
 --> Mounting partitions
 ------ Mounting /live/image/casper/filesystem.squashfs on /source/
EXECUTING: 'mount -o loop -t squashfs /live/image/casper/filesystem.squashfs /source/'
 ------ Mounting /dev/sda2 on /target/
EXECUTING: 'mount -t ext4 /dev/sda2 /target'
 --> Indexing files
 --> Copying files
 --> Restoring meta-info
 --> Chrooting
 --> Removing live user
 --> Removing live-initramfs
 --> Adding new user
 --> Writing fstab
 --> Writing hostname
 --> Configuring MDM
 --> Setting the locale
 --> Setting the timezone
 --> Localizing Firefox and Thunderbird
 --> Setting the keyboard
 --> Configuring Grub
 --> Running grub-install
 --> Running grub-mkconfig
 --> Checking Grub configuration
 --> Found Grub theme: if background_image /boot/grub/linuxmint.png; then
 --> Found Grub theme: if background_image /boot/grub/linuxmint.png ; then
 --> Found Grub entry: menuentry 'LinuxMint GNU/Linux, with Linux 3.2.0-2-amd64' --class linuxmint --class gnu-linux --class gnu --class os {
 --> Found Grub entry: menuentry 'LinuxMint GNU/Linux, with Linux 3.2.0-2-amd64 (recovery mode)' --class linuxmint --class gnu-linux --class gnu --class os {
 --> Cleaning APT
 --> Unmounting partitions
EXECUTING: 'umount /target'
EXECUTING: 'umount /source'
 --> All done
 ## INSTALLATION COMPLETE


Seeing that I miss "Processing triggers for gnome-menus ..." or better, a KDE equivalent, I suspect that the installer is made for Gnome only...
Can anybody verify this?

==============================================================

[Edit]
Live-installer was not created with KDE in mind and needed some adaptation: viewtopic.php?f=148&t=106318

The install runs smoothly now!
Last edited by Schoelje on Sat Jul 21, 2012 6:07 pm, edited 1 time in total.
User avatar
Schoelje
Level 5
Level 5
 
Posts: 791
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands

Linux Mint is funded by ads and donations.
 

Re: Live installer hangs in KDE [Solved]

Postby Oscar799 on Fri Jun 29, 2012 3:52 am

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8699
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 3 guests