x-windows not starting on console

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read how to get help

x-windows not starting on console

Postby sorcerer on Tue Aug 21, 2012 4:20 pm

i don't permanently use x-windows on console (most of the time i use tightvnc server)
it was working when i installed the system, then i stop using it (deactivated mdm) then i update system
and now i cannot start x-windows on console :(
and i can't figure out what is the problem, i installed xserver-xorg-video-nvidia, still not working
log is:
Code: Select all
[   187.704]
X.Org X Server 1.11.4
Release Date: 2012-01-27
[   187.704] X Protocol Version 11, Revision 0
[   187.704] Build Operating System: Linux 3.2.0-1-amd64 x86_64 Debian
[   187.704] Current Operating System: Linux coruscant 3.2.0-2-amd64 #1 SMP Sun Mar 4 22:48:17 UTC 2012 x86_64
[   187.704] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-2-amd64 root=UUID=84d9b912-305b-4a99-8b73-7d6e80320665 ro quiet
[   187.704] Build Date: 04 March 2012  11:42:13PM
[   187.704] xorg-server 2:1.11.4-1 (Cyril Brulebois <kibi@debian.org>)
[   187.704] Current version of pixman: 0.24.4
[   187.704]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   187.704] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   187.704] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 21 17:48:51 2012
[   187.705] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   187.705] (==) No Layout section.  Using the first Screen section.
[   187.705] (==) No screen section available. Using defaults.
[   187.705] (**) |-->Screen "Default Screen Section" (0)
[   187.705] (**) |   |-->Monitor "<default monitor>"
[   187.705] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[   187.705] (==) Automatically adding devices
[   187.705] (==) Automatically enabling devices
[   187.705] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   187.705]    Entry deleted from font path.
[   187.705] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   187.705]    Entry deleted from font path.
[   187.705] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   187.705]    Entry deleted from font path.
[   187.705] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   187.705]    Entry deleted from font path.
[   187.705] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   187.705]    Entry deleted from font path.
[   187.705] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins
[   187.705] (==) ModulePath set to "/usr/lib/xorg/modules"
[   187.705] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[   187.705] (II) Loader magic: 0x7fd2ec893ae0
[   187.705] (II) Module ABI versions:
[   187.705]    X.Org ANSI C Emulation: 0.4
[   187.705]    X.Org Video Driver: 11.0
[   187.705]    X.Org XInput driver : 13.0
[   187.705]    X.Org Server Extension : 6.0
[   187.706] (--) PCI: (0:4:1:0) 14f1:8800:107d:6611 rev 5, Mem @ 0xf8000000/16777216
[   187.706] (--) PCI:*(0:5:0:0) 10de:0402:1458:3455 rev 161, Mem @ 0xfd000000/16777216, 0xc0000000/536870912, 0xfa000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/131072
[   187.706] (II) Open ACPI successful (/var/run/acpid.socket)
[   187.706] (II) LoadModule: "extmod"
[   187.707] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   187.707] (II) Module extmod: vendor="X.Org Foundation"
[   187.707]    compiled for 1.11.4, module version = 1.0.0
[   187.707]    Module class: X.Org Server Extension
[   187.707]    ABI class: X.Org Server Extension, version 6.0
[   187.707] (II) Loading extension SELinux
[   187.707] (II) Loading extension MIT-SCREEN-SAVER
[   187.707] (II) Loading extension XFree86-VidModeExtension
[   187.707] (II) Loading extension XFree86-DGA
[   187.707] (II) Loading extension DPMS
[   187.707] (II) Loading extension XVideo
[   187.707] (II) Loading extension XVideo-MotionCompensation
[   187.707] (II) Loading extension X-Resource
[   187.707] (II) LoadModule: "dbe"
[   187.708] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   187.708] (II) Module dbe: vendor="X.Org Foundation"
[   187.708]    compiled for 1.11.4, module version = 1.0.0
[   187.708]    Module class: X.Org Server Extension
[   187.708]    ABI class: X.Org Server Extension, version 6.0
[   187.708] (II) Loading extension DOUBLE-BUFFER
[   187.708] (II) LoadModule: "glx"
[   187.708] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[   187.720] (II) Module glx: vendor="NVIDIA Corporation"
[   187.720]    compiled for 4.0.2, module version = 1.0.0
[   187.720]    Module class: X.Org Server Extension
[   187.720] (II) NVIDIA GLX Module  295.20  Mon Feb  6 21:28:16 PST 2012
[   187.720] (II) Loading extension GLX
[   187.720] (II) LoadModule: "record"
[   187.720] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   187.720] (II) Module record: vendor="X.Org Foundation"
[   187.720]    compiled for 1.11.4, module version = 1.13.0
[   187.720]    Module class: X.Org Server Extension
[   187.720]    ABI class: X.Org Server Extension, version 6.0
[   187.720] (II) Loading extension RECORD
[   187.720] (II) LoadModule: "dri"
[   187.720] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   187.721] (II) Module dri: vendor="X.Org Foundation"
[   187.721]    compiled for 1.11.4, module version = 1.0.0
[   187.721]    ABI class: X.Org Server Extension, version 6.0
[   187.721] (II) Loading extension XFree86-DRI
[   187.721] (II) LoadModule: "dri2"
[   187.721] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   187.721] (II) Module dri2: vendor="X.Org Foundation"
[   187.721]    compiled for 1.11.4, module version = 1.2.0
[   187.721]    ABI class: X.Org Server Extension, version 6.0
[   187.721] (II) Loading extension DRI2
[   187.721] (==) Matched nouveau as autoconfigured driver 0
[   187.721] (==) Matched nv as autoconfigured driver 1
[   187.721] (==) Matched vesa as autoconfigured driver 2
[   187.721] (==) Matched fbdev as autoconfigured driver 3
[   187.721] (==) Assigned the driver to the xf86ConfigLayout
[   187.721] (II) LoadModule: "nouveau"
[   187.721] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[   187.721] (II) Module nouveau: vendor="X.Org Foundation"
[   187.721]    compiled for 1.11.2.901, module version = 0.0.16
[   187.721]    Module class: X.Org Video Driver
[   187.721]    ABI class: X.Org Video Driver, version 11.0
[   187.721] (II) LoadModule: "nv"
[   187.722] (WW) Warning, couldn't open module nv
[   187.722] (II) UnloadModule: "nv"
[   187.722] (II) Unloading nv
[   187.722] (EE) Failed to load module "nv" (module does not exist, 0)
[   187.722] (II) LoadModule: "vesa"
[   187.722] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   187.722] (II) Module vesa: vendor="X.Org Foundation"
[   187.722]    compiled for 1.11.0, module version = 2.3.0
[   187.722]    Module class: X.Org Video Driver
[   187.722]    ABI class: X.Org Video Driver, version 11.0
[   187.722] (II) LoadModule: "fbdev"
[   187.722] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   187.722] (II) Module fbdev: vendor="X.Org Foundation"
[   187.722]    compiled for 1.11.0, module version = 0.4.2
[   187.722]    ABI class: X.Org Video Driver, version 11.0
[   187.722] (II) NOUVEAU driver Date:   Wed Nov 30 18:56:54 2011 +0100
[   187.722] (II) NOUVEAU driver for NVIDIA chipset families :
[   187.722]    RIVA TNT        (NV04)
[   187.722]    RIVA TNT2       (NV05)
[   187.722]    GeForce 256     (NV10)
[   187.722]    GeForce 2       (NV11, NV15)
[   187.722]    GeForce 4MX     (NV17, NV18)
[   187.722]    GeForce 3       (NV20)
[   187.722]    GeForce 4Ti     (NV25, NV28)
[   187.722]    GeForce FX      (NV3x)
[   187.722]    GeForce 6       (NV4x)
[   187.722]    GeForce 7       (G7x)
[   187.722]    GeForce 8       (G8x)
[   187.722]    GeForce GTX 200 (NVA0)
[   187.722]    GeForce GTX 400 (NVC0)
[   187.722] (II) VESA: driver for VESA chipsets: vesa
[   187.722] (II) FBDEV: driver for framebuffer: fbdev
[   187.722] (++) using VT number 7

[   187.730] drmOpenDevice: node name is /dev/dri/card0
[   187.735] drmOpenByBusid: Searching for BusID pci:0000:05:00.0
[   187.736] drmOpenDevice: node name is /dev/dri/card0
[   187.739] drmOpenByBusid: drmOpenMinor returns -1
[   187.739] drmOpenDevice: node name is /dev/dri/card1
[   187.743] drmOpenByBusid: drmOpenMinor returns -1
[   187.743] drmOpenDevice: node name is /dev/dri/card2
[   187.747] drmOpenByBusid: drmOpenMinor returns -1
[   187.747] drmOpenDevice: node name is /dev/dri/card3
[   187.751] drmOpenByBusid: drmOpenMinor returns -1
[   187.751] drmOpenDevice: node name is /dev/dri/card4
[   187.754] drmOpenByBusid: drmOpenMinor returns -1
[   187.754] drmOpenDevice: node name is /dev/dri/card5
[   187.758] drmOpenByBusid: drmOpenMinor returns -1
[   187.758] drmOpenDevice: node name is /dev/dri/card6
[   187.762] drmOpenByBusid: drmOpenMinor returns -1
[   187.762] drmOpenDevice: node name is /dev/dri/card7
[   187.766] drmOpenByBusid: drmOpenMinor returns -1
[   187.766] drmOpenDevice: node name is /dev/dri/card8
[   187.770] drmOpenByBusid: drmOpenMinor returns -1
[   187.770] drmOpenDevice: node name is /dev/dri/card9
[   187.773] drmOpenByBusid: drmOpenMinor returns -1
[   187.773] drmOpenDevice: node name is /dev/dri/card10
[   187.777] drmOpenByBusid: drmOpenMinor returns -1
[   187.777] drmOpenDevice: node name is /dev/dri/card11
[   187.781] drmOpenByBusid: drmOpenMinor returns -1
[   187.781] drmOpenDevice: node name is /dev/dri/card12
[   187.785] drmOpenByBusid: drmOpenMinor returns -1
[   187.785] drmOpenDevice: node name is /dev/dri/card13
[   187.788] drmOpenByBusid: drmOpenMinor returns -1
[   187.789] drmOpenDevice: node name is /dev/dri/card14
[   187.792] drmOpenByBusid: drmOpenMinor returns -1
[   187.792] drmOpenDevice: node name is /dev/dri/card15
[   187.796] drmOpenByBusid: drmOpenMinor returns -1
[   187.796] drmOpenDevice: node name is /dev/dri/card0
[   187.802] drmOpenDevice: node name is /dev/dri/card0
[   187.806] drmOpenDevice: node name is /dev/dri/card1
[   187.810] drmOpenDevice: node name is /dev/dri/card2
[   187.814] drmOpenDevice: node name is /dev/dri/card3
[   187.817] drmOpenDevice: node name is /dev/dri/card4
[   187.821] drmOpenDevice: node name is /dev/dri/card5
[   187.825] drmOpenDevice: node name is /dev/dri/card6
[   187.829] drmOpenDevice: node name is /dev/dri/card7
[   187.832] drmOpenDevice: node name is /dev/dri/card8
[   187.836] drmOpenDevice: node name is /dev/dri/card9
[   187.840] drmOpenDevice: node name is /dev/dri/card10
[   187.844] drmOpenDevice: node name is /dev/dri/card11
[   187.847] drmOpenDevice: node name is /dev/dri/card12
[   187.851] drmOpenDevice: node name is /dev/dri/card13
[   187.855] drmOpenDevice: node name is /dev/dri/card14
[   187.858] drmOpenDevice: node name is /dev/dri/card15
[   187.862] (EE) [drm] failed to open device
[   187.862] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   187.862] vesa: Ignoring device with a bound kernel driver
[   187.862] (WW) Falling back to old probe method for vesa
[   187.862] (II) Loading sub module "fbdevhw"
[   187.862] (II) LoadModule: "fbdevhw"
[   187.863] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   187.863] (II) Module fbdevhw: vendor="X.Org Foundation"
[   187.863]    compiled for 1.11.4, module version = 0.0.2
[   187.863]    ABI class: X.Org Video Driver, version 11.0
[   187.863] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   187.863] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   187.863] (EE) open /dev/fb0: No such file or directory
[   187.863] (WW) Falling back to old probe method for fbdev
[   187.863] (II) UnloadModule: "vesa"
[   187.863] (II) Unloading vesa
[   187.863] (II) UnloadModule: "fbdev"
[   187.863] (II) Unloading fbdev
[   187.863] (II) UnloadModule: "fbdevhw"
[   187.863] (II) Unloading fbdevhw
[   187.863] (EE) Screen(s) found, but none have a usable configuration.
[   187.863]
Fatal server error:
[   187.863] no screens found
[   187.863]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   187.863] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   187.863]
[   187.868] Server terminated with error (1). Closing log file.
sorcerer
Level 1
Level 1
 
Posts: 38
Joined: Sun May 27, 2012 1:06 pm

Linux Mint is funded by ads and donations.
 

Re: x-windows not starting on console

Postby DrHu on Tue Aug 21, 2012 6:03 pm

You might still have the original /etc/X11/xorg.conf file which was setup via nvidia driver install, maybe it didn't get updated by the system (kernel if any) updates
--you could try and find it or locate a sample file (Internet search nvidia xorg.conf, it is only the display entry that is required to get a display ) and that should be display 0:

The only other issue I could see is are you using an all 64bit driver file (I think nvidia has some) or did you use the standard 32bit driver; which would also work within the 64bit OS with little or no problems..

You have the nouveau driver running
Code: Select all
[   187.721] (II) Module nouveau: vendor="X.Org Foundation"
[   187.721]    compiled for 1.11.2.901, module version = 0.0.16
[   187.721]    Module class: X.Org Video Driver
[   187.721]    ABI class: X.Org Video Driver, version 11.0
[   187.721] (II) LoadModule: "nv"
[   187.722] (WW) Warning, couldn't open module nv
[   187.722] (II) UnloadModule: "nv"
[   187.722] (II) Unloading nv
[   187.722] (EE) Failed to load module "nv" (module does not exist, 0)
[   187.722] (II) LoadModule: "vesa"

--you could either reinstall the nvidia driver or use the sopurce files and build it against the running kernel
In a terminal
    Sudo init 1
    --gets you to single user mode
    sudo mdm stop
    --or whichever GUI windows manger you have running
    sudo ./Nvidia*.run
    --after you have downloaded the appropriate source file
These steps should be able to get an nvidia source file compiled and running

Reboot, but you may also want to remove the nouveau driver, you can always reinstall if you get a problem on reboot
User avatar
DrHu
Level 17
Level 17
 
Posts: 7034
Joined: Wed Jun 17, 2009 8:20 pm

Re: x-windows not starting on console

Postby sorcerer on Wed Aug 22, 2012 5:02 am

thank you for your answer, but two problems
even that i do, want and need nvidia drivers, i didn't install them and then it didn't work

i installed nvidia drivers be cause x-windows didn't work in the first place

also, i install them via xserver-xorg-video-nvidia, (apt-get install ... ) not manually, so cannot find any Nvidia*.run (the command locate Nvidia don't get any results)

so, now, i did removed nouveau xserver (if you say that's the problem) and reinstalled nvidia, and got some warnings:
Code: Select all
apt-get install xserver-xorg-video-nvidia             
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  nvidia-settings
The following NEW packages will be installed:
  xserver-xorg-video-nvidia
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/4478 kB of archives.
After this operation, 16.5 MB of additional disk space will be used.
Selecting previously unselected package xserver-xorg-video-nvidia.
(Reading database ... 169447 files and directories currently installed.)
Unpacking xserver-xorg-video-nvidia (from .../xserver-xorg-video-nvidia_295.20-1_amd64.deb) ...
Processing triggers for nvidia-alternative ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/nvidia/current because link group nvidia is broken.
Processing triggers for glx-alternative-nvidia ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/nvidia because link group glx is broken.
Setting up xserver-xorg-video-nvidia (295.20-1) ...


x-windows still not working:
Code: Select all
[   421.386]
X.Org X Server 1.11.4
Release Date: 2012-01-27
[   421.387] X Protocol Version 11, Revision 0
[   421.387] Build Operating System: Linux 3.2.0-1-amd64 x86_64 Debian
[   421.387] Current Operating System: Linux coruscant 3.2.0-2-amd64 #1 SMP Sun Mar 4 22:48:17 UTC 2012 x86_64
[   421.387] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-2-amd64 root=UUID=84d9b912-305b-4a99-8b73-7d6e80320665 ro quiet
[   421.387] Build Date: 04 March 2012  11:42:13PM
[   421.387] xorg-server 2:1.11.4-1 (Cyril Brulebois <kibi@debian.org>)
[   421.387] Current version of pixman: 0.24.4
[   421.387]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   421.387] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   421.387] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Aug 22 12:01:32 2012
[   421.387] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   421.387] (==) No Layout section.  Using the first Screen section.
[   421.387] (==) No screen section available. Using defaults.
[   421.387] (**) |-->Screen "Default Screen Section" (0)
[   421.387] (**) |   |-->Monitor "<default monitor>"
[   421.388] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[   421.388] (==) Automatically adding devices
[   421.388] (==) Automatically enabling devices
[   421.388] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   421.388]    Entry deleted from font path.
[   421.388] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   421.388]    Entry deleted from font path.
[   421.388] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   421.388]    Entry deleted from font path.
[   421.388] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   421.388]    Entry deleted from font path.
[   421.388] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   421.388]    Entry deleted from font path.
[   421.388] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins
[   421.388] (==) ModulePath set to "/usr/lib/xorg/modules"
[   421.388] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[   421.388] (II) Loader magic: 0x7fcf70331ae0
[   421.388] (II) Module ABI versions:
[   421.388]    X.Org ANSI C Emulation: 0.4
[   421.388]    X.Org Video Driver: 11.0
[   421.388]    X.Org XInput driver : 13.0
[   421.388]    X.Org Server Extension : 6.0
[   421.389] (--) PCI: (0:4:1:0) 14f1:8800:107d:6611 rev 5, Mem @ 0xf8000000/16777216
[   421.389] (--) PCI:*(0:5:0:0) 10de:0402:1458:3455 rev 161, Mem @ 0xfd000000/16777216, 0xc0000000/536870912, 0xfa000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/131072
[   421.389] (II) Open ACPI successful (/var/run/acpid.socket)
[   421.389] (II) LoadModule: "extmod"
[   421.390] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   421.390] (II) Module extmod: vendor="X.Org Foundation"
[   421.390]    compiled for 1.11.4, module version = 1.0.0
[   421.390]    Module class: X.Org Server Extension
[   421.390]    ABI class: X.Org Server Extension, version 6.0
[   421.390] (II) Loading extension SELinux
[   421.390] (II) Loading extension MIT-SCREEN-SAVER
[   421.390] (II) Loading extension XFree86-VidModeExtension
[   421.390] (II) Loading extension XFree86-DGA
[   421.390] (II) Loading extension DPMS
[   421.390] (II) Loading extension XVideo
[   421.390] (II) Loading extension XVideo-MotionCompensation
[   421.390] (II) Loading extension X-Resource
[   421.390] (II) LoadModule: "dbe"
[   421.390] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   421.391] (II) Module dbe: vendor="X.Org Foundation"
[   421.391]    compiled for 1.11.4, module version = 1.0.0
[   421.391]    Module class: X.Org Server Extension
[   421.391]    ABI class: X.Org Server Extension, version 6.0
[   421.391] (II) Loading extension DOUBLE-BUFFER
[   421.391] (II) LoadModule: "glx"
[   421.391] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[   421.404] (II) Module glx: vendor="NVIDIA Corporation"
[   421.404]    compiled for 4.0.2, module version = 1.0.0
[   421.404]    Module class: X.Org Server Extension
[   421.404] (II) NVIDIA GLX Module  295.20  Mon Feb  6 21:28:16 PST 2012
[   421.404] (II) Loading extension GLX
[   421.404] (II) LoadModule: "record"
[   421.404] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   421.404] (II) Module record: vendor="X.Org Foundation"
[   421.405]    compiled for 1.11.4, module version = 1.13.0
[   421.405]    Module class: X.Org Server Extension
[   421.405]    ABI class: X.Org Server Extension, version 6.0
[   421.405] (II) Loading extension RECORD
[   421.405] (II) LoadModule: "dri"
[   421.405] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   421.405] (II) Module dri: vendor="X.Org Foundation"
[   421.405]    compiled for 1.11.4, module version = 1.0.0
[   421.405]    ABI class: X.Org Server Extension, version 6.0
[   421.405] (II) Loading extension XFree86-DRI
[   421.405] (II) LoadModule: "dri2"
[   421.405] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   421.405] (II) Module dri2: vendor="X.Org Foundation"
[   421.405]    compiled for 1.11.4, module version = 1.2.0
[   421.405]    ABI class: X.Org Server Extension, version 6.0
[   421.405] (II) Loading extension DRI2
[   421.405] (==) Matched nouveau as autoconfigured driver 0
[   421.405] (==) Matched nv as autoconfigured driver 1
[   421.405] (==) Matched vesa as autoconfigured driver 2
[   421.405] (==) Matched fbdev as autoconfigured driver 3
[   421.405] (==) Assigned the driver to the xf86ConfigLayout
[   421.405] (II) LoadModule: "nouveau"
[   421.405] (WW) Warning, couldn't open module nouveau
[   421.405] (II) UnloadModule: "nouveau"
[   421.406] (II) Unloading nouveau
[   421.406] (EE) Failed to load module "nouveau" (module does not exist, 0)
[   421.406] (II) LoadModule: "nv"
[   421.406] (WW) Warning, couldn't open module nv
[   421.406] (II) UnloadModule: "nv"
[   421.406] (II) Unloading nv
[   421.406] (EE) Failed to load module "nv" (module does not exist, 0)
[   421.406] (II) LoadModule: "vesa"
[   421.406] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   421.406] (II) Module vesa: vendor="X.Org Foundation"
[   421.406]    compiled for 1.11.0, module version = 2.3.0
[   421.406]    Module class: X.Org Video Driver
[   421.406]    ABI class: X.Org Video Driver, version 11.0
[   421.406] (II) LoadModule: "fbdev"
[   421.406] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   421.406] (II) Module fbdev: vendor="X.Org Foundation"
[   421.406]    compiled for 1.11.0, module version = 0.4.2
[   421.406]    ABI class: X.Org Video Driver, version 11.0
[   421.406] (II) VESA: driver for VESA chipsets: vesa
[   421.406] (II) FBDEV: driver for framebuffer: fbdev
[   421.406] (--) using VT number 7

[   421.413] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   421.413] vesa: Ignoring device with a bound kernel driver
[   421.413] (WW) Falling back to old probe method for vesa
[   421.413] (II) Loading sub module "fbdevhw"
[   421.413] (II) LoadModule: "fbdevhw"
[   421.414] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   421.414] (II) Module fbdevhw: vendor="X.Org Foundation"
[   421.414]    compiled for 1.11.4, module version = 0.0.2
[   421.414]    ABI class: X.Org Video Driver, version 11.0
[   421.414] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   421.414] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   421.414] (EE) open /dev/fb0: No such file or directory
[   421.414] (WW) Falling back to old probe method for fbdev
[   421.414] (II) UnloadModule: "vesa"
[   421.414] (II) Unloading vesa
[   421.414] (II) UnloadModule: "fbdev"
[   421.414] (II) Unloading fbdev
[   421.414] (II) UnloadModule: "fbdevhw"
[   421.414] (II) Unloading fbdevhw
[   421.414] (EE) Screen(s) found, but none have a usable configuration.
[   421.414]
Fatal server error:
[   421.414] no screens found
[   421.414]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   421.414] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   421.414]
[   421.418] Server terminated with error (1). Closing log file.


also, i didn't do this from a very long time (debugging x-windows on console) but isn't there supposed to be a text mode configure tool for X system ?
where i can specify what driver/server to use (there may be several in same system: fb, vesa, own card driver, etc.)
sorcerer
Level 1
Level 1
 
Posts: 38
Joined: Sun May 27, 2012 1:06 pm


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 2 guests