No Windows XP in Grub

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

No Windows XP in Grub

Postby flomint on Wed Jul 31, 2013 7:11 am

Hello,
I just installed the last version of LMDE on a laptop, with Windows XP.
But in grub I have no Windows XP choice after installation....
I can see the partion witn XP when I log in LMDE.
I 've searched for a partition tool or grub edition tool il LMDE, without success...
How can I set GRUB to have Win XP choice?

thanks a lot
flomint
Level 1
Level 1
 
Posts: 14
Joined: Sat Jun 15, 2013 3:16 pm

Linux Mint is funded by ads and donations.
 

Re: No Windows XP in Grub

Postby wayne128 on Wed Jul 31, 2013 7:25 am

I hope you or the installer did not wipe XP boot file..

You can check with these steps
1. boot from LMDE DVD and run live.
2. on terminal, type a few commands and post results, this is to check hard disk partition and where are LMDE and WinXP installation


sudo os-prober

sudo fdisk -l

sudo parted -l
wayne128
Level 10
Level 10
 
Posts: 3242
Joined: Tue Jul 13, 2010 12:15 am

Re: No Windows XP in Grub

Postby flomint on Wed Jul 31, 2013 7:38 am

sudo os-prober:
Code: Select all
/dev/sda1:Microsoft Windows XP Professionel:Windows:chain
/dev/sda5:LMDE Cinnamon Edition (1):LinuxMint:linux


sudo fdisk-l
Code: Select all
Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders, total 117210240 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x40000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63    42138494    21069216    7  HPFS/NTFS/exFAT
/dev/sda2        42138495   117194174    37527840    f  W95 Ext'd (LBA)
/dev/sda5        42141696   117192703    37525504   83  Linux

Disk /dev/sdb: 15.7 GB, 15724707840 bytes
74 heads, 10 sectors/track, 41503 cylinders, total 30712320 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        8064    30712319    15352128    c  W95 FAT32 (LBA)


sudo parted -l
Code: Select all
sudo: parted: command not found


parted
Code: Select all
The program ^parted' is currently not installed. To run 'parted' please ask your administrator to install the package 'parted'


I have no internet connection on this laptop, so how can I install the package parted?

many thanks for your help
flomint
Level 1
Level 1
 
Posts: 14
Joined: Sat Jun 15, 2013 3:16 pm

Re: No Windows XP in Grub

Postby wayne128 on Wed Jul 31, 2013 7:42 am

sorry without internet you cannot install parted.

try these to get WinXP into grub,

1. boot with LMDE DVD and run live
2. on terminal, do these commands

sudo mount /dev/sda5 /mnt

sudo grub-install --root-directory=/mnt /dev/sda

and hopefully it reports no error

3. reboot, see if WinXP appear in grub menu, select it and check if it boots
wayne128
Level 10
Level 10
 
Posts: 3242
Joined: Tue Jul 13, 2010 12:15 am

Re: No Windows XP in Grub

Postby flomint on Wed Jul 31, 2013 7:49 am

sudo mount /dev/sda5 /mnt
OK

sudo grub-install --root-directory=/mnt /dev/sda
Code: Select all
/usr/sbin/grub-setup: warn: Sector 32 is already in use by FlexNet; avoiding it.  This software may cause boot or other problems in future.  Please ask its authors not to store data in the boot track.
Installation finished. No error reported.


I reboot and have no Windows XP in the choice list... :( :(

what happens?
flomint
Level 1
Level 1
 
Posts: 14
Joined: Sat Jun 15, 2013 3:16 pm

Re: No Windows XP in Grub

Postby wayne128 on Wed Jul 31, 2013 7:57 am

flomint wrote:
Code: Select all
/usr/sbin/grub-setup: warn: Sector 32 is already in use by FlexNet; avoiding it.  This software may cause boot or other problems in future.  Please ask its authors not to store data in the boot track.
Installation finished. No error reported.


I reboot and have no Windows XP in the choice list... :( :(

what happens?



You hit the old bug.. sector 32, FlexNet... just too bad.

You can try this method: Boot Repair.
https://help.ubuntu.com/community/Boot-Repair


or other like this
http://computers-linux-other-nonsense.b ... or-32.html
wayne128
Level 10
Level 10
 
Posts: 3242
Joined: Tue Jul 13, 2010 12:15 am

Re: No Windows XP in Grub

Postby flomint on Wed Jul 31, 2013 8:16 am

maaaaaany thanks!

Now it works, I can See and log in XP!

I'va 2 more questions:
1) how can I set Win XP as default OS?
2) I want to install LMDE on a other laptop, dual boot with Win7, Is there the same problem with flexnet??
flomint
Level 1
Level 1
 
Posts: 14
Joined: Sat Jun 15, 2013 3:16 pm

Re: No Windows XP in Grub

Postby wayne128 on Wed Jul 31, 2013 8:32 am

flomint wrote:I'va 2 more questions:
1) how can I set Win XP as default OS?
2) I want to install LMDE on a other laptop, dual boot with Win7, Is there the same problem with flexnet??



1)

a. look at your grub menu, first line is the default that you boot LMDE
count the number of line that is WinXP, remember that number

b. run LMDE, open a teminal, do these command:

sudo nano /etc/default/grub

you should see these in the terminal like mine, not the same but similar

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""


the red highlight is the line you need to amend.

remember just now you count the WinXP line, first LMDE line is '0', second LMDE recover line is '1' and so on, let says your WinXP line is '4' which is '5th line',
then you move cursor to that line, change the 0 to 4 so it reads

GRUB_DEFAULT=4

now, hit <ctrl><x>, follow by hitting <y>, follow by <enter>

you have saved the new file onto the same /etc/default/grub
and you are back to the terminal

Next thing to do, is , on terminal, do this command

sudo update-grub

check that no error.

reboot, you will find that the same grun menu appear, but the 'highlight' go to the WinXP line and either you hit <enter> or wait until the timer run out and it will boot WinXP.


2) when you install LMDE on another computer, the bug might not happen.
For me, I installed many times, never had that Sector 32.
wayne128
Level 10
Level 10
 
Posts: 3242
Joined: Tue Jul 13, 2010 12:15 am

Re: No Windows XP in Grub

Postby flomint on Wed Jul 31, 2013 9:18 am

I do all your instructions, without error, but when I reboot, LMDE is always the default choice! (position 0, XP is in position 3)
When I re-open the config file, default is at position 3...
:?: :?: :?:
flomint
Level 1
Level 1
 
Posts: 14
Joined: Sat Jun 15, 2013 3:16 pm

Re: No Windows XP in Grub

Postby wayne128 on Wed Jul 31, 2013 9:24 am

hmm...not sure what happen.


run LMDE, open a terminal, do these commands and post results


cat /etc/default/grub

cat /boot/grub/grub.cfg
wayne128
Level 10
Level 10
 
Posts: 3242
Joined: Tue Jul 13, 2010 12:15 am

Re: No Windows XP in Grub

Postby flomint on Wed Jul 31, 2013 9:25 am

no I leave the laptop, I wll try these commandes next monday.

many thanks!
flomint
Level 1
Level 1
 
Posts: 14
Joined: Sat Jun 15, 2013 3:16 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 4 guests