[Solved] Installation hangs/freezes

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

[Solved] Installation hangs/freezes

Postby Fesiitis on Sat Sep 07, 2013 5:56 am

Hi,

I'm trying to install LMDE 201303 MATE 64bit to HP Envy DV6-7300sa laptop. Live session starts fine, installation starts fine. But after some time when on installation runs files copying it's just hangs. I can't move mouse or do anything.
I was trying to disable screensaver, i was trying remove live-installer-slideshow, I was trying to install LMDE from USB, but it always hangs.
There's my laptop specs - http://h20000.www2.hp.com/bizsupport/Te ... eId=321957

Thanks!
Last edited by Fesiitis on Tue Sep 10, 2013 1:55 pm, edited 1 time in total.
Fesiitis
Level 2
Level 2
 
Posts: 53
Joined: Sun Feb 19, 2012 8:02 am

Linux Mint is funded by ads and donations.
 

Re: Installation hangs/freezes

Postby simonbromilow on Sun Sep 08, 2013 6:11 pm

As i guessed you have nvidia graphics, nvidia drivers are proprietry so are not included in linux mint install. Proprietry means they are not free to distribute etc.

However a quick fix is to boot from the disc and when you get the 10 second automatic boot press any key to stop it eg, down arrow or something. There will be a list of options but just press the tab key and it will let you edit the boot kernel.

look for "quiet splash _ _" near the end of the command and change this to "quiet splash nomodeset _ _" Make sure there is a space before and after no mode set otherwise it will not work

This will prevent any config of your graphics and stops your system freezing. After installing you need to do the same before rebooting but without the disc of course.

Hold the shift key before it starts to boot and press either tab or letter e to edit the command line again can't remember which but it tells you what key it is for editing.

Afterwards locate quiet splash again and add nomode set after it but remember to check there is a space before and after the command like this: quiet splash" nomodeset " (without the quote marks they just indicate the spaces before and after)
Press F10 to continue booting
When you get into linux mint and logged in we need to fix the graphics issue so go to driver manager and wait for it to check for proprietry drivers. Click the recommended nvidia driver that is displayed and apply it, then wait for it to download and install.

After install restart immediately

Here it is in a short version:

Boot disc and press any key to stop automatic boot
Press tab to edit the boot kernel
locate: quiet splash and add nomodeset like this "quiet splash nomodeset _ _" notice the 2 hyphens there is a space before them between t and _

Press enter to continue booting
Install linux mint
Restart and hold shift key
In boot menu that appears press tab or letter e but check this because it says which to press for editing
locate "quiet splash"
add nomodeset like this: "quiet splash nomodeset " Remember there is 1 space before and after nomodeset
Press F10 to boot
Login to your user account and open driver manager located in preferences tab in the mint menu
Install the recommended nvidia driver and reboot
Use the system as normal from then on :mrgreen: :mrgreen: :mrgreen:
simonbromilow
Level 1
Level 1
 
Posts: 7
Joined: Sun Sep 08, 2013 5:37 pm

Re: [Solved] Installation hangs/freezes

Postby Fesiitis on Tue Sep 10, 2013 1:58 pm

Thanks! That's works. I boot LMDE disc with "quiet splash nomodset _ _" and installation complete without any problems. :)

But funiest is that I boot my new system without "nomodset" and all anyway works without problems, nVidia driver is not installed yet. :D
Fesiitis
Level 2
Level 2
 
Posts: 53
Joined: Sun Feb 19, 2012 8:02 am

Re: [Solved] Installation hangs/freezes

Postby simonbromilow on Tue Sep 10, 2013 2:20 pm

That's good news, its best to get that driver though as it may crash when opening some software like Firefox. In driver manager choose recommended driver if you decide to install. Firefox crashed my pc without driver. Good luck anyway with your installed system :shock: :twisted: without the driver it might crash when a lot of graphics memory is required :mrgreen:
simonbromilow
Level 1
Level 1
 
Posts: 7
Joined: Sun Sep 08, 2013 5:37 pm

Re: [Solved] Installation hangs/freezes

Postby Fesiitis on Mon Sep 16, 2013 3:06 am

I found another option - if "nomodeset" is not worked, try add "acpi=off" option before boot. This disable some hardware like wi-fi, bluetooth. This can avoid installation from freezing.
Fesiitis
Level 2
Level 2
 
Posts: 53
Joined: Sun Feb 19, 2012 8:02 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 1 guest