Grub: LMDE should be the first entry, but not at boot

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

Grub: LMDE should be the first entry, but not at boot

Postby palimmo on Sun Nov 24, 2013 1:32 pm

Well... that's really weird..
I have a triple boot system (LMDE, Ubuntu, Win 7).
After some updates (including kernel) in Ubuntu, back in LMDE I got this situation:
Code: Select all
~ $ cat /boot/grub/grub.cfg | grep menuentry
menuentry 'LinuxMint GNU/Linux, with Linux 3.10-2-amd64' --class linuxmint --class gnu-linux --class gnu --class os {
menuentry 'LinuxMint GNU/Linux, with Linux 3.10-2-amd64 (recovery mode)' --class linuxmint --class gnu-linux --class gnu --class os {
menuentry "Memory test (memtest86+)" {
menuentry "Memory test (memtest86+, serial console 115200)" {
menuentry "Memory test (memtest86+, experimental multiboot)" {
menuentry "Memory test (memtest86+, serial console 115200, experimental multiboot)" {
menuentry "Windows Recovery Environment (loader) (on /dev/sda1)" --class windows --class os {
menuentry "Windows 7 (loader) (on /dev/sda2)" --class windows --class os {
menuentry "Windows 7 (loader) (on /dev/sda3)" --class windows --class os {
menuentry "Ubuntu, with Linux 3.2.0-57-generic (on /dev/sda5)" --class gnu-linux --class gnu --class os {
menuentry "Ubuntu, with Linux 3.2.0-57-generic (recovery mode) (on /dev/sda5)" --class gnu-linux --class gnu --class os {

and /etc/default/grub
Code: Select all
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=3
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=" vga=792 splash quiet"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=1024x768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


But when I restart my laptop, Ubuntu appears as the first voice... why?
Even in StartUp-Manager LMDE is set as my default OS!
What's happening?
... I would like to have LMDE as my first option that will run automatically after 3 seconds..

Any suggestion?
thanks!
LMDE 64bit Cinnamon & SolydK 64bit
User avatar
palimmo
Level 3
Level 3
 
Posts: 193
Joined: Sun Feb 03, 2013 9:55 am

Linux Mint is funded by ads and donations.
 

Re: Grub: LMDE should be the first entry, but not at boot

Postby palimmo on Sun Nov 24, 2013 3:00 pm

I solved reinstalling grub in LMDE.
But how can I remove these 3 entries from my grub list?

menuentry 'LinuxMint GNU/Linux, with Linux 3.10-2-amd64' --class linuxmint --class gnu-linux --class gnu --class os {
menuentry 'LinuxMint GNU/Linux, with Linux 3.10-2-amd64 (recovery mode)' --class linuxmint --class gnu-linux --class gnu --class os {
menuentry "Memory test (memtest86+)" {
menuentry "Memory test (memtest86+, serial console 115200)" {
menuentry "Memory test (memtest86+, experimental multiboot)" {
menuentry "Memory test (memtest86+, serial console 115200, experimental multiboot)" {

menuentry "Windows Recovery Environment (loader) (on /dev/sda1)" --class windows --class os {
menuentry "Windows 7 (loader) (on /dev/sda2)" --class windows --class os {
menuentry "Windows 7 (loader) (on /dev/sda3)" --class windows --class os {
menuentry "Ubuntu, with Linux 3.2.0-57-generic (on /dev/sda5)" --class gnu-linux --class gnu --class os {
menuentry "Ubuntu, with Linux 3.2.0-57-generic (recovery mode) (on /dev/sda5)" --class gnu-linux --class gnu --class os {

and why the hell are they there?? I have never seen them before...
thanks!
LMDE 64bit Cinnamon & SolydK 64bit
User avatar
palimmo
Level 3
Level 3
 
Posts: 193
Joined: Sun Feb 03, 2013 9:55 am

Re: Grub: LMDE should be the first entry, but not at boot

Postby GeneBenson on Sun Nov 24, 2013 7:10 pm

Hi palimmo,

You can remove them by uninstalling memtest86+. How did you get them? Perhaps you installed something that "recommends" memtest86+.

Hope this helps. :wink:
GeneBenson
Level 3
Level 3
 
Posts: 181
Joined: Fri Sep 17, 2010 9:55 pm

Re: Grub: LMDE should be the first entry, but not at boot

Postby palimmo on Tue Nov 26, 2013 4:52 pm

GeneBenson wrote:Hi palimmo,

You can remove them by uninstalling memtest86+. How did you get them? Perhaps you installed something that "recommends" memtest86+.

Hope this helps. :wink:

will this remove just that 3 packages in red or even the useful one?
LMDE 64bit Cinnamon & SolydK 64bit
User avatar
palimmo
Level 3
Level 3
 
Posts: 193
Joined: Sun Feb 03, 2013 9:55 am

Re: Grub: LMDE should be the first entry, but not at boot

Postby GeneBenson on Tue Nov 26, 2013 6:19 pm

Hi palimmo,

will this remove just that 3 packages in red or even the useful one?

It will remove all 4 memtest86+ entries.
It's been awhile since I installed LMDE, but if I'm not mistaken when you boot the Live CD it also has a "Test Memory " option if you really need that.
GeneBenson
Level 3
Level 3
 
Posts: 181
Joined: Fri Sep 17, 2010 9:55 pm

Re: Grub: LMDE should be the first entry, but not at boot

Postby austin.texas on Wed Nov 27, 2013 12:26 am

Daniel Richter's Grub Customizer will allow you to eliminate any entries, change the boot order, and set the delay time.
https://launchpad.net/~danielrichter2007/+archive/grub-customizer
Mint 17 v2 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 11
Level 11
 
Posts: 3607
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 2 guests