LMDE installer can't find dm-crypt / LUKS partitions ?

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read how to get help

Re: LMDE installer can't find dm-crypt / LUKS partitions ?

Postby Epipsychidion on Thu Dec 02, 2010 8:08 am

Hi Nevchen,

Yeah, I had the same problem when installing LMDE too. I'd love to have a LVM based, fully encrypted system, but alas it wasn't to be. I tried for ages, using how-to's made for Mint Standard (Gnome), but alas I was stumped when it was time to install to my encrypted drive. Here's hoping the new installer will fix this, as then LMDE would be pure heaven for me

--EDIT--
Sorry, I forgot to say welcome to the forums!
Lenovo X200s L9400 - 80GB Intel x25-m SSD - LMDE
Epipsychidion
Level 1
Level 1
 
Posts: 10
Joined: Sun Nov 28, 2010 2:24 am
Location: Corryong, Victoria - Australia

Linux Mint is funded by ads and donations.
 

Re: LMDE installer can't find dm-crypt / LUKS partitions ?

Postby dfx on Tue Dec 07, 2010 3:47 pm

You can try one of the two ways mentioned here
dfx
Level 1
Level 1
 
Posts: 34
Joined: Sun Nov 14, 2010 12:35 pm

Re: LMDE installer can't find dm-crypt / LUKS partitions ?

Postby macias on Sat Jan 01, 2011 8:22 am

It looks like to many hoops for such a standard procedure as encrypted install.

Anyway, I was bitten by this too -- I encrypted partitions just to realize LMDE installer checks only physical partitions. Pity :-(
macias
Level 1
Level 1
 
Posts: 30
Joined: Tue Dec 21, 2010 12:06 pm

Re: LMDE installer can't find dm-crypt / LUKS partitions ?

Postby gorillaki on Mon Jan 03, 2011 7:27 pm

I have LMDE on my laptop with full dm-crypt (root/swap/home).
I had to use the squeeze beta2 netinstall CD, do the Debian Testing basic installation from there, and then add the lmde and debian-multimedia repositories.
Adding the mint packages was not smooth, because for some reason a needed package (gstreamer010-pitfdll) is not available in /testing, and I had to retrieve it from Sid. I also had some issues with nouveau (KMS freezing at gdm3 prompt), I solved it by disabling KMS and installing the nvidia blob drivers.
gorillaki
Level 1
Level 1
 
Posts: 8
Joined: Mon Jul 12, 2010 10:38 am

Re: LMDE installer can't find dm-crypt / LUKS partitions ?

Postby CyL on Thu Jan 06, 2011 12:50 pm

Just in case you're still interested, I've made a guide on how to install LMDE with whole disk encryption. It is available at viewtopic.php?f=42&t=63376&p=364620#p364620

Hope that helps!
CyL
Level 1
Level 1
 
Posts: 5
Joined: Wed Jan 05, 2011 1:03 pm

Re: LMDE installer can't find dm-crypt / LUKS partitions ?

Postby macias on Thu Jan 06, 2011 2:03 pm

Very impressive. Thank you very much for the sharing! Thanks to you, I will read more about LVM, maybe it is time to move to that solution as well.
macias
Level 1
Level 1
 
Posts: 30
Joined: Tue Dec 21, 2010 12:06 pm

Re: LMDE installer can't find dm-crypt / LUKS partitions ?

Postby macias on Wed Jan 26, 2011 2:44 pm

Just for the record -- I tried the second way, which should be simpler, i.e. installing Debian and then converting it to LMDE.

Debian with encryption and LVM:
http://forums.debian.net/viewtopic.php?f=10&t=46874
Conversion:
http://www.khattam.info/howto-change-de ... 11-27.html

Either I am really stupid or this does not work.
a) after setting encrypted partition and on top of this, LVM initially Debian while booting tries to set up LVM, instead of dmcrypt (but from installation the dependency should be known), I don't know how this affect the rest of the process of starting the system

b) despite 3 hours installation, and enabling Desktop environment, none of WM/DM starts by default, and startx is not available

c) since system is working, I tried the conversion -- when I executed first command, update of the system, apt-get stopped working with error stating there is no signature for LinuxMint repo

So, for now I am stuck...
macias
Level 1
Level 1
 
Posts: 30
Joined: Tue Dec 21, 2010 12:06 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 2 guests