How to install Plymouth [SOLVED]

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

How to install Plymouth [SOLVED]

Postby luis.nando on Sun Mar 27, 2011 7:21 pm

Hello community,


I managed to get my LMDE pretty ready for my production purposes, it is stable, functional and beautiful. The problem is I couldn`t find a way to make Plymouth work. I installed it using the repos, than i followed instructions to set the default theme. But nothing worked. Funny is that, some months ago I was using a Mint Debian 64bits using the Vincent tutorial on the community website and back then I managed to get plymouth working... But for this original installation of LMDE i couldn`t.

Some ideas?
Last edited by luis.nando on Sat Apr 02, 2011 4:03 pm, edited 1 time in total.
ASUS UL30a2 LMDE 64bit
User avatar
luis.nando
Level 1
Level 1
 
Posts: 48
Joined: Tue Feb 22, 2011 6:09 pm
Location: Brazil

Linux Mint is funded by ads and donations.
 

Re: How to install Plymouth

Postby vincent on Sun Mar 27, 2011 9:07 pm

Just to double check: you've already installed the "plymouth-themes-all" package, right?
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: How to install Plymouth

Postby luis.nando on Mon Mar 28, 2011 8:35 am

Hello Vincent,

after I mintyfied my debian, following your tutorial. I decided to give a try on the normal release. I followed the same steps of your tutorial, but no success!!! Yeap, i've already installed the "plymouth-themes-all".
ASUS UL30a2 LMDE 64bit
User avatar
luis.nando
Level 1
Level 1
 
Posts: 48
Joined: Tue Feb 22, 2011 6:09 pm
Location: Brazil

Re: How to install Plymouth

Postby vincent on Mon Mar 28, 2011 8:39 pm

Code: Select all
cat /etc/default/grub
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: How to install Plymouth

Postby luis.nando on Wed Mar 30, 2011 7:38 am

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="rootflags=commit=100"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
ASUS UL30a2 LMDE 64bit
User avatar
luis.nando
Level 1
Level 1
 
Posts: 48
Joined: Tue Feb 22, 2011 6:09 pm
Location: Brazil

Re: How to install Plymouth

Postby vincent on Wed Mar 30, 2011 4:24 pm

luis.nando wrote:GRUB_CMDLINE_LINUX_DEFAULT="quiet"


Should be something like this:

Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"


Don't forget to run the following command afterwards:
Code: Select all
sudo update-grub
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: How to install Plymouth

Postby luis.nando on Fri Apr 01, 2011 8:50 pm

Still Nothing...
ASUS UL30a2 LMDE 64bit
User avatar
luis.nando
Level 1
Level 1
 
Posts: 48
Joined: Tue Feb 22, 2011 6:09 pm
Location: Brazil

Re: How to install Plymouth

Postby vincent on Sat Apr 02, 2011 3:53 am

Well...I'm out of ideas at the moment. Strange...any LMDE users with Plymouth installed want to chime in?
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: How to install Plymouth [SOLVED]

Postby luis.nando on Sat Apr 02, 2011 4:04 pm

After I reinstalled the package plymouth started working... thanks.
ASUS UL30a2 LMDE 64bit
User avatar
luis.nando
Level 1
Level 1
 
Posts: 48
Joined: Tue Feb 22, 2011 6:09 pm
Location: Brazil

Re: How to install Plymouth [SOLVED]

Postby vincent on Sat Apr 02, 2011 6:31 pm

Even more strange...oh well, if it's working now, I guess everything's fine. :P
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 7 guests