(solved)grub page unreadable

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

(solved)grub page unreadable

Postby nalsdixit on Sat Apr 16, 2011 3:40 am

i recently rebooted after an update, and found the grub page to be unreadable (a distorted color page). the computer still booted into lmde as that is first choice on the page. how do i get back to a normal grub page/background. i did run 'apt-get update-grub', but that did not fix it

i am using an acer aspire one netbook, with upto date lmde

tks

nals
Last edited by nalsdixit on Fri Apr 22, 2011 10:12 am, edited 1 time in total.
nalsdixit
Level 3
Level 3
 
Posts: 100
Joined: Mon Sep 14, 2009 11:38 am

Linux Mint is funded by ads and donations.
 

Re: grub page unreadable

Postby xircon on Sat Apr 16, 2011 4:44 am

Try sudo update-grub (without the apt-get).
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: grub page unreadable

Postby nalsdixit on Sat Apr 16, 2011 6:21 am

tks xircon, tried that, unfort same result, no change.


nals@nals ~ $ sudo update-grub
[sudo] password for nals:
Generating grub.cfg ...
Found background image: linuxmint.png
Found Debian background: linuxmint.png
Found linux image: /boot/vmlinuz-2.6.38-2-686
Found initrd image: /boot/initrd.img-2.6.38-2-686
Found linux image: /boot/vmlinuz-2.6.32-5-686
Found initrd image: /boot/initrd.img-2.6.32-5-686
Found Windows Recovery Environment (loader) on /dev/sda1
Found Microsoft Windows XP Home Edition on /dev/sda2
done

----
nals
nalsdixit
Level 3
Level 3
 
Posts: 100
Joined: Mon Sep 14, 2009 11:38 am

Re: grub page unreadable

Postby xircon on Sat Apr 16, 2011 6:35 am

Have you installed a splash screen or Plymouth?

What is the output of
Code: Select all
cat /etc/default/grub


Mine says:
Code: Select all
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset radeon.modeset=0"
GRUB_CMDLINE_LINUX="vga=792"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: grub page unreadable

Postby nalsdixit on Sat Apr 16, 2011 6:48 am

i have not done anything other than the standard install, and updates. was working fine, until recent updates/kernal upgrade.

here is output of what you asked me to run

nals@nals ~ $ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
nals@nals ~ $
nalsdixit
Level 3
Level 3
 
Posts: 100
Joined: Mon Sep 14, 2009 11:38 am

Re: grub page unreadable

Postby xircon on Sat Apr 16, 2011 7:21 am

The only difference I can see is:
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset radeon.modeset=0"
GRUB_CMDLINE_LINUX="vga=792" <<<<<<< I thought this was deprecated?  Might be an AMD thing?


I have an ATI/AMD card, which would explain the first line.

Try:

Adding nomodeset after quiet

Adding the "vga=792"

Or http://ubuntuforums.org/showthread.php?t=1341868

Code: Select all
GRUB_CMDLINE_LINUX="gfxpayload=1024x768x24,1024x768 splash"


Other than that I am stumped
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: grub page unreadable

Postby nalsdixit on Sun Apr 17, 2011 7:28 am

how do i go about adding that ?

i can just about copy paste something to the terminal, but not much more

tks

nals
nalsdixit
Level 3
Level 3
 
Posts: 100
Joined: Mon Sep 14, 2009 11:38 am

Re: grub page unreadable

Postby AlbertP on Sun Apr 17, 2011 7:47 am

xircon: That line is not deprecated. It is used if your driver does not have KMS (Kernel ModeSetting) and the proprietary drivers of both ATI and NVidia don't use KMS.
Last edited by AlbertP on Fri Apr 22, 2011 3:51 am, edited 1 time in total.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6501
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: grub page unreadable

Postby xircon on Sun Apr 17, 2011 8:02 am

nalsdixit wrote:how do i go about adding that ?

i can just about copy paste something to the terminal, but not much more

tks

nals


What is your video card?

Press alt-f2 (or in a terminal):
Code: Select all
sudo gedit /etc/default/grub


If sudo is not set up:
Code: Select all
su (enter password then press enter)
gedit /etc/default/grub


@AlbertP - thanks, didn't know that.

Steve
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: grub page unreadable

Postby nalsdixit on Fri Apr 22, 2011 2:59 am

hi xircon

this is what i got when i pasted it in the terminal:


[sudo] password for nals:
/usr/share/themes/Shiki-Wise/gtk-2.0/gtkrc:126: Murrine configuration option "gradients" is no longer supported and will be ignored.

(gedit:16195): Gtk-WARNING **: Unable to rename '/root/.recently-used.xbel': No such file or directory

(gedit:16195): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.KETOUV': No such file or directory

(gedit:16195): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

-------------------
any ideas ?

tks

nals
nalsdixit
Level 3
Level 3
 
Posts: 100
Joined: Mon Sep 14, 2009 11:38 am

Re: grub page unreadable

Postby AlbertP on Fri Apr 22, 2011 3:53 am

You should not worry about this, Gedit will open fine if you have some patience. Gedit is always giving GTK warnings in the terminal.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6501
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: grub page unreadable

Postby nalsdixit on Fri Apr 22, 2011 5:42 am

thankyou, i did add the 'nomodeset' and the 'vga=792', saved, update grub, but it did not solve the problem
--------------------------

nals@nals ~ $ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"
GRUB_CMDLINE_LINUX="vga=792"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
nals@nals ~ $

any other suggestions pls ?

nals
nalsdixit
Level 3
Level 3
 
Posts: 100
Joined: Mon Sep 14, 2009 11:38 am

Re: grub page unreadable

Postby Roken on Fri Apr 22, 2011 7:43 am

You could try uninstalling and reinstalling grub - this can fix a multitude of problems with grub.

*** NOTE - DO NOT REBOOT UNTIL YOU FINISH ***

Open a terminal and type
Code: Select all
sudo apt-get remove grub-pc grub-common
sudo apt-get install grub-pc grub-common
sudo update-grub


*** OK - Finished ***

If either fails to uninstall or reinstall, do each of grub-pc and grub-common separately, (though both "removes" before you start "installs"), remove/install whichever failed 2nd. It may happen but it's only because they are installing out of sequence and so dependencies are not met in order.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: grub page unreadable

Postby AlbertP on Fri Apr 22, 2011 9:46 am

Much better:
Code: Select all
sudo apt-get install --reinstall grub-pc grub-common grub2 grub2-theme-mint
sudo update-grub
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6501
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: ( solved)grub page unreadable

Postby nalsdixit on Fri Apr 22, 2011 10:09 am

tks albert

some how it has solved itself, despite the grub page being unreadable, i hit the cursor keys, which made my computer boot up with the earlier linux kernel. however that somehow hung up my computer. when i then did a cold shut down and rebooted, the grub page showed up as per normal. as it is working fine now, i rather leave it as it is. if it acts up again, i will try the solution you suggested

tks for your help

nals
nalsdixit
Level 3
Level 3
 
Posts: 100
Joined: Mon Sep 14, 2009 11:38 am

Re: (solved)grub page unreadable

Postby sdibaja on Sun Jun 19, 2011 12:15 pm

The image (linuxmint.png) in /boot/grub/ is probably all FUBARed... mine was very light gray which made it nearly impossible to see the White characters.
Simply replace the existing image with something more to your taste...

I just found another way in this thread: viewtopic.php?f=46&t=53306&p=437084#p437084

It turns out that there is no need to resize or change the parent image other than to rename it and put it in the correct location:

First, I experimented with various images resized to the same as my original linuxmint.png (640x480) and then renamed to linuxmint.png and then copied to /boot/grub/.
That worked sweet. For grins I then tried a couple images that were of different sizes and they worked fine also, but the scale ratio make some look a bit odd.
I did NOT run update-grub
A simple image replacement does the trick!

Thanks dawgdoc!
Peter
Peter E
sdibaja
Level 2
Level 2
 
Posts: 58
Joined: Sun May 08, 2011 12:57 pm
Location: BC, Mexico

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 3 guests