Slightly (?) broken install...

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read how to get help

Slightly (?) broken install...

Postby acurrie on Wed May 11, 2011 11:43 am

I'm running a fairly new installation on LMDE on my ThinkPad. It's mostly great, but for some reason I'm unable to upgrade it from the Terminal.

Here's what I get when I run "sudo apt-get update && sudo apt-get dist-upgrade":

Code: Select all
Calculating upgrade... Failed
The following packages have unmet dependencies:
 libhsqldb-java : Depends: gij but it is not going to be installed or
                           java-gcj-compat or
                           java2-runtime
 python3 : Depends: python3.2 (>= 3.2~rc1) but it is not going to be installed
           Depends: python3-minimal (= 3.2-3) but it is not going to be installed
 tcl : Depends: tcl8.5 (>= 8.5.0-1) but it is not going to be installed
N: Ignoring file 'dropbox.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


The only things I can think of that may have inadvertently caused this are...

1. Grabbing the latest Chromium and Gwibber builds from the Sid repos, as per the instructions here.
2. Running Mint update from the GUI applet (once) before realizing that it doesn't currently work.

Is fixing this as easy as reactivating the Sid repo in "Software Sources" and hunting down these specific packages?

Thanks in advance for any insight into this...
More about me at www.andrewcurrie.ca
User avatar
acurrie
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 27, 2009 12:50 pm
Location: Toronto, Canada

Linux Mint is funded by ads and donations.
 

Re: Slightly (?) broken install...

Postby AlbertP on Wed May 11, 2011 11:53 am

I think someone at Debian hasn't sorted out the dependencies before putting this packages in Testing. You could indeed solve it by updating these packages from the Sid repo and then returning to Testing.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Slightly (?) broken install...

Postby zerozero on Wed May 11, 2011 11:56 am

yeahh you broke it :)

when you upgrade gwibber, how many dependencies did it upgraded aswell?
at least python for what i can see;

solution? you can try with aptitude, to see if it downgrades the required pks

Code: Select all
sudo aptitude update

Code: Select all
sudo aptitude full-upgrade


but i can't tell you it will work
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: Slightly (?) broken install...

Postby acurrie on Wed May 11, 2011 12:49 pm

Looks like aptitude might work:

Code: Select all
783 packages upgraded, 126 newly installed, 0 to remove and 0 not upgraded.
Need to get 330 MB/758 MB of archives. After unpacking 575 MB will be used.
The following packages have unmet dependencies:
  libsdl1.2debian: Conflicts: libsdl1.2debian-alsa but 1.2.14-6.1 is installed.
  libgfortran3: Depends: gcc-4.6-base (= 4.6.0-2) but 4.6.0-6 is installed.
  libgomp1: Depends: gcc-4.6-base (= 4.6.0-2) but 4.6.0-6 is installed.
  libgtkhtml-editor0: Depends: libgtkhtml3.14-19 (< 3.31) but 3.32.2-2 is to be installed.
  xserver-xorg-video-nv: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-core: Breaks: xserver-xorg-video-6 which is a virtual package.
  libgcc1: Depends: gcc-4.6-base (= 4.6.0-2) but 4.6.0-6 is installed.
  libdrm-nouveau1a: Conflicts: libdrm-nouveau1 but 2.4.21-1~squeeze3 is installed.
  libgtkhtml-editor-3.14-common: Conflicts: libgtkhtml-editor-common but 3.30.3-1 is installed.
  ure: Breaks: openoffice.org-core (< 1:3.3~) but 1:3.2.1-9 is installed.
  libcryptui0a: Conflicts: libcryptui0 but 2.30.1-2 is installed.
  libquadmath0: Depends: gcc-4.6-base (= 4.6.0-2) but 4.6.0-6 is installed.
  esound-clients: Depends: esound-common (= 0.2.41-8) but 0.2.41-9 is to be installed.
The following actions will resolve these dependencies:

      Remove the following packages:                       
1)      openoffice.org-base-core                           
2)      openoffice.org-core                               
3)      xserver-xorg-video-nouveau                         
4)      xserver-xorg-video-nv                             

      Keep the following packages at their current version:
5)      cpp-4.4 [4.4.5-8 (now)]                           
6)      esound-common [0.2.41-8 (now)]                     
7)      evolution [Not Installed]                         
8)      evolution-plugins [Not Installed]                 
9)      g++ [4:4.4.5-1 (now)]                             
10)     g++-4.4 [4.4.5-8 (now)]                           
11)     g++-4.5 [Not Installed]                           
12)     gcc [4:4.4.5-1 (now)]                             
13)     gcc-4.4 [4.4.5-8 (now)]                           
14)     gcc-4.4-base [4.4.5-8 (now)]                       
15)     gcc-4.5 [Not Installed]                           
16)     gnome-core [1:2.30+6 (now)]                       
17)     libcryptui0a [Not Installed]                       
18)     libdrm-nouveau1a [Not Installed]                   
19)     libesd0 [0.2.41-8 (now)]                           
20)     libevolution [Not Installed]                       
21)     libgcc1 [1:4.4.5-8 (now)]                         
22)     libgfortran3 [4.4.5-8 (now)]                       
23)     libgomp1 [4.4.5-8 (now)]                           
24)     libgtkhtml-editor-3.14-0 [Not Installed]           
25)     libgtkhtml-editor-3.14-common [Not Installed]     
26)     libgtkhtml3.14-19 [3.30.3-1 (now)]                 
27)     libquadmath0 [Not Installed]                       
28)     libsdl1.2debian [1.2.14-6.1 (now)]                 
29)     libstdc++6-4.4-dev [4.4.5-8 (now)]                 
30)     libstdc++6-4.5-dev [Not Installed]                 
31)     seahorse [2.30.1-2 (now)]                         

      Leave the following dependencies unresolved:         
32)     evolution-common recommends evolution             


Accept this solution? [Y/n/q/?] y


Like I said, it's a fairly new installation -- so if things go awry I can always nuke & reinstall. And then learn about pinning packages, I guess..

Thank you both for the replies. :)
More about me at www.andrewcurrie.ca
User avatar
acurrie
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 27, 2009 12:50 pm
Location: Toronto, Canada

Re: Slightly (?) broken install...

Postby zerozero on Wed May 11, 2011 12:57 pm

ahh are you using nvidia? because "xserver-xorg-video-nouveau
xserver-xorg-video-nv " are going to be removed! and you will end up without x after the reboot

well it's a big mess anyway :)
good luck
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: Slightly (?) broken install...

Postby acurrie on Wed May 11, 2011 1:21 pm

zerozero wrote:"xserver-xorg-video-nouveau xserver-xorg-video-nv " are going to be removed! and you will end up without x after the reboot


But not if I reinstall those packages before closing the terminal, right? It'll be a learning experience either way -- thanks for the heads-up!
More about me at www.andrewcurrie.ca
User avatar
acurrie
Level 1
Level 1
 
Posts: 8
Joined: Thu Aug 27, 2009 12:50 pm
Location: Toronto, Canada

Re: Slightly (?) broken install...

Postby zerozero on Wed May 11, 2011 1:24 pm

ohh yes it will a learning experience :lol:
but i don't think aptitude will install them again, not without wanting to remove others, i guess, and the hole will be deeper and deeper

welcome to dependencies nightmare :lol:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: Slightly (?) broken install...

Postby AlbertP on Wed May 11, 2011 2:39 pm

Welcome to the Debian :)

You do not get without X, however. You will be using Vesa. And if you don't have an NVidia card, don't worry.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 4 guests